LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 08-04-2007, 09:04 AM   #1
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Rep: Reputation: 30
Changing command line resolution. Not a bootloader problem but kernel's.


Since I recompiled my kernel and booted it, the resolution in command line is 1600x1200. Changing the vga option in lilo.conf doesn't help, it starts with the resolution given in lilo.conf but then goes over to 1600x1200. The biggest problem with it, is that after leaving X, for example with ctrl+alt+F1, I don't get the console anymore, just a black screen. I figured it had to be an option in the kernel, but I can't point it out. Any ideas?
 
Old 08-04-2007, 10:14 AM   #2
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
If you want to change something do it in

/etc/X11/xorg.conf
 
Old 08-04-2007, 03:12 PM   #3
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
I'm not really sure about this.

Here's my cleaned up xorg.conf:
Code:
Section "DRI"
        Mode 0666
EndSection

Section "ServerFlags"
        Option "AIGLX" "off"
EndSection

#Section "Extensions"
#       Option "Composite" "Enable"
#EndSection

Section "ServerLayout"
        Identifier     "SANDER's Layout"
        Screen          0       "SANDER Screen 1"       0       0
        InputDevice    "Mouse" "CorePointer"
        InputDevice    "Keyboard" "CoreKeyboard"
EndSection

Section "Files"
        FontPath     "/usr/share/fonts/TTF"
        FontPath     "/usr/share/fonts/OTF"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/75dpi/:unscaled"
        FontPath     "/usr/lib/X11/fonts/misc/"
        FontPath     "/usr/lib/X11/fonts/75dpi/:unscaled"
        FontPath     "/usr/lib/X11/fonts/100dpi/:unscaled"
        FontPath     "/usr/lib/X11/fonts/Speedo/"
        FontPath     "/usr/lib/X11/fonts/Type1/"
        FontPath     "/usr/lib/X11/fonts/TTF/"
        FontPath     "/usr/lib/X11/fonts/OTF/"
        FontPath     "/usr/lib/X11/fonts/cyrillic/"
        FontPath     "/usr/lib/X11/fonts/75dpi/"
        FontPath     "/usr/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load    "dri"
Load    "glx"
Load    "dbe"
EndSection

Section "InputDevice"
        Identifier      "Keyboard"
        Driver          "kbd"
        Option          "AutoRepeat" "500 30"
        Option          "XkbRules" "xorg"
        Option          "XkbModel" "pc101"
        Option          "XkbLayout" "ee"
EndSection

Section "InputDevice"
        Identifier      "Mouse"
        Driver          "mouse"
        Option          "Protocol" "Auto"
        Option          "Device" "/dev/input/mice"
        Option          "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
        Identifier      "NOKIA Multigraph 447Xpro"
        HorizSync       30.0 - 96.0
        VertRefresh     50.0 - 150.0
        Option          "DPMS" "true"
EndSection

Section "Device"
        Identifier      "Ati Radeon 9600SE 128MB"
        Driver          "fglrx"
        #Option         "AccelMethod" "exa"
        #VideoRam       131072
EndSection

Section "Screen"
        Identifier      "SANDER Screen 1"
        Device          "Ati Radeon 9600SE 128MB"
        Monitor         "NOKIA Multigraph 447Xpro"
        DefaultDepth    24
        SubSection "Display"
                Viewport        0 0
                Depth           24
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
Nothing here I can see can fix it. You did realise that my problem is in command line part, before X even starts?
 
Old 08-04-2007, 10:01 PM   #4
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
look at my open thread:

http://www.linuxquestions.org/questi...d.php?t=572161

I don't see any modeentry in your xorg.conf
like this
Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 138.54 1280 1320 1456 1720 1024 1025 1028 1069
Modeline "1280x1024" 128.94 1280 1352 1488 1712 1024 1025 1028 1066
Modeline "1280x1024" 119.40 1280 1356 1492 1700 1024 1025 1028 1063
Modeline "1280x1024" 108.88 1280 1360 1496 1712 1024 1025 1028 1060
Modeline "1280x960" 131.72 1280 1368 1504 1728 960 961 964 1003
.
I have no experiance with lilo maybe there is also something wrong

Paul7
 
Old 08-05-2007, 03:39 AM   #5
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
Well, I just realised I must have been mistaken. The resolution in command line might actually be 1280x1024 as given in my xorg.conf, the monitor must have got something wrong. I think the real question becomes then, how do I stop X from kicking in before the login screen (and well, outside of desktop environment)? My guess is that some kind of console framebuffer option in the kernel that I should turn off, can anyone confirm before I recompile?
 
Old 08-05-2007, 10:51 AM   #6
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 37
Check that you have framebuffer vga16 and framebuffer vesa compiled in. IIRC the vesa option should be compiled into the kernel (ie not a module)

Look in the framebuffer hardware drivers section
 
Old 08-06-2007, 02:00 AM   #7
kummiliim
Member
 
Registered: Mar 2007
Location: Tallinn, Estonia
Distribution: Slackware 12.0
Posts: 276

Original Poster
Rep: Reputation: 30
At first only VESA vas compiled in. I now did same for VGA16 but no change.

I hope I made myself clear, I want to make the command line part independant of X, using a different and smaller resolution.

Last edited by kummiliim; 08-06-2007 at 03:15 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing resolution in FC3. Which xorg.conf line do I edit? ColKurtz Linux - Newbie 2 02-18-2005 01:09 PM
Changing video resolution from command line? lhouk Linux - General 4 04-15-2004 03:16 PM
How to install Grub bootloader to MBR from command line sleddog Linux - Software 2 04-08-2004 03:17 PM
How do i set my command line resolution greendusk Linux - General 1 09-26-2003 06:14 PM
Changing Resolution of Linux command line mindfrost82 Linux - Newbie 6 07-09-2003 10:05 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration