LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 12-23-2012, 06:49 PM   #1
khhuff
LQ Newbie
 
Registered: Feb 2012
Posts: 5

Rep: Reputation: Disabled
centos 6 fails to load file system while booting


Upon rebooting I receive the error;
dracut:/ can't mount file system. This is Centos 6 on a usb live flash drive. It was working fine until I started a download. My question is how do I direct the filesystem to be loaded with the dracut shell, or does it have to be done within the actual files. This is my first attempt at fixing a kernel instead of just doing a re-install so any help would be appreciated.
Thank You
 
Old 12-23-2012, 09:49 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 13,028

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
What did you download ?

dracut normally is called if a new kernel is insalled
or
if you have a nvidia ore AMD 3d card for a new driver

centOS by default is using the nouveau driver for a nvidia card

you could boot into "single user" mode
edit the end of the kernel line in grub.conf / menu.lis
or during the 3 sec. countdown during boot up

hit the space bar to kill the 3 sec. count
Then hit "e" ( for edit )
down arrow to get to the kernel line
add a blank space and a 1 to the end of the kernel line
then enter
then "b" ( for boot )

Last edited by John VV; 12-23-2012 at 09:53 PM.
 
Old 12-24-2012, 09:55 AM   #3
khhuff
LQ Newbie
 
Registered: Feb 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
I had attempted to download metasploit for centos, and it was after the download that the problem occurred. I have tried what you posted and it still comes up with kernel panic - can't mount file system
 
Old 12-24-2012, 10:21 AM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 13,028

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
What exact commands / procedure did you do ?

was it the *.run ( 32 bit or 64 bit) from the web site ?
http://www.metasploit.com/download/

or the SVN source pull
Code:
svn ls https://www.metasploit.com/svn/framework3/trunk/
were you fallowing some guide?
if so please past a link

something like this ?
https://community.rapid7.com/docs/DOC-1293/version/6
or the install guide?
https://community.rapid7.com/docs/DOC-2100

Last edited by John VV; 12-24-2012 at 10:26 AM.
 
Old 12-24-2012, 10:42 AM   #5
khhuff
LQ Newbie
 
Registered: Feb 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
I was downloading from this link: http://www.metasploit.com/download/.

I just clicked on 32-bit and it downloaded, but I could not open it to install, and after that I could not open up the computer files from the desktop, nor any web browsers, that is why I did a restart and then encountered the kernel panic. All I could find out to do was edit the boot options with rdshell, but from there I am stuck trying to direct the file system to be loaded.
 
Old 12-24-2012, 12:05 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 13,028

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
so you did download the .run
that is an executable file
You do not "open" it

so what exactly did you do with the .run ?

you normally run the ".run" program
it is a type of installer

so the 32 bit ?
i take it that this is a old computer that is using a 32 bit hardware
metasploit-latest-linux-installer.run
you dl it
open a terminal
Code:
su -
cd / to/the/location/you/saved/the/file 
chmod +x metasploit-latest-linux-installer.run
sh metasploit-latest-linux-installer.run
Fallow the instructions in the "Linux_InstallationGuide.pdf"
the full install instructions are in the pdf -- i am looking at it as i type

cent like RHEL dose not use"sudo" by default
use "su" or " su -"
or set up sudo ( disabled by default)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
after MATE 1.4.2 upgrade my system fails booting fabiox Linux Mint 1 11-09-2012 09:33 AM
[SOLVED] Dualboot (VM) CentOS 6.2 + Archlinux system hangs after GRUB menu when booting Arch Novalight Linux - Newbie 5 07-02-2012 10:43 PM
[SOLVED] CentOS fails to finish booting brother.gabriel Linux - Server 5 05-21-2012 11:23 AM
How to load a firmware file in CentOS with udev / hotplug? ptemmerman Linux - Newbie 3 05-06-2009 02:56 PM
System hangs on boot - "Mounting root file system" fails with Via VT6410 enabled Eagleorn Linux - Hardware 3 09-21-2006 12:58 PM


All times are GMT -5. The time now is 04:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration