LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 01-16-2013, 06:44 AM   #1
tony paul
LQ Newbie
 
Registered: Jan 2013
Posts: 2

Rep: Reputation: Disabled
'Kernel too old message' when booting a newly compiled kernel


I was trying to install kernel 2.6.25 on fedora 14(2.6.35.6-45.fc14.i686).
But it is giving the following error at step 'make install'

ERROR: modinfo: could not find module mperf
ERROR: modinfo: could not find module snd_hda_codec_realtek
ERROR: modinfo: could not find module snd_hda_codec
ERROR: modinfo: could not find module drm_kms_helper

However the following files are created under /boot

initramfs-2.6.25.img
vmlinuz-2.6.25
System.map-2.6.25

also /boot/grub/grub.conf and /boot/grub/menu.lst are updated properly.
but when i tried to boot the kernel 2.6.25 it is showing the following error and hanging

"FATAL:kernel too old
[0.897645] Kernel panic-not syncing:Attempted to kill init "

What will be the reason for this problem?

I built the kernel with glibc version-2.12.90, gcc version 4.5.1, binutils version 2.20.51.

Is it caused by the tools i used for compiling the 2.6.25 kernel ?
 
Old 01-16-2013, 02:06 PM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: Fedora
Posts: 1,537

Rep: Reputation: 375Reputation: 375Reputation: 375Reputation: 375
2.6.25 is circa 2008. Many changes have been made since then. The last 2.6 kernel was 2.6.35 and the latest stable release is 3.7.2. Maybe you have an EFI BIOS? Do you know that 2.6.25 supports your current hardware?
 
Old 01-24-2013, 05:38 AM   #3
tony paul
LQ Newbie
 
Registered: Jan 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thumbs up

I think it was the problem of using newer version of build tools for building a relatively old kernel.
I installed fedora 8 in the same machine and was able to successfully compile, install and boot 2.6.19 kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting into a newly compiled kernel in ubuntu ajitht1986 Linux - Desktop 2 03-16-2011 12:54 AM
[SOLVED] booting a newly compiled kernel error :"invalid or unsupported executable format" shivanth Linux - Kernel 1 09-16-2009 06:57 AM
kernel panic - mkrootdev: label /1 not found - when booting from newly compiled kerne the_shani Red Hat 7 05-21-2009 06:27 AM
Kernel Panic while booting with a newly compiled kernel coolkrish Linux - Newbie 1 06-04-2008 06:22 AM
Newly compiled kernel gets error message morphir Linux - Kernel 3 07-19-2006 12:34 PM


All times are GMT -5. The time now is 09:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration