LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-10-2011, 02:31 AM   #1
anassb
LQ Newbie
 
Registered: Dec 2010
Posts: 2

Rep: Reputation: 0
zte ax225 problem


i just boght zte ax225 wimax modem i`v tried usb_modeswitch and U3-MuM with no luck

can you please help me to get it work ...please

# lsusb

Code:
bash-3.1# lsusb
Bus 001 Device 008: ID 19d2:0044 ONDA Communication S.p.A. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 1bcf:0007 Sunplus Innovation Technology Inc.
# dmesg

Code:
usb 1-7: new high speed USB device using ehci_hcd and address 4
usb 1-7: New USB device found, idVendor=19d2, idProduct=0044
usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-7: Product: ZTE?Mobile?WiMAX?USB?Adap???
usb 1-7: Manufacturer: ZTE?Corporation
usb 1-7: SerialNumber: 0
usb 1-7: configuration #1 chosen from 1 choice
usb 1-7: USB disconnect, address 4
usb 1-7: new high speed USB device using ehci_hcd and address 5
usb 1-7: New USB device found, idVendor=19d2, idProduct=0065
usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-7: Product: USB DISK
usb 1-7: Manufacturer: ZTE Corporation
usb 1-7: SerialNumber: AA04012700009085
usb 1-7: configuration #1 chosen from 1 choice
scsi5 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
scsi 5:0:0:0: CD-ROM            ZTE      CD Less          1100 PQ: 0 ANSI: 2
sr1: scsi3-mmc drive: 0x/0x caddy
sr 5:0:0:0: Attached scsi CD-ROM sr1
sr 5:0:0:0: Attached scsi generic sg2 type 5
usb-storage: device scan complete
usb 1-7: USB disconnect, address 5
usb 1-7: new high speed USB device using ehci_hcd and address 6
usb 1-7: New USB device found, idVendor=19d2, idProduct=0044
usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-7: Product: ZTE?Mobile?WiMAX?USB?Adap???
usb 1-7: Manufacturer: ZTE?Corporation
usb 1-7: SerialNumber: 0
usb 1-7: configuration #1 chosen from 1 choice
usb 1-7: USB disconnect, address 6
usb 1-7: new high speed USB device using ehci_hcd and address 7
usb 1-7: New USB device found, idVendor=19d2, idProduct=0065
usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-7: Product: USB DISK
usb 1-7: Manufacturer: ZTE Corporation
usb 1-7: SerialNumber: AA04012700009085
usb 1-7: configuration #1 chosen from 1 choice
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 7
usb-storage: waiting for device to settle before scanning
scsi 6:0:0:0: CD-ROM            ZTE      CD Less          1100 PQ: 0 ANSI: 2
sr1: scsi3-mmc drive: 0x/0x caddy
sr 6:0:0:0: Attached scsi CD-ROM sr1
sr 6:0:0:0: Attached scsi generic sg2 type 5
usb-storage: device scan complete
usb 1-7: USB disconnect, address 7
usb 1-7: new high speed USB device using ehci_hcd and address 8
usb 1-7: New USB device found, idVendor=19d2, idProduct=0044
usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-7: Product: ZTE?Mobile?WiMAX?USB?Adap???
usb 1-7: Manufacturer: ZTE?Corporation
usb 1-7: SerialNumber: 0
usb 1-7: configuration #1 chosen from 1 choice
# /usr/sbin/usb_modeswitch -I -W -c

Code:
bash-3.1# /usr/sbin/usb_modeswitch -I -W -c /etc/usb_modeswitch.d/19d2:0044
Reading config file: /etc/usb_modeswitch.d/19d2:0044
 * usb_modeswitch: handle USB devices with multiple modes
 * Version 1.1.5 (C) Josua Dietze 2010
 * Based on libusb0 (0.1.12 and above)

 ! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor=  0x19d2
DefaultProduct= 0x0044
TargetVendor=   0x19d2
TargetProduct=  0x0065
TargetClass=    not set
TargetProductList=""

DetachStorageOnly=0
HuaweiMode=0
SierraMode=0
SonyMode=0
GCTMode=0
KobilMode=0
MessageEndpoint=0x7fffffff
MessageContent=""
NeedResponse=0
ResponseEndpoint= not set
Interface=0x00

InquireDevice disabled
Success check enabled, max. wait time 20 seconds
System integration mode disabled

usb_set_debug: Setting debugging level to 15 (on)
usb_os_find_busses: Found 001
usb_os_find_busses: Found 004
usb_os_find_busses: Found 002
usb_os_find_busses: Found 003
usb_os_find_busses: Found 005
usb_os_find_devices: Found 008 on 001
usb_os_find_devices: Found 001 on 001
error obtaining child information: Inappropriate ioctl for device
usb_os_find_devices: Found 001 on 004
usb_os_find_devices: Found 001 on 002
usb_os_find_devices: Found 001 on 003
usb_os_find_devices: Found 001 on 005
usb_os_find_devices: Found 002 on 005
skipped 1 class/vendor specific interface descriptors
error obtaining child information: Inappropriate ioctl for device

Looking for target devices ...
  searching devices, found USB ID 19d2:0044
   found matching vendor ID
  searching devices, found USB ID 1d6b:0002
  searching devices, found USB ID 1d6b:0001
  searching devices, found USB ID 1d6b:0001
  searching devices, found USB ID 1d6b:0001
  searching devices, found USB ID 1d6b:0001
  searching devices, found USB ID 1bcf:0007
 No devices in target mode or class found
Looking for default devices ...
  searching devices, found USB ID 19d2:0044
   found matching vendor ID
   found matching product ID
   adding device
  searching devices, found USB ID 1d6b:0002
  searching devices, found USB ID 1d6b:0001
  searching devices, found USB ID 1d6b:0001
  searching devices, found USB ID 1d6b:0001
  searching devices, found USB ID 1d6b:0001
  searching devices, found USB ID 1bcf:0007
 Found devices in default mode or class (1)
Accessing device 008 on bus 001 ...
Getting the current device configuration ...
 OK, got current device configuration (1)

USB description data (for identification)
-------------------------
Manufacturer: ZTE?Corporation
     Product: ZTE?Mobile?WiMAX?USB?Adap???
  Serial No.: 0
-------------------------
Warning: no switching method given.

Checking for mode switch (max. 20 times, once per second) ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Waiting for original device to vanish ...
 Original device still present after the timeout

Mode switch most likely failed. Bye.
thank you ...
 
Old 01-15-2011, 03:55 PM   #2
anassb
LQ Newbie
 
Registered: Dec 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Angry anyone

wow nobody can answer my question .
 
Old 06-11-2011, 06:46 PM   #3
J_Rey
LQ Newbie
 
Registered: Jul 2006
Location: NW Florida, USA
Distribution: Debian, Puppy
Posts: 9

Rep: Reputation: 1
I believe that this device might have a Beceem chipset & if so then there probably are Linux drivers available for it. It might take some work but see http://goo.gl/jRnEJ for a good start.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
reliance zte mg880 data modem problem khirodpatra Linux - Newbie 1 12-06-2009 10:21 AM
zte fm 626 connection to the internt problem eslam Linux - Networking 0 09-11-2009 03:00 AM
Problem with usb pendrive and usb modem ZTE ZXDSL 852 AM33N Linux - Hardware 3 12-10-2008 03:25 AM
Fedora 9 Connecting Problem with Reliance ZTE MG880 and Huawei EC325 modems eCubeH Fedora 7 09-10-2008 10:24 PM
Zte Mf600 IvanHow79 Linux - Hardware 0 09-27-2007 10:24 AM


All times are GMT -5. The time now is 06:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration