LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-23-2012, 10:47 AM   #1
farna
Member
 
Registered: Nov 2008
Location: Batesburg-Leesville, SC
Distribution: Mint
Posts: 37

Rep: Reputation: 0
Zonet ZPS1000 Printer Server - anyone get one to work?


I bought a Zonet ZPS1000 USB/Network print server about a year ago because it specifically said Linux compatible on the box. Right... Now I'm trying to get it to work! It's supposed to be set up from a browser, with a default IP address of 192.168.5.1. I can ping that address, but it won't come up on Firefox. I'm using Mint 12 (Ubuntu 11.10 based). I'm relatively new to Linux, not real familiar with the command line but can use it. I used "Network Tools" to ping the ZPS1000. I've discovered that Zonet went out of business, so no help there! The manual that comes with it and everything I find on the Internet is for Windows or Mac, nothing on Linux. The printer (HP2605) works fine plugged into the USB port of my computer, and I can access the printer from other computers on my network -- when that computer is on. I want to get away from having my computer on and a USB cable strung across my office floor to print from another location. I have the server plugged into a dumb five port network switch with my computer plugged directly into the same switch.

If there is no help getting this thing to work, does anyone have any experience with any small USB/Network print server that WILL easily work with Linux? This is the second one I've bought and had no luck with. Other one was a different brand, I forget what it was.
 
Old 11-23-2012, 12:04 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,808

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
From the little information I can find on the web the print server supports IPP and netbios protocols. Are you sure you configured the IP addresses and netmasks for your printer / network correctly?

With the printer plugged into the server post the output of the command
smbclient -L server.ip.address

Hopefully this will output some kind of printer netbios name so you can use a SMB URL like:
smb://ip.address.server/printer (or whatever it shows in the output above)

For IPP just try
ipp://ip.address.server/lp1
 
Old 11-24-2012, 10:47 AM   #3
farna
Member
 
Registered: Nov 2008
Location: Batesburg-Leesville, SC
Distribution: Mint
Posts: 37

Original Poster
Rep: Reputation: 0
Hmm... so what you're saying is I need to install another printer with the address "ipp://ip.address.server/lp1" and it should work?

This is what I got:
frank2@frank2 ~ $ smbclient -L 192.168.5.1
Enter frank2's password:
Connection to 192.168.5.1 failed (Error NT_STATUS_UNSUCCESSFUL)
frank2@frank2 ~ $

But I can still ping the address, so I know I have the address right:
frank2@frank2 ~ $ ping 192.168.5.1
PING 192.168.5.1 (192.168.5.1) 56(84) bytes of data.
64 bytes from 192.168.5.1: icmp_req=1 ttl=250 time=12.1 ms
64 bytes from 192.168.5.1: icmp_req=2 ttl=250 time=25.7 ms
64 bytes from 192.168.5.1: icmp_req=3 ttl=250 time=20.2 ms
64 bytes from 192.168.5.1: icmp_req=4 ttl=250 time=9.93 ms
etc.

I haven't changed anything in my network configuration. Have no idea what I'd need to change!

I used "network tools" (Ubuntu) and "lookup" reports
Name - 168.192.in-addr.arpa
TTL - 300
Address Type - IN
Record Type - SOA
Address - prisoner.iana.org. hostmaster.root-servers.org. 2002040800 1800 900 604800 604800

Have no idea what any of that really means or if any of it helps...

Last edited by farna; 11-24-2012 at 10:53 AM. Reason: added lookup info
 
Old 11-24-2012, 11:03 AM   #4
farna
Member
 
Registered: Nov 2008
Location: Batesburg-Leesville, SC
Distribution: Mint
Posts: 37

Original Poster
Rep: Reputation: 0
Well, I tried using the Ubuntu install printer feature and that failed. I chose "install network printer" and "IPP printer". I installed it at address ipp://192.168.5.1/lp1, and installed the proper driver. Tried printing a test page, and "printer state" returns "Processing - Network host '192.168.5.1' is busy; will retry in 30 seconds..." in a loop.

When I look at the "Document Print Status" status is reported as "Processing - Not Connected?"

I changed the printer address to ipp://192.168.5.1 and get the same results.

In the "Printer Properties" box it reports "Idle - Network host '192.168.5.1' is busy; will retry in 30 seconds" even when nothing is being sent to the printer. I changed the address back to "ipp://192.168.5.1/lp1" and get the exact same message.

Last edited by farna; 11-24-2012 at 11:08 AM.
 
Old 11-24-2012, 11:14 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,808

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
If you did not change any network settings then is your network LAN 192.168.5.xxx? How is your LAN configured. Post the output of the ifconfig command.

192.168.0.0 - 192.168.255.255 defines a block of private IP addresses. You might be pinging another device other then the server.
 
Old 11-25-2012, 06:23 PM   #6
farna
Member
 
Registered: Nov 2008
Location: Batesburg-Leesville, SC
Distribution: Mint
Posts: 37

Original Poster
Rep: Reputation: 0
I bet it has something to do with the LAN configuration....
The LAN starts at my dad's house where we have a wireless router w/5 ports. This is the main router and is configured to handle giving out IP addresses. It automatically gets an IP from our ISP. He has one computer connected all the time, and has the wireless active for occasional use with a laptop. From there an underground line connects to a dumb 5 port switch in my house. Two computers and my smart DVD connected there, along with a wireless router configured as an access point only for occasional laptop/Ipad use. Another underground cable goes out to my shop office where there is another dumb 5 ports switch. That has my main computer, the printer server, and another computer station I use for working on computers attached to it.

Requested output:
frank2@frank2 ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr 00:30:67:64:2d:77
inet addr:192.168.1.18 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::230:67ff:fe64:2d77/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9092 errors:0 dropped:0 overruns:0 frame:0
TX packets:9193 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8492030 (8.4 MB) TX bytes:2312440 (2.3 MB)
Interrupt:43 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)


I'm pretty sure I'm pingin the print server. When plugged in it is obviously strobing the switch -- the port light flashes. There should be nothing else on the LAN with that address... but it is possible.

Last edited by farna; 11-25-2012 at 06:34 PM. Reason: added info
 
Old 11-25-2012, 07:50 PM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,808

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
Unplug the server and see if you can still ping its address.
 
Old 11-26-2012, 06:51 PM   #8
farna
Member
 
Registered: Nov 2008
Location: Batesburg-Leesville, SC
Distribution: Mint
Posts: 37

Original Poster
Rep: Reputation: 0
DARN!! Yes, I can still ping 192.168.5.1.... So how the heck do I figure out what the server address is? The manual that came with it is useless, unless I install it on my Windows box. I can plug that into my shop hub and use the CD that came with it to configure if necessary. Guess I might have to try that. Once configured my Linux box should be able to find it and print to it, correct?

Last edited by farna; 11-26-2012 at 06:53 PM.
 
Old 11-26-2012, 07:03 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,808

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
You will need to change the IP address of the server by connecting it direct to a computer. Most network adapters these days are auto detect so a cross over cable should not be necessary. If neither laptop or server LED link lights are illuminated then a cross over cable is required. You can change the computers IP address temporarily if the ifconfig command. (sudo ifconfig 192.168.5.2 netmask 255.255.255.0 up )

You should now be able to connect to the servers web configuration page. Change the IP address to an address in your LAN not in the DHCP range. You can look at your routers config page for the numbers. (192.168.1.x). Save it and reset power to the server to make sure the numbers stick. You can not connect the computer and server back into the network. Reset your computer back to its original IP address. You should be able to connect to the server on its new IP address.
 
Old 11-27-2012, 11:26 AM   #10
farna
Member
 
Registered: Nov 2008
Location: Batesburg-Leesville, SC
Distribution: Mint
Posts: 37

Original Poster
Rep: Reputation: 0
I've got some other work that is taking priority for about a week, will get back on this as soon as I can. Thanks a lot for the help!
 
Old 11-27-2012, 01:42 PM   #11
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,808

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
Quote:
Once configured my Linux box should be able to find it and print to it, correct?
No actual experience but from the information I found it should work with linux.

Last edited by michaelk; 11-27-2012 at 01:44 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Printer HP Laserjet P1007 does not work on Windows server on Fedora 7 NARESHAGGARWAL Fedora 2 04-17-2009 03:29 AM
My printer won't work in Linux. Can I install Windows in a VM to use my printer? Caboose79 Linux - Hardware 5 07-14-2008 11:05 AM
printer modules not loaded; parallel printer doesn't work blinux1 Linux - Newbie 7 06-24-2004 09:59 PM
Zonet CF LAN and Zaurus Slebine Linux - Laptop and Netbook 4 06-10-2004 11:10 PM
Zonet ZEW 1000 on Mandrake MattLaw Linux - Hardware 5 01-12-2004 11:56 AM


All times are GMT -5. The time now is 05:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration