LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-26-2008, 09:05 PM   #1
harikrishnan81
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Rep: Reputation: 0
Question Your BIOS doesn't leave a aperture memory hole


Hi all ,
I am getting an error in one of my server m/c with Phoenix motherboard ,AMD processor with 16GB RAM.The error message is

"CPU 0: aperture @ 0 size 32 MB
No AGP bridge found
Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM "

Is this a bios problem or an os bug?The os is Red Hat Enterprise Linux ES release 4 (Nahant)(64Bit).

Can anyone help me to solve this error?
Thanks in advance
Regards,
Hari
 
Old 02-26-2008, 10:25 PM   #2
harikrishnan81
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Hi All,

Can i Solve this problem by using the boot option "iommu=memapper=3"
I saw this optin in a forum but this server is an importent m/c in our enviornment and i cant experiment on this.
Please help me to solve this if any one of you faced such a problem.
Thnaks and regard,
Hari
 
Old 02-27-2008, 11:50 AM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Have you tried doing what it says:

Quote:
Please enable the IOMMU option in the BIOS setup
 
Old 04-23-2008, 02:48 PM   #4
SuperSparky
LQ Newbie
 
Registered: Apr 2008
Location: San Diego, California
Distribution: Ubuntu
Posts: 11

Rep: Reputation: 2
Quote:
Originally Posted by H_TeXMeX_H View Post
Have you tried doing what it says:
And people wonder why Linux isn't more mainstream with people like this to "help" you.

I get the same error, and I don't have an AGP machine (this is a GART error). My system is a PCIExpress system with two PCIE x16 slots. There is no IOMMU setting in the BIOS, nor any "aperture" setting. This aperture is just an AGP need.

Oddly enough, when looking at DMESG, it says it can't find an AGP bridge, but despite that, it decides to act as if there is one there. The problem isn't BIOS settings. The problem appears to be a poorly written kernel module not smart enough to realize that when there is no AGP hardware it shouldn't try to allocate resources for one.

How about a competent reply this time?

Quote:
Checking aperture...
CPU 0: aperture @ eb40000000 size 32 MB
Aperture too small (32 MB)
No AGP bridge found
Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
Mapping aperture over 65536 KB of RAM @ c000000
 
0 members found this post helpful.
Old 04-23-2008, 08:33 PM   #5
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
If you don't have it and you don't need it ... why don't you disable it in kernel configuration!?
 
Old 04-23-2008, 08:55 PM   #6
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Quote:
Originally Posted by SuperSparky View Post
And people wonder why Linux isn't more mainstream with people like this to "help" you.

...

How about a competent reply this time?
As a fairly active particiant in the forum, I'd like to say, I think you're taking this comment out of context. I see a large number of posts where an error message pretty clearly states an error and proposed solution and the poster gives no indication of whether or not (s)he has followed the advice or not.


I wouldn't take the comment posted as insulting or frivolous, merely a valid question to ask before spending more time on the problem. More an issue of style than anything.

Consider sitting down face to face with the OP showing you that message on screen. Would your first question be what was asked? A lot of people would say yes.


My 2c
 
Old 04-23-2008, 09:21 PM   #7
sumit dash
Member
 
Registered: Jul 2007
Location: Hyderabad
Distribution: Red Hat
Posts: 33

Rep: Reputation: 15
hi

Hi friend,
Its not a OS bug you have to update ur BIOS information, serch the compatible bios information from internet and update ur BIOS u r operating system would work fine.

Thank you
sumit
 
Old 04-24-2008, 03:21 AM   #8
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Quote:
Originally Posted by SuperSparky View Post
And people wonder why Linux isn't more mainstream with people like this to "help" you.

How about a competent reply this time?
Normally, I would not even reply to such a post.

If you were to search a bit on google you'd see that this usually happens when you have more than 4GB of RAM.

Read about IOMMU here:
http://en.wikipedia.org/wiki/IOMMU

Here's a good post on it in a mailing list describing the problem and solution:
http://www.x86-64.org/pipermail/disc...er/006680.html

note that both of the suggestions on there have been posted in this thread, one by harikrishnan81 and one by me. If you didn't know there actually is an IOMMU option in most new BIOSes.

I assure you that the kernel devs are much smarter than you and know much more than you on this subject, so don't say things like:

Quote:
Originally Posted by SuperSparky View Post
The problem isn't BIOS settings. The problem appears to be a poorly written kernel module not smart enough to realize that when there is no AGP hardware it shouldn't try to allocate resources for one.
unless you have proof or know what you are talking about.
 
Old 04-25-2008, 12:41 AM   #9
harikrishnan81
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Hi All,
Sorry for the late replay.I was on leave due to some personal problems and due to that i couldnt check the repalys.
Thanks for the help.

In BIOS settings i couldn't find any IOMMU option.
Insted i tried with RHEL4.6 and its working fine.

Regards,
Hari
 
Old 04-25-2008, 12:43 AM   #10
harikrishnan81
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Thakyou all for spending your valuable time to help me.
 
Old 04-25-2008, 02:25 PM   #11
SuperSparky
LQ Newbie
 
Registered: Apr 2008
Location: San Diego, California
Distribution: Ubuntu
Posts: 11

Rep: Reputation: 2
Quote:
Originally Posted by H_TeXMeX_H View Post
Normally, I would not even reply to such a post.

If you were to search a bit on google you'd see that this usually happens when you have more than 4GB of RAM.

Read about IOMMU here:
http://en.wikipedia.org/wiki/IOMMU

Here's a good post on it in a mailing list describing the problem and solution:
http://www.x86-64.org/pipermail/disc...er/006680.html

note that both of the suggestions on there have been posted in this thread, one by harikrishnan81 and one by me. If you didn't know there actually is an IOMMU option in most new BIOSes.

I assure you that the kernel devs are much smarter than you and know much more than you on this subject, so don't say things like:



unless you have proof or know what you are talking about.
Oddly enough, my search on Google showed this thread. Hmmm....

Since this only started happening with recent versions of the Fedora version of the Kernel, a "solution" from 2005 didn't seem to apply.

Also, had you actually read my response as you seem to be indicating I do about posts spread all over the Internet, you would have noticed that I said no such settings are possible in my BIOS, and similar posts by people on other sites on the Internet seem to say the same thing, which is the purpose for the post in the first place. Why post a message about a Kernel issue giving instructions on how to fix it, unless the indicated "solution" is not possible? Your complaint about my "nasty" post doesn't make any sense.

It seemed quite obvious to me that "Why don't you do what it says" was the uncalled-for response to an obvious indication that the "solution" or the ability to "do what it says" was not possible in the case of the post.

Instead of assuming everyone that posts a problem is an idiot or is required to "RTFM", how about assuming they have already attempted the obvious and are requesting other means? That was my complaint about the "passive-aggressive" nature of the short and useless original response.

To complain about the detailed correction of another having the same or similar issues seems to also be quite elitist.

I have an ASUS M2N32 SLI-Deluxe Vista Edition motherboard with a PCIExpress and PCI (NVidia) chipset. Yes, it does have 4 Gigs of RAM. Also, in its BIOS, there is no aperture or IOMMU setting (the manual is available for download). That was the first thing I happened to look for when I saw the error message. Having not found it and then looking on Google and only seeing responses such as "Do what it says" and no other solutions, since doing what it says was not possible, I did find that all of these various posts mentioned the AGP port as being the cause for the need of an aperture for IODMA in large memory environments outside the 32 bit memory footprint of AGP. Having no AGP port, it is natural to assume this need for an aperture is not necessary in a PCIExpress system, although my assumptions could be wrong, they were not founded on a whim.

So, to summarize:
  1. The solution given by the kernel itself is not possible on my BIOS
  2. I used Google to research the problem, and no real solutions were found, only responses saying to do what the error message says. This is sort of a catch-22 situation.
  3. Reading between the lines, I found it was related to the AGP subsystem and large RAM footprints.
  4. Still, as of yet, no indication as to WHY the error is happening on a non-AGP system without an aperture or IOMMU setting in the BIOS, and no (physically possible) solutions have been offered.
  5. Assuming the programming of a Kernel module is coded incorrectly, is not unfounded especially since the "solution" is not possible on all systems, and the subsystem involved in the error doesn't seem to relate to the type of system it is running on. If I am wrong in this assumption, then I apologize, but clearly the "solution" needs to be something possible on all types of systems.
  6. Finally, given all this, no solution in my situation has been offered. I'd be happy to try whatever is possible, but the BIOS setting approach isn't possible (at least not as given).
 
Old 04-25-2008, 02:56 PM   #12
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Quote:
Originally Posted by SuperSparky View Post
Since this only started happening with recent versions of the Fedora version of the Kernel, a "solution" from 2005 didn't seem to apply.
Well, there's your problem, the fedora kernel. Try compiling your own vanilla kernel, it'll probably solve it.
 
Old 05-18-2008, 01:21 PM   #13
revof11
Member
 
Registered: Nov 2003
Location: Macungie, PA
Distribution: Fedora Core 9, Gentoo 2008.0
Posts: 108

Rep: Reputation: 15
I know it's a little late, but I can successfully boot adding the iommu=noagp kernel parameter. I still get the error messages, but I can at least boot.
 
Old 05-18-2008, 11:37 PM   #14
SuperSparky
LQ Newbie
 
Registered: Apr 2008
Location: San Diego, California
Distribution: Ubuntu
Posts: 11

Rep: Reputation: 2
Can you prove the Fedora Kernal was the problem, or was condescending Slackware evangelism clouding your judgement?


Quote:
Originally Posted by H_TeXMeX_H View Post
Well, there's your problem, the fedora kernel. Try compiling your own vanilla kernel, it'll probably solve it.
 
Old 05-19-2008, 05:11 AM   #15
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I can't prove it, because I don't run Fedora, but when I did, most of the problems came from the crappy kernel they use, probably because the patch the crap out of it. It could also be just a kernel bug, but typically compiling a kernel myself fixed the problem that I had, so I'm thinking it's Fedora's kernel. You can prove it, not me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are PHP session variables held in memory when you leave a PHP site? Locura Programming 11 11-16-2008 08:37 PM
request_mem_region kernel function and 15-16M memory hole trifola Linux - Kernel 0 01-04-2008 02:16 AM
Asus K8N-DL no memory hole --> no boot! Basileus Romaion Linux - Hardware 2 07-04-2007 11:49 AM
FC5, the memory black hole seimour Fedora 3 04-17-2006 04:30 PM
Memory hole/leak in RH9? mrogers Linux - Newbie 2 09-23-2003 08:07 PM


All times are GMT -5. The time now is 05:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration