LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 12-29-2003, 10:09 AM   #1
blaisepascal
LQ Newbie
 
Registered: Jun 2002
Distribution: Red Hat Linux 9
Posts: 27

Rep: Reputation: 15
Yes, I Want ALSA With My (sound) Chips :D (RH9)


I have a devil of time getting my ALSA mixer settings to be saved on reboot. First, here's the relevant hardware:

Pentium 4 3.2ghz
i875P-based Motherboard
Onboard sound: AD1980, though ALSA identifies it as an "intel8x0"

What I did:

I did a stock Red Hat install (Workstation). Now, this gives me 2 kernels, 2.4.20-6 and 2.4.20-6smp, so I removed the uniproc kernel. I also added the kernel-source. Then I ftp'ed to updates.redhat.com and grabbed the up2date rpms (because I can't use the stock up2date with the SSL certificates being expired). I up2date everything; I also up2dated the kernel and the source to 2.4.20-27.9.

Then I went to shrike.freshrpms.net, since I still have RH9 and not FC1. Unfortunately, among the ALSA rpm's, there isn't one for my kernel. So I got the alsa-driver source rpm and rebuilt it for my kernel:
Code:
rpmbuild --rebuild --target i686 --define 'kernel 2.4.20-27.9smp'
It spitted out an alsa-driver rpm and a kernel-modules-alsa rpm. So far so good. I went back to freshrpms.net and got the alsa-lib and the alsa-util rpms. I followed the directions to the letter at the freshrpms.net website.

As I said, the problem is that the mixer settings aren't being saved on shutdown/reboot. Here's the contents of my modules.conf:
Code:
alias eth0 e1000
alias usb-controller ehci-hcd
alias usb-controller1 usb-uhci

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-intel8x0
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

post-install snd-card-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
pre-remove snd-card-0 /usr/sbin/alsactl store >/dev/null 2>&1 || :
I will mention that the first time I rebooted, I noticed that something added two more lines to the modules.conf file. They resembled the post-install/pre-remove lines mentioned above, but both referenced an /etc/.aumixrc file. I removed those lines, but kept the lines that reference the alsactl script.

After a reboot, I would see that the settings weren't saved. But if I manually ran "alsactl restore" in Terminal, the settings get restored. Sound in general seems to be working. I only tested playing a music CD and playing an mp3 (via xmms, it's mp3 plugin, and it's alsa plugin).

I should also mention that alsamixer gives much more options than aumix. One of the more important ones is "Surround". If "Surround" is muted, there is no sound.

Another curious thing is the following from /var/log/messages:
Code:
Dec 29 15:10:55 localhost modprobe: modprobe: Can't locate module snd-card-1
Dec 29 15:10:55 localhost modprobe: modprobe: Can't locate module snd-card-1
Dec 29 15:10:55 localhost modprobe: modprobe: Can't locate module snd-card-2
Dec 29 15:10:55 localhost modprobe: modprobe: Can't locate module snd-card-2
Dec 29 15:10:55 localhost modprobe: modprobe: Can't locate module snd-card-3
Dec 29 15:10:55 localhost modprobe: modprobe: Can't locate module snd-card-3
This occured on looks like every startup since ALSA was installed. Why is modprobe looking for snd-card-1, 2 & 3? I see no mention of it under modules.conf (only snd-card-0). Is there any other file that Red Hat is looking at?

So that's my puzzle. Any help appreciated.


BP

001B
 
Old 12-29-2003, 03:06 PM   #2
Z@pp Shenanigan
LQ Newbie
 
Registered: Dec 2003
Location: Central Coast, NSW, Australia
Distribution: Slackware 9.1
Posts: 11

Rep: Reputation: 0
have you got alsasound starting at boot?

there is an alsasound script in /etc/rc.d/init.d/alsasound that you may need to add to your boot by:
/sbin/chkconfig --add /etc/rc.d/init.d/alsasound

this loads the alsasound script at startup

i did this and my mixer settings are restored at startup though am not sure if it is the alsasound script that does this. try it and see, if you already have alsasound starting i have no other ideas.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onboard Sound on A PC Chips MotherBoard NewToLinux2005 Linux - Hardware 3 02-04-2005 04:16 PM
Are sound chips capable of multiple sound streams? SGFHK321 Linux - Hardware 1 07-29-2004 04:26 PM
RH9/KDE3.1/Kernel 2.6.2/Alsa no sound iidbis Linux - General 2 02-06-2004 06:41 AM
Alsa sound problem, RH9, 2.4.20-8 mismach 2.4.20-8custom Bultza Linux - Software 2 10-21-2003 01:10 PM
sound card Q: mp3 chips. Vlackmar Linux - General 1 08-19-2001 11:29 AM


All times are GMT -5. The time now is 02:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration