LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Xrandr 1.2 S-video output to TV is trapezoidal using ATI Radeon 9250 PCI (http://www.linuxquestions.org/questions/linux-hardware-18/xrandr-1-2-s-video-output-to-tv-is-trapezoidal-using-ati-radeon-9250-pci-684461/)

theschlubb 11-18-2008 08:57 PM

Xrandr 1.2 S-video output to TV is trapezoidal using ATI Radeon 9250 PCI
 
Greetings Everyone,

I have been searching for an answer to my problem for about a week using Google. I have not found any threads on any forums that resolve this problem. I am currently running Slackware 12.1 on Linux kernel 2.6.27.5. I believe that the resolution I am outputting to S-video is the culprit. When I try to add a resolution to S-video output I get this error:

Code:

xrandr --addmode S-video 640x480
X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  155 (RANDR)
Minor opcode of failed request:  18 ()
Serial number of failed request:  16
Current serial number in output stream:  17

Here is some other pertinent information:

Code:

lspci -v

01:04.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01) (prog-if 00 [VGA controller])
        Subsystem: Hightech Information System Ltd. Unknown device 2020
        Flags: bus master, medium devsel, latency 64, IRQ 16
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at de00 [size=256]
        Memory at fe9e0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at fe900000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2

01:04.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) (rev 01)
        Subsystem: Hightech Information System Ltd. Unknown device 2021
        Flags: bus master, medium devsel, latency 64
        Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Memory at fe9f0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 2

I have tried adding a new modeline created with gtf to S-video output. It allows the output to be created, but then does not recognize it when I try to add that mode. Here is the output:

Code:

xrandr --newmode "640x480_60.00"  23.86  640 656 720 800  480 481  484 497  -HSync +Vsync

xrandr --output S-video --mode 640x480_60.00
xrandr: cannot find mode 640x480_60.00

xrandr --addmode  S-video  640x480_60.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  155 (RANDR)
  Minor opcode of failed request:  18 ()
  Serial number of failed request:  16
  Current serial number in output stream:  17

Have I missed something or are there limitations to what outputs I can use for S-video? I am fairly new to configuration of video cards and utilizing outputs, and I would appreciate any help that I can get.

theschlubb 11-25-2008 11:32 PM

Xrandr 1.2 S-video output to TV is trapezoidal using ATI Radeon 9250 PCI
 
So I've been trying to resolve this problem with fglrx instead of the drivers that come with Linux kernel 2.6.27.5, but I can't seem to get it to install properly. Are the proprietary drivers better than the kernel drivers? I was also talking with a friend and he told me I should post my xorg.conf and Xorg.log here in case there is some information in them that could help. As both of those are quite long, what parts are important for diagnosing this problem? When looking for the proprietary drivers, I found out that ATI has discontinued the Radeon 9250 video card. Could they have not included support for this card in the latest Catalyst update? I am a total loss. If I come across any solutions I will be sure to include a link in my next post.

mongi3 12-06-2008 02:03 AM

I'm new to dealing with video card config with xrandr as well. I do however have the same card as you and have been able to get my S-video output working well under ubuntu 8.10.

I got a similar error to yours when trying to add resolutions until I used 800x600.

I'm not sure that these lines are all necessary, but here is what worked for me:

force video mode:

$ xrandr --addmode S-video 800x600

I then made the display active using the following lines:

$ xrandr --output S-video --set load_detection 1
$ xrandr --auto


For what it's worth, I couldn't get things to display properly with the fglrx driver.

xrandr version: 1.2
kernel: 2.6.27-9

Hope this helps!

theschlubb 12-07-2008 08:05 PM

Xrandr 1.2 S-video output to TV is trapezoidal using ATI Radeon 9250 PCI
 
I can get an S-video output resolution of 800x600. I don't think I was too clear in my initial posts though. When I use the default S-video output, I get a picture that is slightly more narrow at the top than at the bottom. I have tried it on two televisions, and both get the same results. The picture is fine, it's just not square is all. I have been searching for a couple of months and I have yet to come across a solution for this problem. I also use your method when I am not cloning my desktop. I do this set of commands to get a picture just for my television using xrandr:
Code:

xrandr --output S-video --set load_detection 1
xrandr --output S-video --preferred --left-of VGA-0

That will give me a picture resolution of 800x600@60Hz on my television while I can keep my 1024x768 resolution on my CRT. My total virtual desktop resolution is currently set to 2048x2048. I have also tried setting my CRT resolution to 800x600 and cloning my desktop. Both methods give me the same results. From what I understand, television is usually 720x480 or 704x480. That was why I thought using a resolution of 640x480 would fix the trapezoidal picture problem. Whenever I make a DVD, the picture resolution must be one of those two or there is massive overscan. I thought maybe the S-video signal is not being interpreted correctly because the resolution is set too high, and instead of there being overscan, the picture is just being squashed. If there is anyone out there that can elucidate, I would greatly appreciate it.


All times are GMT -5. The time now is 04:17 AM.