LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 08-31-2012, 06:55 AM   #1
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Xorg Setup Centos6: Asus VW192T+NVIDIA Geforce 7025 / nForce 630a] (rev a2) ?


Hi Guys,

got a dual boot Centos5 & Centos6 system.

Centos5 has a great high/fine resolution using xorg.conf
Code:
# Xorg configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "gb"
EndSection

Section "Monitor"
        Identifier  "Monitor0"
        ModelName   "LCD Panel 1440x900"
        HorizSync   31.5 - 56.0
        VertRefresh 56.0 - 65.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
lspci gives
Code:
00:0d.0 "VGA compatible controller" "NVIDIA Corporation" "C61 [GeForce 7025 / nForce 630a]" -ra2 "ASUSTeK Computer Inc." "Device 83a4"
Unfortunately, Centos 6 doesn't seem to like the xorg file.
Without it, I can only get 1024 x 768 & unknown monitor.
Tried copying xorg file over, but just get black screen with errors such as
Code:
[    37.704] (--) using VT number 7

[    37.705] (EE) NV: The PCI device 0x10de03d6 ((null)) at 00@00:13:0 has a ker
nel module claiming it.
[    37.705] (EE) NV: This driver cannot operate until it has been unloaded.
[    37.705] (EE) No devices detected.
[    37.705] 
Fatal server error:
[    37.705] no screens found
Anyone know how to setup video & screen in Centos/RHEL6?

Last edited by chrism01; 08-31-2012 at 06:56 AM.
 
Old 08-31-2012, 07:27 AM   #2
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
You can force a resolution by using xrandr.

Alex Brinister
 
Old 09-02-2012, 06:25 AM   #3
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Original Poster
Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Ok; thanks for that; that's an example I can follow.
Took me a while to figure out how to get a working xorg.conf; basically only specified the Monitor section and had to find the right Identifier to use, but it seems to work.
Just left the system to use the defaults it somehow finds for the rest...
 
Old 10-03-2013, 09:46 PM   #4
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Original Poster
Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Actual SOLN

As you can see, I failed to document the soln, which led me to asking again recently when my system died during transport.
Here's the link to the new thread + Soln
 
Old 04-10-2014, 07:34 AM   #5
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Original Poster
Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Really with the xorg.conf this time

cat xorg.conf
Code:
Section "Monitor"
    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier		"VGA-1"
    VendorName		"ASUS"
    ModelName		"VW192t"
    HorizSync		30.0 - 81.0
    VertRefresh		56.0 - 75.0
    ModeLine		"1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
    Option			"Preferred Mode" "1440x900_60.00"
    Option			"DPMS"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia card question NVIDIA GeForce 7025 simion314 Linux - Hardware 2 01-27-2011 04:04 PM
[SOLVED] Geforce 6150 nforce 430 and nVidia-drivers 196.* stiv Linux - Hardware 2 07-22-2010 02:04 PM
How do I config my P5N73-AM WITH NVIDIA GEFORCE 7050/NFORCE 610i linuxpen Linux - Hardware 4 12-14-2008 09:13 AM
Help solve driver issue.RHEL5.-ASUS MCP73 NVIDIA GeForce 7050/nForce 610i motherboard vinodsuresh Linux - Newbie 1 10-28-2008 06:23 AM
Linux on ASUS A8N-VM CSM, GeForce 6150 nForce 430 dillo Linux - Hardware 18 08-10-2006 03:12 PM


All times are GMT -5. The time now is 12:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration