LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-14-2005, 06:46 AM   #1
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Rep: Reputation: 15
Xorg server (fglrx) SEGV calling openGL


Hi,

I'm trying to get 3D acceleration from a Radeon 9550 ATI card... until now it was working well with the radeon open source driver (not accelerated) and now with the ATI proprietary (fglrx) driver but... I have to turn off Direct Rendering Interface (DRI) in xorg.conf so only getting 2D acceleration.

If I turn on DRI, the X server gets SEGV (signal 11) and goes down on the first call to OpenGL (running fgl_glxgears, even sometimes opening a GNOME session). I've checked libGL to be the ATI, not the MesaGL-package ones... the following appears in Xorg.log:

Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting

Please help !

Last edited by finidi; 06-14-2005 at 10:01 AM.
 
Old 06-20-2005, 11:12 PM   #2
Gary987
Member
 
Registered: Oct 2003
Distribution: Gentoo, Mint, Ubuntu, Vector
Posts: 149

Rep: Reputation: 15
could you post your xorg log, dmesg ,

export LIBGL_DEBUG verbose

then post glxinfo
and
do
ldd /usr/bin/glxgears and post the info from that too

Gary
 
Old 06-21-2005, 07:02 AM   #3
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Original Poster
Rep: Reputation: 15
Thanks for your answer Gary987,

now I have another problem: I recently upgraded to Fedora Core 4, which C compiler is GCC 4.0 ..... well, now the "fglrx" kernel module does not compile under GCC 4.0 ... I tried to fix the sources with no success... I have to wait until ATI or ??? fixes that.

My previous graphic card was nvidia... much better Linux support.
 
Old 06-29-2005, 04:25 AM   #4
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Original Poster
Rep: Reputation: 15
Angry

Ok. Now the fglrx driver is loaded under FC4 (via livna.org rpms) but still I'm not getting 3D acceleration. The server SEGV is not present, but still not getting DRI (and 3D acceleration).

This is part of Xorg.log :


(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 8.14.13
(II) fglrx(0): Date: Jun 8 2005
(II) fglrx(0): Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0): Build-Kernel UTS_RELEASE: 2.6.11-1.1369_FC4
(II) fglrx(0): Build-Kernel MODVERSIONS: no
(II) fglrx(0): Build-Kernel __SMP__: no
(II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
(II) fglrx(0): [drm] register handle = 0xbf800000
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe0a08000 at 0xb7eb8000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *


The bold line seems to be serious...
 
Old 06-29-2005, 10:55 AM   #5
finidi
Member
 
Registered: Dec 2002
Location: World
Distribution: Fedora Core 4
Posts: 127

Original Poster
Rep: Reputation: 15
Finally I got it switching to internal agpgart in xorg.conf - livna left it using external agpgart and for undetermined reasons it doesn't work for me. But internal fglrx agpgart does.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fglrx xorg.conf file info dangerousdave Linux - Newbie 1 08-21-2005 11:36 PM
ATI FGLRX 3.7.0 work with Xorg and XFree 4.4! Shade Slackware 19 08-05-2005 05:06 AM
XOrg-6.8.1 problem with ATI's fglrx-8.8.25 driver??? ginobili_20 Linux From Scratch 4 02-16-2005 01:57 PM
OpenGL with fglrx (anti-aliasing) deveraux83 Programming 2 01-23-2005 01:51 PM
ATi fglrx 3.9.0 and xorg slackMeUp Slackware 12 06-27-2004 12:46 PM


All times are GMT -5. The time now is 03:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration