LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-17-2007, 01:16 PM   #1
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Rep: Reputation: 15
xorg doesn't set refresh rate properly


I have LCD Monitor Samsung SyncMaster 710N. I have been using it for about 4 years. Unfortunately recently the monitor has been working improperly. I can open X session in linux and work as usual, however, when I reboot or simply exit from X the screen goes black. Of course this happens when I work in X for a while.

This became a big problem for me because I am not able to use my computer. The monitor is frankly speaking corrupted. The problem remains even when I launch windows. This is definately to do with hardware. However, I can use monitor again after it is 10 minutes unplugged.

I noticed that when I start X the refresh rate is very high - in 1240x1024 mode it is 81 Hz - maximum value. There is no way to change it to something like 1240x1024 @ 60. I tried gft and reconfigure the xserver-xorg but it didn't help.

Moreover, I thing that because of the problem with setting the proper resolution and refresh rate my hardware doesn't work fine.

What should I do to set these parameters correctly?
 
Old 12-17-2007, 10:28 PM   #2
tyggna
LQ Newbie
 
Registered: Jul 2007
Posts: 14

Rep: Reputation: 0
Best bet

Your best bet would be to edit /etc/X11/xorg.conf directly. Under the Monitor section add:

Code:
VertRefresh "#"
where the # can be either a single number or a range (e.g. 54-63). Once you've done this, and saved your xorg.conf (back it up before you do this), press ctrl-alt-backspace and see if that does the trick.

Last edited by tyggna; 12-17-2007 at 11:07 PM.
 
Old 12-18-2007, 03:57 PM   #3
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: 15
Thanks for answer. Unfortunately it doesn't work. I modified my xorg.conf but the Vertical refresh is still 75 Hz

My xorg.conf looks like that:

Quote:
Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "pl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "nVidia Corporation NV31 [GeForce FX 5600]"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "SyncMaster"
Option "DPMS"
HorizSync 30-81
#VertRefresh 50-60
VertRefresh 60
#1240x768 @ 60 Hz (GTF) hsync: 47.70; pclk: 77.46 MHz
ModeLine "1240x768_60.00" 77.46 1240 1304 1432 1624 768 769 772 795 -HSync +Vsync
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV31 [GeForce FX 5600]"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection
What else can I do?

Last edited by lord_didger; 12-18-2007 at 04:29 PM.
 
Old 12-19-2007, 10:09 AM   #4
tyggna
LQ Newbie
 
Registered: Jul 2007
Posts: 14

Rep: Reputation: 0
monitor options

For Linux, that's really it.

Now, most monitor's are "smart"--meaning they can tell your graphics card what kind of refresh rate they need. Chances are, if you're still getting 81hz after changing xorg.conf, then something is set on your monitor to override this. Try going into your monitors onboard configuration and see if you can find anything.

If you can't--then changing your monitor driver to "generic" instead of syncmaster--or whatever it is now--would cripple the monitor's ability to override your settings.
 
Old 12-19-2007, 01:03 PM   #5
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
First:
Quote:
ModeLine "1240x768_60.00" 77.46 1240 1304 1432 1624 768 769 772 795 -HSync +Vsync
Shouldn't that be 1280X768?

2nd. That is only 1/2 of what you have to do. You forgot to add it to your modes line.
Quote:
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
Should be:

Quote:
Modes "1240x768_60.00" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
Good luck.
Lazlow
 
Old 12-19-2007, 03:17 PM   #6
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: 15
lazlow tyggna
tyggna, you advised me to change the monitor's driver. I did't know what you mean so I changed my graphic card's driver. It was set to nvidia - now is nv. That helped. When I change the value of VertRefresh it really works. I checked it in the monitor's onboard configuration.

lazlow, you're absolutely right. It was mistake. I wonder why I thought that 1240x768 was a proper mode?

Do you know why the previous driver doesn't follow the options set in xorg.conf? I typed nvidia-installer --version and I got

Quote:
nvidia-installer: version 1.0.7 (buildmeister@builder3) Wed Jun 13 18:39:37 PDT 2007
The NVIDIA Software Installer for Unix/Linux.

This program is used to install and upgrade The NVIDIA Accelerated Graphics Driver Set for Linux-x86.

Copyright (C) 2003 NVIDIA Corporation.
This driver is quite new. I remeber that I compiled it a few months ago after I downloaded it from www.nvidia.com.
 
Old 12-19-2007, 03:38 PM   #7
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
lord_didger

You have to add both the lines I referred to in post #5. The names in quotes have to be EXACTLY the same in both places or xorg will not understand.

I do not know where it is in Debian but in RH based distros there is also a monitor config file. Post #4 has the right idea on this.
 
Old 12-19-2007, 11:50 PM   #8
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
All monitor settings and desire modelines should be in the monitor section in /etc/X11/xorg.conf.

The driver nvidia does use the settings but ignores them when EDID is enabled which is set to enable by default.

I suggest reading nVidia's documentation for Linux module (driver). It explains about modelines. gtf utility, metamode, and several others.
 
Old 12-20-2007, 10:17 AM   #9
lord_didger
Member
 
Registered: Jun 2005
Location: Poland
Distribution: Debian
Posts: 106

Original Poster
Rep: Reputation: 15
You've said that EDID is enabled by default. Can I set an option in xorg.conf to disable it? I found nothing about EDID in `man xorg.conf`.
 
Old 01-14-2008, 08:47 PM   #10
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
see this post to disable EDID.

http://www.linuxquestions.org/questi...a-2008-613570/
 
  


Reply

Tags
modeline, refresh, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf, refresh rate and viewsonic VX2025wm mala fide Linux - Hardware 8 10-18-2006 12:19 AM
Xorg and refresh rate of AOCd556 Monitor nexus06 Linux - Desktop 0 10-04-2006 01:04 PM
Xorg refresh rate Synesthesia Linux - General 1 12-19-2005 06:13 PM
editing refresh rate in xorg.conf does nothing Riallin Slackware 22 02-28-2005 03:31 AM
Xorg Refresh Rate kundor Linux - Hardware 3 06-29-2004 07:13 PM


All times are GMT -5. The time now is 03:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration