LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Xorg.conf is edited on restart? x-server fails to start (http://www.linuxquestions.org/questions/linux-hardware-18/xorg-conf-is-edited-on-restart-x-server-fails-to-start-589884/)

Linkhiei 10-06-2007 10:56 AM

Xorg.conf is edited on restart? x-server fails to start
 
Hihi everyone. I am having a problem where everytime I restart my debian etch, my x-server will not start. I have the proprietary nvidia drivers installed. I beleive that the xorg.conf might be being edited on startup (I could be totally wrong about this), which could be causing this problem.

There is a line in the startup that makes me think this:
Code:

Removing NVIDIA TLS Links
All I have to do to fix my problem is run the nvidia drivers install and make sure it writes to my xorg.conf file. Everything works fine after this. But then, once I restart my computer, x cannot start again.

My xorg.conf file currently looks like this (this is the file while x-server is running correctly):


Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:29:35 PDT 2007

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg
#Section "InputDevice"
#        Identifier    "Configured Mouse"
#        Driver        "mouse"
#    Option        "Protocol"        "evdev"
#    Option        "Dev Name"        "Logitech USB-PS/2 Optical Mouse"
#    Option        "Dev Phys"        "usb-*/input0"
#        Option        "Device"        "/dev/input/event3"
#    Option        "Buttons"        "10"
#    Option        "ZAxisMapping"        "4 5"
#EndSection

Section "ServerLayout"

# Uncomment if you have a wacom tablet
#        InputDevice    "stylus"        "SendCoreEvents"
#        InputDevice    "cursor"        "SendCoreEvents"
#        InputDevice    "eraser"        "SendCoreEvents"
    Identifier    "Default Layout"
    Screen        "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
    Load          "glx"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier    "stylus"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "stylus"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier    "eraser"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "eraser"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier    "cursor"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "cursor"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier    "HW191D"
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "nVidia Corporation NV43 [GeForce 6600]"
    Driver        "nvidia"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "nVidia Corporation NV43 [GeForce 6600]"
    Monitor        "HW191D"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
        Modes      "1440x900" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

o__O Sorry if I don't give a quick response, I am leaving the house for a while.

Peacedog 10-06-2007 12:20 PM

Hi Linkhiei, I believe you'll find the answer to your problem here.

http://www.leverkruid.eu/linux-laptop/index.html

Good luck. ;-)

Linkhiei 10-07-2007 10:49 AM

Thanks much for the reply! Sorry for taking so long to reply, I've been at my friend's house.


Anyways, I tried that page and it didn't fix my problem, but it was quite useful in helping me search for answers to my problem.

For future reference, this is how I fixed it:

Of course, when I started up x-server was not working. I reinstalled the nvidia drivers again, but this time instead of going into my graphical login afterwards, I decided to do the following:

I edited the nvidia-glx file:
Code:

nano /etc/init.d/nvidia-glx
Then, there was a section that said:
Code:

echo -n "Removing NVIDIA TLS links..."
 remove the symlinks
rm -f /usr/lib/tls/libGL.so
rm -f /usr/lib/tls/libGL.so.*
rm -f /usr/lib/tls/libGL.la
rm -f /usr/lib/tls/libGLcore.so.*
rm -f /usr/lib/tls/libnvidia-tls.so
rm -f /usr/lib/tls/libnvidia-tls.so.*
 reconfigure dynamic linker run-time bindings
ldconfig
echo " done."

I just commented out that entire section by adding the pound signs so that it looked like this:

Code:

#echo -n "Removing NVIDIA TLS links..."
# remove the symlinks
#rm -f /usr/lib/tls/libGL.so
#rm -f /usr/lib/tls/libGL.so.*
#rm -f /usr/lib/tls/libGL.la
#rm -f /usr/lib/tls/libGLcore.so.*
#rm -f /usr/lib/tls/libnvidia-tls.so
#rm -f /usr/lib/tls/libnvidia-tls.so.*
# reconfigure dynamic linker run-time bindings
#ldconfig
#echo " done."

Saved the file by hitting F3. Then after the file was saved, I just restarted and everything was working perfectly! :D


All times are GMT -5. The time now is 08:11 AM.