LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-25-2005, 03:09 AM   #1
fostiator
Member
 
Registered: Mar 2003
Location: Marbella
Distribution: SuSE 10.0
Posts: 63

Rep: Reputation: 15
Xlib: extension "XFree86-DRI" missing on display ":0.0".


Hi, this is what I get when running glxgears:
fostiator@neo:~> glxgears
Xlib: extension "XFree86-DRI" missing on display ":0.0".
2336 frames in 5.0 seconds = 467.200 FPS
2880 frames in 5.0 seconds = 576.000 FPS
3120 frames in 5.0 seconds = 624.000 FPS
3000 frames in 5.0 seconds = 600.000 FPS
3120 frames in 5.0 seconds = 624.000 FPS
2640 frames in 5.0 seconds = 528.000 FPS

and

fostiator@neo:~> fgl_glxgears
Xlib: extension "XFree86-DRI" missing on display ":0.0".
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 155 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 30
Current serial number in output stream: 30


I have Suse 9.2,kernel 2.6.8-24.11-default and an Ati Radeon X800 pro,i've recently installed new ati drivers for X.org (now i can choose my card) but I can't enable 3D acceleration and i get that message.

anybody can help? thanks
 
Old 01-25-2005, 01:12 PM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
i think i need to look at ur xorg.conf or Xf86cfg file

regards
 
Old 01-25-2005, 04:26 PM   #3
fostiator
Member
 
Registered: Mar 2003
Location: Marbella
Distribution: SuSE 10.0
Posts: 63

Original Poster
Rep: Reputation: 15
This is my XF86Config (Xorg.conf)

# /.../
# SaX generated X11 config file
# Created on: 2005-01-25T13:00:48+0100.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "es"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Logitech Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
DisplaySize 310 230
HorizSync 30-63
Identifier "Monitor[0]"
ModelName "BENQ FP557"
Option "DPMS"
VendorName "BNQ"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "Radeon X800PRO (R423) UI (PCIE)"
Driver "radeon"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "ATI"
Option "NoTV" "no"
Option "TVStandard" "PAL-D"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

Last edited by fostiator; 01-25-2005 at 04:28 PM.
 
Old 01-25-2005, 11:24 PM   #4
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
comments this line and see if it works

Load "dri"

regards
 
Old 01-26-2005, 06:42 AM   #5
fostiator
Member
 
Registered: Mar 2003
Location: Marbella
Distribution: SuSE 10.0
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by masand
comments this line and see if it works

Load "dri"

regards
same error message
 
Old 01-26-2005, 07:09 AM   #6
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
i am sorry forgot to mention that

try commenting this one too

Section "DRI"
Group "video"
Mode 0660
EndSection

regards
 
Old 01-26-2005, 08:47 AM   #7
fostiator
Member
 
Registered: Mar 2003
Location: Marbella
Distribution: SuSE 10.0
Posts: 63

Original Poster
Rep: Reputation: 15
still nothing

thanks
 
Old 01-26-2005, 10:19 AM   #8
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
try configuring with the help of

xorgconfig

regards
 
Old 01-26-2005, 03:46 PM   #9
fostiator
Member
 
Registered: Mar 2003
Location: Marbella
Distribution: SuSE 10.0
Posts: 63

Original Poster
Rep: Reputation: 15
i've tried it but i can't find my card in the database

i think i have to move to fedora if i want to use my card with all its features
 
Old 01-26-2005, 04:32 PM   #10
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
Quote:
Originally posted by fostiator
i've tried it but i can't find my card in the database

i think i have to move to fedora if i want to use my card with all its features
did u try the no.6 entry in the database

ATI radeon???

regards
 
Old 01-27-2005, 02:45 AM   #11
fostiator
Member
 
Registered: Mar 2003
Location: Marbella
Distribution: SuSE 10.0
Posts: 63

Original Poster
Rep: Reputation: 15
i've tried it,this is what i get:

> glxgears
Xlib: extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.

thanks for your patience
 
Old 01-27-2005, 02:53 AM   #12
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
i haven't worked on glx

i beleive it is desktop

can u run other desktops

atleast we can be sure that there is nothing wrong with glx

regards
 
Old 01-27-2005, 04:49 AM   #13
fostiator
Member
 
Registered: Mar 2003
Location: Marbella
Distribution: SuSE 10.0
Posts: 63

Original Poster
Rep: Reputation: 15
finally i could fix it!!!!

using suse ati drivers instead ati officials

now i get:

> glxgears
24227 frames in 5.0 seconds = 4845.400 FPS
25683 frames in 5.0 seconds = 5136.600 FPS
25684 frames in 5.0 seconds = 5136.800 FPS
25684 frames in 5.0 seconds = 5136.800 FPS
25683 frames in 5.0 seconds = 5136.600 FPS
25682 frames in 5.0 seconds = 5136.400 FPS
> fgl_glxgears
4398 frames in 5.0 seconds = 879.600 FPS
4697 frames in 5.0 seconds = 939.400 FPS
4691 frames in 5.0 seconds = 938.200 FPS
4704 frames in 5.0 seconds = 940.800 FPS
4692 frames in 5.0 seconds = 938.400 FPS
4697 frames in 5.0 seconds = 939.400 FPS
4695 frames in 5.0 seconds = 939.000 FPS
4691 frames in 5.0 seconds = 938.200 FPS
4707 frames in 5.0 seconds = 941.400 FPS
4697 frames in 5.0 seconds = 939.400 FPS
4702 frames in 5.0 seconds = 940.400 FPS

thanks, best regards
 
Old 01-27-2005, 05:29 AM   #14
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
good that it is working now!!

can u tell me what is glx and how is it usefull

regards
 
Old 01-27-2005, 04:29 PM   #15
fostiator
Member
 
Registered: Mar 2003
Location: Marbella
Distribution: SuSE 10.0
Posts: 63

Original Poster
Rep: Reputation: 15
it's a linux graphics card benchmark

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 04:07 PM
Xlib: extension "XFree86-DRI" missing on display :0.0 rose_bud4201 Linux - Hardware 0 06-18-2005 11:43 PM
"extension "XFree86-DRI" missing on display" upgrading XFree86 to 4.3.0 on Sarge Moloko Debian 5 03-31-2004 06:06 PM
bash-2.05b# Xlib: extension "XFree86-DRI" missing on display ":0.0". citrus Linux - General 8 02-22-2004 11:43 AM
Xlib: extension "GLX" missing on display ":0.0" Evohack Linux - Software 18 10-23-2003 11:10 PM


All times are GMT -5. The time now is 03:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration