LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-01-2008, 09:15 PM   #1
onthefritz
Member
 
Registered: Dec 2005
Location: Colorado
Distribution: Ubuntu, RHEL, openSUSE
Posts: 105

Rep: Reputation: 19
xfree86-dri missing on display


Well first with the details.

Graphics card: Radeon 9700 Pro
Distor version: Ubuntu 7.10
Kernel version: 2.6.22
ATI restricted Drivers: Installed (Installed by Ubuntu...not the ATI distributed driver.)

I get this error whenever I try to run 3d accelerated programs. Here is the output from many of the programs I try to run:

Code:
Neverwinter Nights:
Xlib:  extension "XFree86-DRI" missing on display ":1.0".
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

glxgears:
Xlib:  extension "XFree86-DRI" missing on display ":1.0".

glxinfo
name of display: :1.0
Xlib:  extension "XFree86-DRI" missing on display ":1.0".
display: :1  screen: 0
I have tried to install the ATI drivers from their site but all my graphics slowed to a crawl. So that was a bust. I have tried many a few other idea on other sites with no fix... does anyone else have an ideas?

Thank you

OTF
 
Old 01-02-2008, 01:48 PM   #2
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
/var/log/Xorg.0.log should contain the error.
 
Old 01-02-2008, 07:39 PM   #3
onthefritz
Member
 
Registered: Dec 2005
Location: Colorado
Distribution: Ubuntu, RHEL, openSUSE
Posts: 105

Original Poster
Rep: Reputation: 19
Here is a list of Warnings and Errors I found. I know it has something to do with the 3D rendering (even though Compiz Fusion works fine) but I'm not sure how to fix it.

Code:
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
	Entry deleted from font path.
(WW) fglrx: No matching Device section for instance (BusID PCI:3:0:1) found
(WW) fglrx(0): Only one display is connnected,so single mode is enabled
(WW) LoadModule: given non-canonical module name "glesx.so"
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering
I can post my xorg.conf if needed, but I think it's more of a driver issue. Only I don't know where to get a driver that works correctly.

OTF
 
  


Reply

Tags
ati, radeon


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: extension "XFree86-DRI" missing on display :0.0 rose_bud4201 Linux - Hardware 0 06-18-2005 10:43 PM
Xlib: extension "XFree86-DRI" missing on display ":0.0". fostiator Linux - Hardware 15 02-20-2005 07:13 AM
XFree86 DRI Missing on Display: 0.0 & MESAGL instead of OpenGL nealkochhar Linux - Newbie 1 06-07-2004 02:07 PM
"extension "XFree86-DRI" missing on display" upgrading XFree86 to 4.3.0 on Sarge Moloko Debian 5 03-31-2004 05:06 PM
bash-2.05b# Xlib: extension "XFree86-DRI" missing on display ":0.0". citrus Linux - General 8 02-22-2004 10:43 AM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration