LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-01-2009, 08:01 PM   #1
airswit
Member
 
Registered: Dec 2005
Distribution: Fedora 4
Posts: 89

Rep: Reputation: 15
xFi sound card giving kernel errors


Hi All,

I have installed the Sound Blaster XFI drivers (downloaded from Creative a few days ago) onto my Fedora11 machine, and am getting this kernel error every now and then:
Code:
Kernel failure message 1:
BUG: sleeping function called from invalid context at mm/slub.c:1602
in_atomic(): 0, irqs_disabled(): 1, pid: 2149, name: pulseaudio
Pid: 2149, comm: pulseaudio Tainted: P           2.6.29.6-217.2.16.fc11.x86_64 #1
Call Trace:


Kernel failure message 2:
BUG: sleeping function called from invalid context at mm/slub.c:1602
in_atomic(): 0, irqs_disabled(): 1, pid: 2149, name: pulseaudio
Pid: 2149, comm: pulseaudio Tainted: P           2.6.29.6-217.2.16.fc11.x86_64 #1
Call Trace:
 [<ffffffff8103fd8c>] __might_sleep+0x10b/0x110
 [<ffffffff810cd382>] kmem_cache_alloc+0x37/0xf1
 [<ffffffffa01d7c0b>] ? amixer_commit_write+0xf9/0x127 [ctxfi]
 [<ffffffffa01d4c9e>] ct_vm_map+0xef/0x195 [ctxfi]
 [<ffffffffa01d7cc1>] ? amixer_setup+0x3e/0x48 [ctxfi]
 [<ffffffffa01d38b6>] ct_map_audio_buffer+0x50/0x79 [ctxfi]
 [<ffffffffa01d4629>] atc_pcm_playback_prepare+0x200/0x2ce [ctxfi]
 [<ffffffff811b6f1d>] ? __up_read+0x76/0x81
 [<ffffffffa01d6680>] ? src_set_pm+0x0/0x18 [ctxfi]
 [<ffffffff8105fc3e>] ? up_read+0xe/0x10
 [<ffffffff810606dc>] ? __blocking_notifier_call_chain+0x5b/0x67
 [<ffffffffa01d520e>] ct_pcm_playback_prepare+0x29/0x3c [ctxfi]
 [<ffffffffa01aee33>] snd_pcm_do_prepare+0x1b/0x2d [snd_pcm]
 [<ffffffffa01ae9e1>] snd_pcm_action_single+0x33/0x6a [snd_pcm]
 [<ffffffffa01b0576>] snd_pcm_action_nonatomic+0x4f/0x68 [snd_pcm]
 [<ffffffffa01b2b88>] snd_pcm_common_ioctl1+0x455/0xbf4 [snd_pcm]
 [<ffffffff8109ed88>] ? wake_up_page+0x25/0x2a
 [<ffffffff8109ede4>] ? unlock_page+0x14/0x16
 [<ffffffff810b25c0>] ? __do_fault+0x39e/0x3d5
 [<ffffffff81029f87>] ? default_spin_lock_flags+0x9/0xe
 [<ffffffffa01b387b>] snd_pcm_playback_ioctl1+0x282/0x29f [snd_pcm]
 [<ffffffffa01b422b>] snd_pcm_playback_ioctl+0x2f/0x33 [snd_pcm]
 [<ffffffff810e0f13>] vfs_ioctl+0x22/0x87
 [<ffffffff810e13fb>] do_vfs_ioctl+0x462/0x4a3
 [<ffffffff810e1492>] sys_ioctl+0x56/0x79
 [<ffffffff8101133a>] system_call_fastpath+0x16/0x1b
Can anyone help me out here?

Thanks
 
Old 09-02-2009, 05:31 AM   #2
cladisch
Member
 
Registered: Oct 2008
Location: Earth
Distribution: Slackware
Posts: 227

Rep: Reputation: 54
Quote:
I have installed the Sound Blaster XFI drivers (downloaded from Creative)
Try the latest ALSA drivers.
 
Old 09-02-2009, 06:21 AM   #3
karamarisan
Member
 
Registered: Jul 2009
Location: Illinois, US
Distribution: Fedora 11
Posts: 374

Rep: Reputation: 55
Seconded; I haven't tried in a while, but Creative's driver was offensively bad. Just checked here, and ALSA now claims X-Fi support in their latest release. Your current software is a little behind the required version, but if you want to reach into the future or wait soon, it should be possible to get this working. Let us know how that goes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XFi sound card driver install problem on Ubuntu (32-bit) cushman2 Linux - Newbie 1 06-12-2008 04:42 PM
Suse 10.2 kernel 2.6.18 to 2.6.20 patch giving errors tAgC Suse/Novell 1 02-16-2007 04:56 AM
INTEX SOUND Card Not giving Output NIXPIX Linux - Hardware 2 10-17-2006 03:18 AM
X giving ambiguous errors on Kernel - 2.6.17 / X - 6.8.1 wakeboarder3780 Slackware 20 09-21-2006 09:11 PM
2 sound card errors after kernel recompile. Need newbie help LearningToSlack Linux - Newbie 2 11-10-2003 03:46 PM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration