LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-18-2009, 04:42 PM   #1
Nadasdy
LQ Newbie
 
Registered: Nov 2006
Distribution: Fedora core 5
Posts: 7

Rep: Reputation: 0
x86_64 kernel on Fedora 11 does not see 4 GB RAM


I just installed Fedora 11 with kernel 2.6.29.4-167.fc11.x86_64 on my
G31M-S motherboard (Intel G31 + ICH7 chipsets) with Intel Quad-core CPU and 4 GB RAM.

-The motherboard manufacturer's manual claims that the chipset can handle RAM up to 8 GB.

-The BIOS setup correctly detects the 4 GB RAM but after Linux boots the system detects only 2.9 GiB.

Below is the relevant section of my "dmesg" output if someone is not afraid of digging in.

Is this a BIOS limitation?
Should I upgrade the BIOS?
Any ideas or solutions?

Thanks.
-z


====-----------------------------------------------------------
Linux version 2.6.29.4-167.fc11.x86_64 (mockbuild@xenbuilder4.fedora.phx.redhat.com) (gcc version 4.4.0 200
90506 (Red Hat 4.4.0-4) (GCC) ) #1 SMP Wed May 27 17:27:08 EDT 2009
Command line: ro root=/dev/mapper/vg_toy-lv_root nomodeset rhgb quiet
KERNEL supported cpus:
Intel GenuineIntel
AMD AuthenticAMD
Centaur CentaurHauls
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009d000 (usable)
BIOS-e820: 000000000009d000 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000e6000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 00000000bbfb0000 (usable)
BIOS-e820: 00000000bbfb0000 - 00000000bbfc0000 (ACPI data)
BIOS-e820: 00000000bbfc0000 - 00000000bbff0000 (ACPI NVS)
BIOS-e820: 00000000bbff0000 - 00000000bc000000 (reserved)
BIOS-e820: 00000000fed00000 - 00000000fed00400 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ff380000 - 0000000100000000 (reserved)
DMI present.
AMI BIOS detected: BIOS may corrupt low RAM, working around it.
last_pfn = 0xbbfb0 max_arch_pfn = 0x100000000
x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
original variable MTRRs
reg 0, base: 3008MB, range: 64MB, type UC
reg 1, base: 0GB, range: 2GB, type WB
reg 2, base: 2GB, range: 1GB, type WB
total RAM coverred: 3008M
Found optimal setting for mtrr clean up
gran_size: 64K chunk_size: 128M num_reg: 3 lose cover RAM: 0G
New variable MTRRs
reg 0, base: 0GB, range: 2GB, type WB
reg 1, base: 2GB, range: 1GB, type WB
reg 2, base: 3008MB, range: 64MB, type UC
x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
===--------------------------------------------------------------
 
Old 06-18-2009, 05:01 PM   #2
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,051

Rep: Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100
It looks like a BIOS or Motherboard limit. It does not look like the problem is in Linux.

Wander through the BIOS setup screens and see if there is anything that looks like it relates to the way the BIOS reports memory to the OS and/or remapping ram and/or the memory "hole".

There may be some BIOS setting you can just change to get the extra memory working.
 
Old 06-18-2009, 05:12 PM   #3
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,051

Rep: Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100
Quote:
Originally Posted by Nadasdy View Post
The motherboard manufacturer's manual claims that the chipset can handle RAM up to 8 GB.
Do you have a URL for that claim?

I just did a quick google search on both the motherboard and the G31 chipset. Every page I found says the max ram is "4GB" and that unfortunately always means less than 4GB, typically 3.25GB.

I don't know whether you're really stuck with under 3GB. Some pages I found said that motherboard could use 3.5GB when 4GB is installed. Maybe a change in BIOS setting or a BIOS upgrade would get you to 3.5GB.

I don't think that motherboard will let you use the full 4GB.
 
Old 06-18-2009, 05:58 PM   #4
Nadasdy
LQ Newbie
 
Registered: Nov 2006
Distribution: Fedora core 5
Posts: 7

Original Poster
Rep: Reputation: 0
Below is the URL to the motherboard specs.
It clearly states the supported RAM is up to 8 GB and with 64 bit OS there is no reduction on memory size.

http://www.asrock.com/mb/overview.asp?Model=G31M-S
 
Old 06-18-2009, 06:01 PM   #5
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
Your graphics card may be using it. Check the bios settings
 
Old 06-18-2009, 06:22 PM   #6
Nadasdy
LQ Newbie
 
Registered: Nov 2006
Distribution: Fedora core 5
Posts: 7

Original Poster
Rep: Reputation: 0
I was checking the BIOS settings but could not find anything related to Graphics.
Do you know what exactly to look for?
I am actually using a PCI-E graphics card and not the one that is built in. If that matters at all.
 
Old 06-19-2009, 07:56 AM   #7
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,051

Rep: Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100
Quote:
Originally Posted by Nadasdy View Post
I was checking the BIOS settings but could not find anything related to Graphics.
How close is the actual BIOS to the documented BIOS in the manual at
ftp://174.142.97.10/manual/G31M-S.pdf

1) Look at 3.4.2 Chipset Configuration near the bottom of page 32.
If "Memory remap" is disabled, that would cause exactly your symptoms. Make sure that is enabled.

2) Look at 3.2 Main Screen. See how it displays shared memory and GTT memory. I don't know what GTT is. Since you're using a separate video card, you want shared memory as low as possible.

3) Further into 3.4.2, see Internal Graphics Mode, DVMT mode, and DVMT/Fixed Memory. It isn't clear from the doc, but I think some combination of those will disable the on board graphics when you have a graphics card, thus stopping the onboard graphics from reserving ram.

Earlier I was looking at the wrong motherboard entirely (by using google rather than your link to find the motherboard info). Adding ASROCK to that search I now see lots of sources indicating it has 8GB support, including that BIOS manual (the whole "Memory remap" feature would be meaningless if it didn't support over 3.x GB of ram). I still found only a little info on the Intel G31 chip itself and that says you are limited to 3.x GB. But there seems to be too much info about the board supporting 8GB for what I read about the chip to be correct.

Before I bought my Gigabyte MB, I downloaded the pdf for the manual and was impressed with the power in the documented BIOS setup. Your motherboard manual documents an even more powerful BIOS. Unfortunately, the Gigabyte documentation was a total lie. The actual BIOS was missing almost every documented feature. After upgrading to the only BIOS version that had a download available, only one of those missing features appeared. I hope your Asrock documentation is more honest about what features are actually present in the BIOS.

Please report back on how well the actual BIOS matched the documented one and whether changing any of those settings helped.

Last edited by johnsfine; 06-19-2009 at 08:14 AM.
 
Old 06-19-2009, 10:04 PM   #8
Nadasdy
LQ Newbie
 
Registered: Nov 2006
Distribution: Fedora core 5
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks to everyone, PROBLEM FIXED!!!

The lead that in the BIOS setup, by default, a significant chunk of RAM is reserved for the on-board video card was correct.

Joshfine, you put your finger on it!
Your first suggestion to enable "Memory remap" was instrumental. It recovered 3.8 GB RAM. There are still some ~200 MB missing for whatever purpose and I was not able to reduce that but I am not concerned about it.

My BIOS setup is actually missing the "Internal Graphics Mode, DVMT" option.

Good job guys!!!
-z

Last edited by Nadasdy; 06-19-2009 at 10:06 PM.
 
Old 06-20-2009, 08:04 AM   #9
johnsfine
Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,051

Rep: Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100Reputation: 1100
Quote:
Originally Posted by Nadasdy View Post
a significant chunk of RAM is reserved for the on-board video card
That may have been part of the problem and may still be part or all of the missing 200MB. It wasn't originally the main problem.

Quote:
"Memory remap" was instrumental.
That fixed the main problem. It did not affect the amount of ram (if any) that is reserved for video. It was a different kind of problem. My earlier email assumed you had to fix two separate problems.

Quote:
My BIOS setup is actually missing the "Internal Graphics Mode, DVMT" option.
Maybe the BIOS is really missing that documented option. Maybe other options combined with the presence of a video card cause the internal video to get disabled and then the BIOS suppresses options that are meaningless while it is disabled.

I guess it would take a fair amount of investigation to see whether there is memory allocated to the on-board video or whether the missing 200MB is something else.

If you ever care enough about the missing memory, post the new values (after remapping was enabled) of the BIOS ram table that you had in the first post, and post some info about the BIOS settings around the point where that DVMT option should have been.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 9 Kernel Source for both x86_64 and i[3|4|5|6]86 versions... amitra Fedora - Installation 1 11-14-2008 10:58 AM
fedora 8 x86_64 4G RAM problem ziyunxiao Linux - General 2 04-08-2008 09:27 PM
Fedora Core 8 x86_64 does not recognize full 4GB Ram mnsse Linux - Newbie 23 03-24-2008 03:41 PM
Can't see 4 Gb RAM with ASUS P5B Deluxe / x86_64 Fedora Core 6 drewb1977 Linux - Hardware 14 01-28-2008 11:20 PM
Slackware on x86_64 with 8GB RAM gargamel Slackware 9 01-16-2008 04:45 PM


All times are GMT -5. The time now is 10:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration