LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-18-2006, 03:34 AM   #1
LAj
LQ Newbie
 
Registered: Sep 2006
Location: Italy, Napoli
Distribution: Gentoo 2006.1
Posts: 11

Rep: Reputation: 0
X crash using ATI driver 8.28.8 on CrossFire system


Hi all,
my first post
I trust this forum help all linux user, and mine is a distro wide problem.

I'm looking for somebody that is running X with 2 Radeon on a CrossFire mainboard.
I know that XFire is a tecnology available on for Windows and DirectX, but I want to know how to make working one VGA device in Linux without the needs of removing the other one.


My expirience refer to:
ASUS A8R32-MVP
2x X850 XT( CrossFire edition & CrossFire ready tested with Windows drivers)
SyncMaster 244T with native resolution 1920x1200

My distro is -amd64 Gentoo 2006.1 with GCC4.1.1( I'm going to upgrade my profile info )
and the x86_64 ATI driver since 8.27.10 enable DRI for all VGA devices to the Radeon X1950.
If I remove the slave card I can run X with a fglrx drived device but if togheter are installed X stuck in a black screen( with a low resolution, as I can see from cursor ) also I can hear the VGA works because fan speed increase but no input device respond and there is not any info in the log file.

Is needed some special section in xorg.conf?

Last edited by LAj; 09-20-2006 at 04:40 AM.
 
Old 09-20-2006, 04:42 AM   #2
LAj
LQ Newbie
 
Registered: Sep 2006
Location: Italy, Napoli
Distribution: Gentoo 2006.1
Posts: 11

Original Poster
Rep: Reputation: 0
No one with CrossFire system?
 
Old 10-03-2006, 07:31 AM   #3
LAj
LQ Newbie
 
Registered: Sep 2006
Location: Italy, Napoli
Distribution: Gentoo 2006.1
Posts: 11

Original Poster
Rep: Reputation: 0
I'm the only owner of this system that run linux?

I've a ATI chipset on the mainboard, but also Intel and Uli chipset can operate with 2 ATI.

Come on, try to config out a multi-seat system with you PC and 2 ATI VGA.
 
Old 10-07-2006, 12:20 AM   #4
ight8
LQ Newbie
 
Registered: May 2004
Location: cleveland
Distribution: fedora 5
Posts: 18

Rep: Reputation: 0
proprietary driver?

fedora 5
amd 4000
DFI Lanparty cfx-3200 with crossfire
one x-1900 ati


The only problem I had was the inability to use various functions with my video card, such as 3D rendering (not yet supported by mesa). I don't as of yet have the second card but I will. My question to you is, are you using the x.org/xfree86 driver or the ati-linux-proprietary-driver?

The proprietary driver should have all the functions for using crossfire on linux; I know that half the standard driver for ati is usually free (the half ati makes) and the other half is non-free because someone else made it for them. However, that is why ati puts out the linux version, so you can use all the functions of your hardware, even in Linux.

ATI's support site
https://support.ati.com/ics/support/...e&folderID=300
 
Old 10-08-2006, 02:08 AM   #5
LAj
LQ Newbie
 
Registered: Sep 2006
Location: Italy, Napoli
Distribution: Gentoo 2006.1
Posts: 11

Original Poster
Rep: Reputation: 0
You have not my problem because you don't have 2 vga.
If you install another X1xx on the slave PCI-e slot, then you'll be unable to set X with fglrx driver for your cards.
This is the problem!!!
Sorry
 
Old 10-10-2006, 03:33 AM   #6
LAj
LQ Newbie
 
Registered: Sep 2006
Location: Italy, Napoli
Distribution: Gentoo 2006.1
Posts: 11

Original Poster
Rep: Reputation: 0
I've opened a bug on ATI bugzilla:

You can found it here:
http://ati.cchtml.com/show_bug.cgi?id=523

...but looks like I'm the only one with such a system.

Last edited by LAj; 10-10-2006 at 03:37 AM.
 
Old 11-11-2006, 04:35 AM   #7
LAj
LQ Newbie
 
Registered: Sep 2006
Location: Italy, Napoli
Distribution: Gentoo 2006.1
Posts: 11

Original Poster
Rep: Reputation: 0
Still doesn't work with 8.30.3!

No one with 2 ATI VGAs on his CrossFire mainboard?

I have't found such system's owner on all the web using linux!
I'm the only one? Incredible.
 
Old 11-14-2006, 04:44 PM   #8
LAj
LQ Newbie
 
Registered: Sep 2006
Location: Italy, Napoli
Distribution: Gentoo 2006.1
Posts: 11

Original Poster
Rep: Reputation: 0
Xorg beats ATI

Great solution for me:
-emerge latest libdrm masked package;
-emerge latest mesa hard masked package;
-read this section only: http://dri.freedesktop.org/wiki/Buil...d4f5268396b2b4
-configure your xorg.conf properly( with "radeon" Device ).
-reboot your system;
-enjoy it:-D

Code:
NeXT ~ # lspci
00:00.0 Host bridge: ATI Technologies Inc Unknown device 5952
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:03.0 PCI bridge: ATI Technologies Inc Unknown device 5a35
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
00:1a.0 PCI bridge: ALi Corporation M5249 HTT to PCI Bridge
00:1c.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:1c.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:1c.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:1c.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
00:1d.0 Audio device: ALi Corporation High Definition Audio/AC'97 Host
Controller (rev 02)
00:1e.0 ISA bridge: ALi Corporation Unknown device 1575
00:1e.1 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:1f.0 IDE interface: ALi Corporation M5229 IDE (rev c8)
00:1f.1 SATA controller: ALi Corporation ULi M5288 SATA (rev 10)
01:10.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear
SoundFusion Audio Accelerator] (rev 01)
01:12.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip /
Technisat SkyStar2 DVB card (rev 02)
01:13.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
01:14.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit
Ethernet Controller (rev 14)
02:00.0 VGA compatible controller: ATI Technologies Inc R480 [Radeon X850XT
(PCIE)] (Primary)
02:00.1 Display controller: ATI Technologies Inc R480 [Radeon X850XT (PCIE)]
(Secondary)
03:00.0 VGA compatible controller: ATI Technologies Inc R480 [Radeon X850XT
(PCIE)] (Primary)
03:00.1 Display controller: ATI Technologies Inc R480 [Radeon X850XT (PCIE)]
(Secondary)
NeXT ~ # glxinfo | grep rendering
direct rendering: Yes
NeXT ~ #
Code:
NeXT ~ # LIBGL_DEBUG=verbose glxgears
libGL: XF86DRIGetClientDriverName: 5.2.0 r300 (screen 0)
libGL: OpenDriver: trying /usr/lib64/dri/tls/r300_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/r300_dri.so
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 5, (OK)
drmOpenByBusid: Searching for BusID pci:0000:03:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 5, (OK)
drmOpenByBusid: drmOpenMinor returns 5
drmOpenByBusid: drmGetBusid reports pci:0000:03:00.0
w,h 0 0
9636 frames in 5.0 seconds = 1926.856 FPS
8592 frames in 5.0 seconds = 1718.375 FPS
11146 frames in 5.0 seconds = 2228.752 FPS
12383 frames in 5.1 seconds = 2421.769 FPS
15943 frames in 5.0 seconds = 3188.455 FPS
I think ATI need to release its drivers as open source[/code].
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fglrx-driver vs ATI kernel driver for ATI Radeon 9200 in Debian Debian_Poland Debian 3 02-01-2006 01:10 PM
System Hangs on Boot-- ATI driver problem? 43r05p4c3 Linux - Hardware 9 01-08-2006 06:00 PM
X.org ati driver crashes system only loading KDE dulles Linux - Laptop and Netbook 4 12-12-2005 04:39 PM
Ati fglrx-driver hangs up the system Saquel Linux - Software 0 09-05-2005 03:31 AM
ATI driver help! - Xlib crash... static_drc Slackware 8 01-05-2004 10:51 PM


All times are GMT -5. The time now is 11:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration