LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Wrong bus speed on hard drive? (http://www.linuxquestions.org/questions/linux-hardware-18/wrong-bus-speed-on-hard-drive-469876/)

mikieboy 08-01-2006 05:58 PM

Wrong bus speed on hard drive?
 
During boot up I have noticed the message :

"ide: assuming 33MHz system bus speed for PIO modes; override with idebus=xx"

My hard drive is a Seagate Barracuda 7200.7 series which is ATA-100. Does this mean that my hard drive is running slower than it should? If so, do I add idebus=100 to the kernel line in my /boot/grub/menu.lst?

Emerson 08-01-2006 08:10 PM

It may mean your IDE cable is ATA-33.

ciotog 08-01-2006 10:18 PM

No, only if your HDD is set in PIO mode will it run at 33MHz. It's most likely running in DMA mode.
"dmesg | grep DMA" should tell you.

mikieboy 08-03-2006 05:44 PM

Thanks for the replies.
"dmesg | grep DMA" gave the following output:

SIS5513: SiS 962/963 MuTIOL IDE UDMA133 controller
ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:DMA
hda: 234441648 sectors (120034 MB) w/2048KiB Cache, CHS=14593/255/63, UDMA(100)

It looks as if hda (my hard drive) is running in DMA mode. Is that right?

EDIT: I don't have a clue what the smilies are doing in there but I can't get rid of them!

ciotog 08-04-2006 12:38 AM

Yes, all four of your drives are running in DMA mode. Your hda in particular is running in UDMA100 (100 MB/s) mode.

The smilies are because that's what you get when you put a colon next to a capital D, unless you turn of smilies :)

If they really bother you, click on "edit" then "go advanced" and check "disable smilies" at the bottom.

mikieboy 08-04-2006 01:44 PM

Once again, many thanks

Mikie :)


All times are GMT -5. The time now is 04:05 AM.