LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-03-2008, 10:20 PM   #1
gvp87
Member
 
Registered: Mar 2007
Location: Boston
Distribution: Ubuntu Gutsy
Posts: 50

Rep: Reputation: 15
wifi driver installed, but not working on Ubuntu Gutsy


I just installed the driver for my Broadcom mini-pci wifi card, using Ubuntu's Restricted Drivers' installation. According to my system, my wifi card is up and running, but I still can't connect. I don't get why...

the light on my computer showing the wifi access is now working (it never did before)
I entered in my essid and wep key into ubuntu's network Settings manager, and I set the wireless capability to active.

I even tried using the command "sudo dhclient eth1" and it still can't connect. eth1 is my wireless interface.

I can't figure out what's wrong. What am I missing?

thanks
giuseppe
 
Old 02-04-2008, 04:26 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
First test:
Code:
sudo iwlist eth1 scan
Does this produce scan results? It should. If you find your network there, pick up the ESSID.

Second: If the AP only uses weak WEP encryption, (WPA would be a lot better), you can test the connection easily with iwconfig. Like this:

Code:
sudo iwconfig eth1 essid "network_essid_here" key s:ascii_password_here
If you instead use hex password (not ascii), use 'key hex_password_here' instead of 'key s:ascii_password_here' (leave s: off).

That should get you connected - the only point you can type wrong there is the password (use s: if it's in ASCII like it usually is, and don't use it if you have a hex password; if you want to make sure, use quotes around the password too). If it succeeded,
Code:
sudo dhcpcd eth1
should give you an IP within a moment, and then you should be online. If the iwconfig command tells you there is no such interface, try running 'ifconfig eth1 up' first to bring the interface up.

If you use WPA encryption instead, like you should, you need to setup wpa_supplicant OR use NetworkManager (the graphical thing). NetworkManager is easier - just point, click and type password - but wpa_supplicant isn't that difficult either.

If iwlist eth1 scan brings scan results, driver and hardware are working fine. If it doesn't, check the driver. If scanning works but connecting doesn't, it's very probably a problem in the encryption key; WEP encryption should be supported by all wireless hardware (WEP too nowadays, though) and Linux wifi drivers, so that ought not be a problem. Of course you can try without encryption first if you like; turn off all encryption from the access point (note: this is both foolish and dangerous, so don't leave it like that for long!), then just run
Code:
sudo iwconfig eth1 essid "network_essid_here"
sudo dhcpcd eth1
and see if it works. If not, there is something seriously wrong with your configuration or driver. If it works, turn on encryption and try to connect with the right key (iwconfig for WEP keys or no encryption, wpa_supplicant for WPA encryption, or NetworkManager in either case).
 
Old 02-05-2008, 03:18 PM   #3
gvp87
Member
 
Registered: Mar 2007
Location: Boston
Distribution: Ubuntu Gutsy
Posts: 50

Original Poster
Rep: Reputation: 15
okay, so I did the "iwconfig" command with my essid and my key. I did the "dhcpcd" command after, and I got the output "Error, eth1: timed out."

So i did the "ifconfig eth1 up" and then did the 'iwconfig', but still nothing.

But I am getting scan results, so that's good.

Also, just before running all these commands, i unplugged my network cable to test out the wifi, but after running all these, I couldn't connect back with a wired connection. Usually when I plug in my cable, the lights the port on my computer turn on, but those aren't even lit.

I did 'sudo ifdown eth0' to reset the interface, then i did 'sudo ifup eth0' and it output 'no DHCPOFFERS received'.

I'm on another computer right now, bc I can't use wired or wireless connection!! lol


I didn't think any of those commands that I ran wouldn've changed any eth0 settings. How can I get them both up and running?

giuseppe

Last edited by gvp87; 02-05-2008 at 03:19 PM. Reason: unclear wording
 
Old 02-05-2008, 03:42 PM   #4
gvp87
Member
 
Registered: Mar 2007
Location: Boston
Distribution: Ubuntu Gutsy
Posts: 50

Original Poster
Rep: Reputation: 15
I figured it out.

I can't get the wired connection back up, but i got the wireless connection to run.

Just for fun, i typed in "iwconfig", and noticed in the output, that there was no ESSID or KEY(the entries next to them said 'any'), which I thought was strange, since i had just entered it in with a previous command to iwconfig.

i typed in 'iwconfig eth1 essid "essid" '

i checked iwconfig, and my essid was there!

I did it again with my key, and it worked.

I used your dhcpcd command, and iwas connected!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless not working Ubuntu Gutsy (7.10) JMC8501 Linux - Laptop and Netbook 38 10-30-2008 05:23 AM
Retrieve a Wep key (wifi) in Ubuntu Gutsy Fulano X Linux - Newbie 10 02-04-2008 03:38 PM
Sound is nt working on HP laptop running on Ubuntu 7.10 gutsy dherath10 Linux - Newbie 1 12-26-2007 01:36 AM
LXer: Ubuntu Gutsy With ExpressCard - Working Options LXer Syndicated Linux News 0 11-06-2007 04:40 PM
ATI Driver installed. Ubuntu 5.10. not working javb Ubuntu 3 01-22-2006 06:51 PM


All times are GMT -5. The time now is 08:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration