LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Wifi card connects to router, but not internet (http://www.linuxquestions.org/questions/linux-hardware-18/wifi-card-connects-to-router-but-not-internet-404707/)

Mbaum 01-17-2006 08:38 PM

Wifi card connects to router, but not internet
 
I don't know exactly what the problem is here,

https://wiki.ubuntu.com/DLinkDWL520E1

Those were the install instructions for the card (DLinkDWL520E1), and after I did that the Kwifimanger was able to connect to routers in the area(but still not scan, not sure that matters since it seems to be a common problem). But when I try and enable the card in network settings, it just goes right back to being disabled. I have found lots of info on how to get this cards FW isntalled right, but nothing on the problem I have. I assume since the card is in fact connecting that the FW is installed and the problem is that for whatever reason it doesn't want to give it credit for being a network interface.


iface wlan0 inet dhcp
hostname localhost
fw_primary /etc/firmware/pm010102.hex
fw_secondary /etc/firmware/rf010803.hex
wireless_mode managed


That is what it says in the config for /interfaces sans the essid and pw, other than that it looks exactly like that. I don't know if that helps at all, but thats the only file I really tinkered with, so....

This is my first serious install of Linux to be honest, but I have used it in the past at school and at friends houses etc, so I'm not a total newbie. I have looked all over trying every search combo I could think of for this problem, and I couldn't find it. I'm thinking maybe there is a term I just don't know or something.

Half_Elf 01-18-2006 10:11 AM

How do you know you are connected to your router? Do you get any ip address from it?
Can you post the output of "ifconfig" here (and tell us which one of these interface is the wireless card).
The output of "route -n" could be useful too.

If you can reach the router but not internet, the problem is most likely on your router side, or something is very wrong on your linux.

Xerop 01-18-2006 10:33 AM

Check you host file too. try turning off other interfaces. Also you could try some static configurations.

Mbaum 01-18-2006 05:05 PM

Quote:

Originally Posted by Half_Elf
How do you know you are connected to your router? Do you get any ip address from it?
Can you post the output of "ifconfig" here (and tell us which one of these interface is the wireless card).

eth0 Link encap:Ethernet HWaddr 00:0E:A6:44:9A:88
inet addr:192.168.0.116 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20e:a6ff:fe44:9a88/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1827 errors:0 dropped:0 overruns:0 frame:0
TX packets:1775 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1593651 (1.5 MiB) TX bytes:326996 (319.3 KiB)
Interrupt:22 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:31 errors:0 dropped:0 overruns:0 frame:0
TX packets:31 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1572 (1.5 KiB) TX bytes:1572 (1.5 KiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wifi0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-65-74-00-00-00-00-00-00-00-00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:18 Memory:f0a7a000-f0a7b000

And the one that matters...

wlan0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:18 Memory:f0a7a000-f0a7b000


Quote:

The output of "route -n" could be useful too.
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
0.0.0.0 192.168.0.2 0.0.0.0 UG 0 0 0 eth0

I'm not sure this is worth anything, because for whatever reason now my card just will not come up and it isn't listed there.
Quote:

If you can reach the router but not internet, the problem is most likely on your router side, or something is very wrong on your linux.
I will edit this post in a few mins when I boot back into linnux with those commands you just shot oout, but I know for a fact my router works just fine. I know I'm logged in because the router says my mac adress is logged in, I know the wifi works because I've tried other computers using wifi, as well as connected to 3 routers in the area(people and their unsecure wireless are good for testing)

I can't explain why but last night I got this working, then when I restarted it I was back in the same boat. When I loaded up GNOME isntead of KDE, and enabled the card that way, it worked. For whatever reason none of the cards were enabled when I logged in. I noticed that when Kubuntu was loading up that the "configing networking interfaces" went by right away, normally it doesn't do that, normally it takes quite a while. I also couldn't enable it in KDE, only in GNOME. In KDE it shuts off right after you enable it. And now again I can't even get it working right in GNOME. It says(but i'm not sure it really does)activates the card, and it's listed in the GNOME networking as the default but again, no internet.

Mbaum 01-18-2006 05:07 PM

Quote:

Originally Posted by Xerop
Check you host file too. try turning off other interfaces. Also you could try some static configurations.

Will try the static ones, however I have disabled every other interfaced 3-4 times and restarted etc, no luck. In fact there is an interface called wifi0 I can't seem to get rid of at all, I'm on wlan0.

Also...host file? Sorry but I have no idea how to get at that one ;(

Half_Elf 01-18-2006 06:49 PM

wlan0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1


Your interface have no IP, so it's not even getting an IP from the router (so, it's not connected to it). I suggest that you run a dhcp client by hand (instead of using your distribution script) for now to find out what's the problem. Try "dhcpcd wlan0" or "dhclient". Also, just in case, make sure you are associated to the correct acces point using "iwconfig"

Mbaum 01-18-2006 06:55 PM

Quote:

Originally Posted by Half_Elf
wlan0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1


Your interface have no IP, so it's not even getting an IP from the router (so, it's not connected to it). I suggest that you run a dhcp client by hand (instead of using your distribution script) for now to find out what's the problem. Try "dhcpcd wlan0" or "dhclient". Also, just in case, make sure you are associated to the correct acces point using "iwconfig"


You're right, it isn't connecting anymore. I cann't figure out why obviously,but everything keeps changing. I even got ON the internet last night, which was then all undone by a restart. I'll try that and see what I get though. I did try making everything static, on both sides. It worked for my eth0(which worked on dhcp anyways), but doesn't change anything about the way wlan0 acts.

Mbaum 01-19-2006 04:39 PM

Ok I got this working. Somehow the /etc/networking/interfaces part that is special to this card got deleted. I then copy/pasted the info back in there, not realizing that the wiki page(as listed up top) has a 3 where a 4 should be in the file name, I didn't copy/paste the first time and didn't notice that the filenames were wrong. That was the entire problem it seems. Prior to that when I could connect but couldn't get internet on it, it seems that is fixed by using only a static IP. DHCP sometimes works, mostly doesn't work. Another problem was I didn't know how to set a default interface, and the KDE GUI doesn't have that option, GNOME does.

So for anyone who googles this and sees that link, that thing works like a charm with a static IP. Also I think this way will only work for ubuntu, since ubuntu has the ability to setup interfaces to load FW on bootup, I'm not sure others do, but I know at the very least it's a new feature of ubuntu 5.10.

And thanks for the help on this one, as stupid of an issue as it was, the static IP thing seemed to fix the problem I was having earlier.


All times are GMT -5. The time now is 12:55 PM.