LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Wheel Scrolling (http://www.linuxquestions.org/questions/linux-hardware-18/wheel-scrolling-143266/)

123 Paul 02-07-2004 04:51 AM

Wheel Scrolling
 
Ok, this is really bugging me, and it must be really simple to sort out!

I have a M$ IntelliMouse ps2, it all works fine, apart from the I cant use the wheel for scrolling.

Please can some one tell me how - I am using Mandrake! Simple steps please, as I am still learning :newbie:

b0uncer 02-07-2004 05:11 AM

I think this one is easy :) just open your /etc/X11/XF86Config (or, if that's not your XF's config, then the one that is - but this is usually the one) and locate your mouse's config at Section "Input Device", it should look somehow like this:

Identifier "mouse1"
Driver "mouse"
Option "Protocol" "imps/2"
Option "Device" "psaux"

or whatever - these depend on _your_ own mouse config. Now add there the following line:

Option "ZAxisMapping" "4 5"

and that's it. If it doesn't work yet, then you might want to see if adding these lines help (to make sure the wheel is accepted as a wheel, not as a button - these are usually not needed):

Option "Emulate3Buttons" "off"
Option "Buttons" "3"

I guess you just need the ZAxisMapping -line. Save & restart your X, and enjoy! :)

EDIT:

to make this simple, read these too if you don't understand something (even tough I'm pretty sure you do :) )

- I'm pretty sure you can edit XF's config while in X; just restart after editing.
- Use any text editor you wish to edit /etc/X11/XF86Config , like nano, Bluefish, vim, emacs, somekind of "notepad", whatever - that's not important. Just get the file open somehow ;)
- I think you must be root to do this, so if you're logged in as normal user, start the editor you use from terminal and before starting, su to root. Or then just log in as root :) it's easier
- After saving, if you're in X, and nothing seems to happen, make sure you get your X truly restarted - either do a CTRL+ALT+BACKSPACE or then open terminal and do a "killall X" and start it again. Logout/login should do, though.

grayswander 02-07-2004 05:45 AM

Look at your XF86Config.

The mouse configuration should be:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

The lines
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
say that you have a wheel and third button. Here you can see, that wheel is registerea as buttons 4 an five.

123 Paul 02-07-2004 09:38 AM

thats odd, I was playing around with the mouse options in the mandrake control centre, but nothing happened, but after a reboot the scrollong seems to be working now :D

thanks for you help anyway

grayswander 02-07-2004 03:49 PM

Possibly, your control center has updated the XF86Config file, X is to be restarted in order to these changes to activate.

b0uncer 02-09-2004 01:38 PM

yes, indeed..that's because XFree86Config is (as far as I know) read through only when X is started, so the changes that are made in it, are (re)loaded only when X starts again. you can see this in /var/log/Xfree-something logfile, in a line that tells which config file is being used.

it's a good habit, if not automatically made (I think it is), to make a backup copy of XFree86Config when making big changes. this prevents accidents :)


All times are GMT -5. The time now is 02:47 PM.