LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-31-2005, 01:39 PM   #1
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Rep: Reputation: 30
what is wrong with this /etc/fstab entry?


/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859,codepage=850,noauto,ro,exec,users 0 0

This line in /etc/fstab is set at installation. I have not touched it.
In order to mount the cdrom, I have to type as root, mount /mnt/cdrom.
Then, I can not umount it. I have to reboot to access it again.
Nothing else is open and I am in '/' as root.


Why?

dlw
 
Old 01-31-2005, 03:16 PM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 77
Quote:
In order to mount the cdrom, I have to type as root, mount /mnt/cdrom.
This is because of the "noauto" option.

Quote:
Then, I can not umount it. I have to reboot to access it again.
What command, and what error do you get when you try this?

I am not sure the ramifications of having iocharset, codepage, and the other options you have there. In my fstab I have simply:
Code:
/dev/hdc      /mnt/cdrom      iso9660         noauto,ro          0 0
and it works as expected. If you want, comment out your line and try mine....you never know.
 
Old 01-31-2005, 03:17 PM   #3
marlor
Member
 
Registered: May 2004
Distribution: Slackware C
Posts: 274

Rep: Reputation: 30
try something more simple

Code:
/dev/cdrom       /mnt/cdrom       iso9660     noauto,user,ro   0   0
and about unmounting
leave the 'cdrom' directory first and then unmount

in term(console) if you are in /mnt/cdrom
and you try:
Code:
umount /mnt/cdrom
it will not work, doesn't work with me atleast
first leave the directory
do a
Code:
cd ..
to end up in /mnt
and then try to umount

hope i helps

good luck
 
Old 01-31-2005, 03:42 PM   #4
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
I added your line and get the same results.
Click on 'home icon', click on 'mnt', click on 'cdrom' and there is nothing but a blank screen where there should be folders.

Change to su then
mount /mnt/cdrom
The folder icons show up correctly.

Then I can not get out of /mnt/cdrom
I close everything and the folders that appeared with mount /mnt/cdrom are still there even with the cd out. I can insert a different cd and the old cd's folders are still listed.

I have to reboot to get rid of them.
 
Old 01-31-2005, 03:54 PM   #5
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 77
Quote:
Click on 'home icon', click on 'mnt', click on 'cdrom' and there is nothing but a blank screen where there should be folders.

Change to su then
mount /mnt/cdrom
The folder icons show up correctly.
Again, this is because of "noauto", but because a cd is removable media you _do_ want to leave it there.
Quote:
Then I can not get out of /mnt/cdrom
What do you mean by this? What are you using to unmount the disk. You need to do this manually you know...you can't just yank the cd out (in fact, you shouldn't be able to).

After you close any filebrowsers and cd away from /mnt/cdrom what happens when you run "umount /mnt/cdrom"?

We need some sort of error message to diagnose this further...

Last edited by bulliver; 01-31-2005 at 03:56 PM.
 
Old 01-31-2005, 05:07 PM   #6
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
[don@localhost don]$ su
Password:
[root@localhost don]# umount /mnt/cdrom
[root@localhost don]# mount /mnt/cdrom
[root@localhost don]# cd /mnt/cdrom
[root@localhost cdrom]# ls
distfiles/ isolinux/ snapshots/ x86-packagelist-2004.3.txt
docs/ livecd.squashfs* stages/ x86-release-notes.txt
[root@localhost cdrom]# cd /
[root@localhost /]# umount /mnt/cdrom
[root@localhost /]#
I apologize for not being clear.
All works as 'root' in a konsole.
It's when i'm on as a 'user' that it will not work properly in konquerer.
In konquerer is where I have to reboot to get /mnt/cdrom to change.
When I look at whats on a cd in konquerer I can not get the folders to change after taking that cd out and inserting another without rebooting. The same folders are shown as if the other cd is still there.

There is no error message. It simply will not change.
I can take a cd out as well as insert a cd even though it is mounted via a konsole. as root.
 
Old 01-31-2005, 05:23 PM   #7
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 77
Ok, kde problem then. Just to be absolutely clear: Are you navigating away from /mnt/cdrom in konqueror before you unmount it? If you leave the browser open to /mnt/cdrom then unmount it manually (using konsole) and mount a different disk then this would explain the freezeup.

Or is it that as soon as you navigate to /mnt/cdrom in konqueror it freezes up?

Quote:
I can take a cd out as well as insert a cd even though it is mounted via a konsole. as root.
That shouldn't be. Your cd-rom drive should refuse to open unless it is properly unmounted. I don't know what to tell you about this...
 
Old 01-31-2005, 05:51 PM   #8
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Without a console open.
When I open konquerer, click on 'mnt', 'cdrom' no folders show up even though a cd is in the cdplayer. I close konquerer. (cd not mounted)
Open a console, change to su, mount /mnt/cdrom then 'ls' there are files.
close console, open konquerer (cd mounted)
The files now show in /mnt/cdrom. close konquerer, unmount cd in console, close console.
Open konquerer, /mnt/cdrom, the files still show and I can not get rid of them without rebooting.

Yes, I can open and close the cd at will whether mounted or unmounted.

In the past I've been able to open and close /mnt/cdrom in konquerer without having to use a console to mount the cd. This is my prefrence since I am the only user.
 
Old 01-31-2005, 06:09 PM   #9
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 77
Ok thanks for that. I understand perfectly now... this sounds like a bug in konqueror
or maybe just kde, as it seems to be cacheing the contents of /mnt/cdrom and not updating when it changes.

I have no idea what to do here, but if you post the version # of kde (and konq) I can help you google for bugs
 
Old 01-31-2005, 06:18 PM   #10
d1l2w3
Member
 
Registered: May 2004
Location: Amboy WA USA
Distribution: Mandriva 2007
Posts: 366

Original Poster
Rep: Reputation: 30
Both kde and konquerer are 3.2.3

Thanks for the help.
dlw
 
Old 02-01-2005, 12:15 AM   #11
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
You can use
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859,codepage=850,noauto,ro,exec,users 0 0

The user and users are conflicting with each other. user means only a certain user can mount which is root. users means anybody can mount it. If you take out user, anybody should be able to mount because of the users option. I suggest changing codepage to 437, but neither iocharset and codepage should be included for CD-ROM/DVD-ROM drives. The iocharset and codepage is used during writing to a vfat, msdos, or fat partition. I suggest adding unhide just in case if you want to install some games like Unreal Tournament or other programs.

You have to unmount before ejecting. It should be locking the drive after you mount it, so pushing the eject button on the drive should not work. Also typing eject should automatically unmount the drive.

In any OS, ejecting the CD and not putting a disc in. Then closing it. This will force the OS to flush its contents. Though Linux does not have this problem, but Windows and DOS does.

You can run hdparm -f /dev/hdc as root or su.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/etc/fstab entry ryedunn Linux - Newbie 1 01-17-2005 02:45 AM
fstab entry changed by system to wrong device cmbguy Linux - General 2 08-19-2004 10:04 PM
FC2 FSTAB Entry jeopardyracing Linux - Newbie 2 07-10-2004 10:53 AM
FC2 FSTAB Entry jeopardyracing Linux - Networking 6 06-27-2004 07:57 PM
fstab entry albean Linux - Newbie 1 12-04-2002 02:33 PM


All times are GMT -5. The time now is 03:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration