LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-09-2004, 09:25 PM   #1
haimeltjnfg
Member
 
Registered: May 2004
Distribution: debian
Posts: 235

Rep: Reputation: 30
What is adsp0? and why cat /dev/urandom >/dev/adsp0 give me "no such device"?


Debian Sarge,
Sound Blaster Live Value(oem, the one with the digital output)
digital speakers
Alsa 1.0.3

here's the deal:
I can't get kde system notifications to play, but nearly everything else will play. i read somewhere it might be because of adsp0. so i tested adsp0.

running cat /dev/urandom >/dev/dsp0 plays static.

# cat /dev/urandom >/dev/adsp0
bash: /dev/adsp0: No such device

would this be why i can't get the system notifications to work? is this because oss emulation is not working?

in addition to this, my mixer settings are very touchy, i need to have IEC958 Optical Raw muted, and SB Live Analog/Digital Output Jack unmuted to hear sound.

Sorry about the long question

Thanks!
 
Old 05-09-2004, 10:34 PM   #2
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
adsp0 would be for alsa digital signal processor 0, but I don't think they use that device node any longer, wherever you read that may indeed be old info.

KDE typically uses the aRts sound daemon for system sounds, is that up and running?

Cheers,

Finegan
 
Old 05-09-2004, 10:54 PM   #3
haimeltjnfg
Member
 
Registered: May 2004
Distribution: debian
Posts: 235

Original Poster
Rep: Reputation: 30
yes it is. i actually had it running, but after restarting alsa it stopped.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Terminal Questions? "cat /dev/tty1" Why Not? chris318 Linux - Security 1 02-25-2005 09:57 PM
Terminal Questions? "cat /dev/tty1" Why Not? chris318 Linux - Newbie 3 02-24-2005 10:59 PM
V4L: "cat /dev/video0: no such device"; to be sure not supported? jago25_98 Linux - Hardware 1 01-27-2005 04:04 PM
"unable to find device node for /dev/x in /dev!" during install zombiedeth *BSD 0 02-02-2004 02:38 AM
why did cat /dev/urandom send my printer insane ? qwijibow Linux - Newbie 1 12-01-2003 03:41 AM


All times are GMT -5. The time now is 07:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration