LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Western Digital USB External HD not Mounting (http://www.linuxquestions.org/questions/linux-hardware-18/western-digital-usb-external-hd-not-mounting-152881/)

zakmtbike 03-03-2004 12:08 AM

Western Digital USB External HD not Mounting
 
Hi All,
I know these posts can be redundant but...I recently purchased a 120 gig Western Digital USB/Firewire HD....and just can't seem to access it using linux (Distro: RH 9 Ker. 2.4.20-30.9) I should also note that I am using USB 1.1.
I can't seem to be able to mount it. This is sorta of a newbie question I've only been using Linux for a year. The dmesg dump is:

hiddev0: USB HID v1.10 Device [Western Digital External HDD] on usb1:16.1
usb.c: USB disconnect on device 00:07.2-2 address 15
usb.c: USB disconnect on device 00:07.2-2.2 address 16
hub.c: new USB device 00:07.2-2, assigned address 17
hub.c: USB hub found
hub.c: 4 ports detected
hub.c: new USB device 00:07.2-2.2, assigned address 18
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 18
usb-uhci.c: interrupt, status 2, frame# 1339
usb_control/bulk_msg: timeout
hiddev0: USB HID v1.10 Device [Western Digital External HDD] on usb1:18.1
usb-uhci.c: ENXIO 80001280, flags 0, urb cbefc800, burb cf57da00
usbdevfs: USBDEVFS_CONTROL failed dev 18 rqt 128 rq 6 len 57 ret -6
usb-uhci.c: ENXIO 80001280, flags 0, urb cf57da00, burb cbefc800
usbdevfs: USBDEVFS_CONTROL failed dev 18 rqt 128 rq 6 len 9 ret -6
usb-uhci.c: ENXIO 80001280, flags 0, urb cbefc800, burb cf57da00
usbdevfs: USBDEVFS_CONTROL failed dev 18 rqt 128 rq 6 len 9 ret -6
usb-uhci.c: ENXIO 80001280, flags 0, urb cbefc800, burb cf57da00
usbdevfs: USBDEVFS_CONTROL failed dev 18 rqt 128 rq 6 len 9 ret -6

The device shows up in /proc/scsi/usb-storage-0/1 that entry is:
Host scsi1: usb-storage
Vendor: Western Digital
Product: External HDD
Serial Number: 574D41454B32333830323639
Protocol: Transparent SCSI
Transport: Bulk
GUID: 105804004b32333830323639
Attached: Yes

After much avail I still have yet to get the HD mounted /dev/sda1 is configured for a jump drive (PNY Attache). If anyone has any suggestions on how to mount this drive
it would be helpful. Right now the drive is formated as NTFS but I have no data on it. I plan on running mkfs.ext3 on it to convert it to an ext3 file system I just need to figure out what device name to use. Also the device shows up in system devices when I run Gnomes hardware browser.

Thanks in advance for all of you help,
Zach

zakmtbike 03-03-2004 12:11 AM

Oops I forgot the lsmod dump is:

Module Size Used by Not tainted
msr 2312 0 (unused)
sd_mod 13516 0 (autoclean)
usb-storage 74656 1
maestro3 30960 1 (autoclean)
ac97_codec 14568 0 (autoclean) [maestro3]
soundcore 6404 2 (autoclean) [maestro3]
parport_pc 19076 1 (autoclean)
lp 8996 0 (autoclean)
parport 37056 1 (autoclean) [parport_pc lp]
autofs 13268 0 (autoclean) (unused)
ds 8680 4
yenta_socket 13504 2
pcmcia_core 57216 0 [ds yenta_socket]
tulip 43840 1
ipt_REJECT 3992 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 15096 2 [ipt_REJECT iptable_filter]
sg 36524 0 (autoclean)
sr_mod 18136 0 (autoclean)
ide-scsi 12208 0
scsi_mod 107544 6 [sd_mod usb-storage sg sr_mod ide-scsi]
ide-cd 35712 0
cdrom 33728 0 [sr_mod ide-cd]
nls_iso8859-1 3516 1 (autoclean)
nls_cp437 5148 1 (autoclean)
vfat 13004 1 (autoclean)
fat 38808 0 (autoclean) [vfat]
keybdev 2976 0 (unused)
mousedev 5556 1
hid 22244 0 (unused)
input 5856 0 [keybdev mousedev hid]
usb-uhci 26412 0 (unused)
usbcore 79040 1 [usb-storage hid usb-uhci]
ext3 70784 2
jbd 51924 2 [ext3]


Thanks,
Zach

bxb32001 03-03-2004 06:28 AM

I just bought an external hardrive myself, 20 GB via USB. All my 128 mb pen drives work but when I try the 20GB one Fedora couldn't seem to be able to mount it. Yeah, I'd like to dig out some sort of solution to this.

- bxb32001

bxb32001 03-05-2004 10:59 PM

*bump*

anyone?

bxb32001 03-07-2004 06:49 PM

I was having problems with my 20 gig external usb drive. Fedora, while no problems whatsoever with pen drives, couldn't seem to mount this one.

Er, I have seen it mounted in another system.... in Lindows (no empowered/maximized fireballs please) I can get it to mount but only as root. As a regular user it also wouldn't mount.

(note: copied and pasted from another relevant thread)

zakmtbike 03-08-2004 07:21 PM

Thanks Everyone....got the HD mounted using a firewire card...formatted the drive a badda-bing-badda-boom 120 gigs of extra space...Thanks for entertaining my question.
-Zach


All times are GMT -5. The time now is 09:09 AM.