LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-12-2007, 01:02 PM   #1
Ian_Hawdon
Member
 
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 317

Rep: Reputation: 30
Unhappy [SOLVED] Weird Screen resolution problem


Hi,

Having a weird problem with my new openSUSE 10.3 installation...

My laptop has an intel graphics card, and has had the 915resolution program patch the vbios for the 1280x800 resolutions

This works, but some programs shrink to 1024x768

http://www.op-ezy.co.uk/system_/screen-weird2.png

anyone figure this out?

Last edited by Ian_Hawdon; 10-31-2007 at 04:30 AM. Reason: to say it's solved!
 
Old 10-14-2007, 08:20 AM   #2
Ian_Hawdon
Member
 
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 317

Original Poster
Rep: Reputation: 30
bump

btw, here is some more info about me gfx card:

Code:
14: PCI 02.0: 0300 VGA compatible controller (VGA)
  [Created at pci.301]
  UDI: /org/freedesktop/Hal/devices/pci_8086_27a2
  Unique ID: _Znp.DKUnSX7wZ50
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "QUANTA 945 GM"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x27a2 "945 GM"
  SubVendor: pci 0x152d "QUANTA Computer Inc"
  SubDevice: pci 0x0753 
  Revision: 0x03
  Memory Range: 0xdc100000-0xdc17ffff (rw,non-prefetchable)
  I/O Ports: 0x1800-0x1807 (rw)
  Memory Range: 0xc0000000-0xcfffffff (rw,prefetchable)
  Memory Range: 0xdc200000-0xdc23ffff (rw,non-prefetchable)
  IRQ: 17 (228875 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d000027A2sv0000152Dsd00000753bc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: intel
  Driver Info #1:
    XFree86 v4 Server Module: intel
    3D Support: yes
    Extensions: dri
  Config Status: cfg=no, avail=yes, need=no, active=unknown

15: PCI 02.1: 0380 Display controller
  [Created at pci.301]
  UDI: /org/freedesktop/Hal/devices/pci_8086_27a6
  Unique ID: ruGf.H0hfo4nhQs6
  SysFS ID: /devices/pci0000:00/0000:00:02.1
  SysFS BusID: 0000:00:02.1
  Hardware Class: graphics card
  Model: "QUANTA Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x27a6 "Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller"
  SubVendor: pci 0x152d "QUANTA Computer Inc"
  SubDevice: pci 0x0753 
  Revision: 0x03
  Memory Range: 0xdc180000-0xdc1fffff (rw,non-prefetchable)
  Module Alias: "pci:v00008086d000027A6sv0000152Dsd00000753bc03sc80i00"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
 
Old 10-21-2007, 07:57 AM   #3
Ian_Hawdon
Member
 
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 317

Original Poster
Rep: Reputation: 30
what was i thinking? I forgot to send my xorg.conf file!

Code:
# /.../
# SaX generated X11 config file
# Created on: 2007-10-20T13:31:45+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
EndSection

Section "Module"
  Load         "freetype"
  Load         "type1"
  Load         "dbe"
  Load         "glx"
  Load         "extmod"
  Load         "dri"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "gb"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "synaptics"
  Identifier   "Mouse[1]"
  Option       "Device" "/dev/input/mice"
  Option       "Emulate3Buttons" "on"
  Option       "Name" "Touchpad"
  Option       "SHMConfig" "on"
  Option       "Vendor" "Synaptics"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[3]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  DisplaySize  331 207
  HorizSync    30-52
  Identifier   "Monitor[0]"
  ModelName    "1280X800@60HZ"
  Option       "DPMS"
  VendorName   "--> LCD"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
  Modeline 	"1280x800" 69.75 1280 1328 1360 1440 800 803 809 823 +HSync -VSync
  Modeline 	"1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
  Modeline 	"1024x768" 55.00 1024 1072 1104 1184 768 771 775 790 +HSync -VSync
  Modeline 	"800x600" 38.22 800 832 912 1024 600 601 604 622
  Modeline 	"800x600" 34.75 800 848 880 960 600 603 607 617 +HSync -VSync
  Modeline 	"1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
  Modeline 	"1280x768" 82.91 1280 1344 1480 1680 768 769 772 796
  Modeline 	"1024x768" 66.33 1024 1080 1184 1344 768 769 772 796
  Modeline 	"1280x600" 63.55 1280 1336 1464 1648 600 601 604 622
  Modeline 	"1024x600" 50.60 1024 1064 1168 1312 600 601 604 622
  Modeline 	"800x600" 39.49 800 832 912 1024 600 601 604 622
  Modeline 	"768x576" 36.13 768 792 872 976 576 577 580 597
  Modeline 	"640x480" 24.70 640 656 720 800 480 481 484 498
EndSection

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x800" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x800" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x800" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x800" "1024x768" "800x600" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "945 GM"
  BusID        "0:2:0"
  Driver       "intel"
  Identifier   "Device[0]"
  Option       "SaXDualHead"
  Option       "monitor-LVDS" "Monitor[0]"
  Option       "SaXDualMonitorVendor" "--> VESA"
  Option       "SaXDualOrientation" "LeftOf"
  Option       "SaXDualResolution" "1280x800"
  Option       "SaXDualMode" "Clone"
  Option       "SaXDualHSync" "31-50"
  Option       "SaXDualMonitorModel" "1024X768@60HZ"
  Option       "SaXDualVSync" "50-60"
  Option       "SaXExternal" "Identifier&EXT+DisplaySize&+VendorName&--> VESA+PreferredMode&1280x800+HorizSync&31-50+ModelName&1024X768@60HZ+VertRefresh&50-60"
  Option       "usevnc" "no"
  Screen       0
  VendorName   "Intel"
EndSection

Section "Monitor"
  HorizSync    31-50
  Identifier   "EXT"
  ModelName    "1024X768@60HZ"
  Option       "PreferredMode" "1280x800"
  VendorName   "--> VESA"
  VertRefresh  50-60
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  InputDevice  "Mouse[3]" "SendCoreEvents"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection
 
Old 10-30-2007, 01:13 PM   #4
Ian_Hawdon
Member
 
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 317

Original Poster
Rep: Reputation: 30
hey hey, i finally fixed it!!!!!

All i had to do, was change the driver from "intel" to "i810"

works great now
 
Old 10-31-2007, 12:41 AM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Congrats on solving the problem and thanks for posting back with the update, as it may be extremely helpful to future readers who have the same question
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
weird black screen problem ATi X700 laissezfaire Linux - Laptop and Netbook 6 02-12-2007 10:10 PM
Login screen weird problem TigerLinux Suse/Novell 5 10-05-2005 06:47 PM
Weird with screen resolution using NVIDIA javb Linux - Laptop and Netbook 1 02-06-2005 06:43 PM
weird problem with gnome splash screen +0+4|_ n00b Linux - Newbie 1 01-31-2005 12:32 AM
weird name resolution problem kreilk Linux - Networking 1 07-04-2004 06:47 AM


All times are GMT -5. The time now is 12:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration