LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-09-2005, 12:12 PM   #1
eegerda
LQ Newbie
 
Registered: Apr 2005
Location: NJ
Distribution: Centos 5.5
Posts: 15

Rep: Reputation: 1
Unhappy webcam issues


Hello everyone! Am somewhat new to linux and am having a small problem I can use some help with. Am running slackware 10.2 on a dell latitude c610. I just bough a new Micro innovations webcam, model is IC445c. For some reason I can't get this camera to work on my machine.

Here is the output from dmesg|tail when I plug the camera in:

usb 1-1.2: new full speed USB device using uhci_hcd and address 9
Linux video capture interface: v1.00
sn9c102: V4L2 driver for SN9C10x PC Camera Controllers v1:1.24a
usb 1-1.2: SN9C103 PC Camera Controller detected (vid/pid 0x0C45/0x60AF)
usb 1-1.2: No supported image sensor detected
usb 1-1.2: SN9C103 PC Camera Controller detected (vid/pid 0x0C45/0x60AF)
usb 1-1.2: No supported image sensor detected
usb 1-1.2: SN9C103 PC Camera Controller detected (vid/pid 0x0C45/0x60AF)
usb 1-1.2: No supported image sensor detected
usbcore: registered new driver sn9c102


Here is the output from lsusb

Bus 001 Device 009: ID 0c45:60af Microdia <-----I believe this is the webcam
Bus 001 Device 002: ID 05e3:0604 Genesys Logic, Inc.
Bus 001 Device 001: ID 0000:0000


The following modules are loaded when I plug the camera in
root@mypc:/dev# lsmod
Module Size Used by
sn9c102 88716 0
videodev 7232 1 sn9c102



I also set the rw permission on /dev/video0, here is the output of root@mypc:/dev# ls -l video*
root@mypc:/dev# ls -l video*
lrwxrwxrwx 1 root root 6 2005-10-04 15:28 video -> video0
crw-rw---- 1 root video 81, 0 2003-03-09 12:28 video0
crw-rw---- 1 root video 81, 1 2003-03-09 12:28 video1
crw-rw---- 1 root video 81, 2 2003-03-09 12:28 video2
crw-rw---- 1 root video 81, 3 2003-03-09 12:28 video3


I also made sure that my user name belong to the video group
root@ddg74u00011:/dev# grep -e video /etc/group
video::18:egerda


now this is the issue whenever I try to run any webcam software I get the following message:

egerda@mypc:~$ xawtv
This is xawtv-3.94, running on Linux/i686 (2.6.13)
seteuid(root): Operation not permitted
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such device
v4l2: open /dev/video0: No such device
v4l: open /dev/video0: No such device
no video grabber device available


or:

egerda@mypc:~$ spcagui
SpcaGui version: 0.3.5 date: 18 September 2005
video device /dev/video0
ERROR opening V4L interface
: No such device



One more thing, I searched in google to see if this model was supported but I did'nt find much information on the IC445C. What am I doing wrong? Am I using the wrong drivers?

By the way am using kernel 2.6.13 which I compiled my self.
 
Old 10-09-2005, 01:00 PM   #2
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
My webcam also uses a chipset recognized by the sn9c102 driver, but that driver doesn't appear to work properly. This driver works for me:

http://sourceforge.net/projects/sonix/

You'll have to compile it and such, and once compiled and installed, you'll have to rmmod the sn9c102 driver and add the following line to your /etc/modprobe.conf:

Code:
alias char-major-81-0 sonix-cam
to tell modprobe to load the sonix-cam module rather than the sn9c102 for the video0 device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How To Install A Usb Webcam [Genius WebCam on Suse 9.1 Personal] ofvergara Suse/Novell 4 11-29-2006 12:09 PM
Modem (Smartlink PCI) and webcam issues GPLed Linux - Hardware 2 10-23-2005 10:33 PM
I want to veiw my friends webcam, im using Lycoris, how do i c his webcam? CaffeinatedGamer Linux - Newbie 10 06-07-2005 07:23 PM
webcam issues fackamato Linux - Hardware 3 06-01-2005 10:36 PM
10.1 Issues. Wine, webcam,mozilla..... Maintech Mandriva 4 11-18-2004 10:45 PM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration