LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-09-2011, 02:59 PM   #1
photoelectricgeek
LQ Newbie
 
Registered: May 2009
Location: Mary Esther, Florida
Distribution: Ubuntu 11.04
Posts: 10

Rep: Reputation: 0
Question Webcam integrated microphone in dv6-3013nr


Hello and thanks ahead of time for your help.

I'm running Ubuntu 11.04 on my HP dv6-3013nr that came with Windows 7 64-bit.(now it's simply a linux system)

Product Spec's from HP website

I was setting up google video chat and discovered that the internal webcam worked fine but the microphone either wasn't being recognized or wasn't receiving input for some reason. I tried recording in the default sound recorder app that comes with Ubuntu with the same result.

My first thought was to check the HP website for drivers, but in the specifications I saw that my laptop has a, "HP TrueVision Webcam with integrated digital microphone," and there was nothing more than webcam drivers listed.

I'm not sure where to go from here, but I guess that's why I made a forum post; any ideas?

P.S. (The webcam runs perfectly fine regarding video)

Last edited by photoelectricgeek; 07-09-2011 at 03:01 PM. Reason: adding info I forgot to mention {the P.S.}
 
Old 07-09-2011, 07:21 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Hi photoelectricgeek, Welcome to LQ. It's likely a matter of telling the software which device to use for recording or input. Please post the output from the following.

Code:
$ sudo cat /proc/asound/card0/codec#* | grep Codec
$ arecord -l
Good luck. ;-)
 
Old 07-09-2011, 08:36 PM   #3
photoelectricgeek
LQ Newbie
 
Registered: May 2009
Location: Mary Esther, Florida
Distribution: Ubuntu 11.04
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
patrick@dv6-3013nr:~$ sudo cat /proc/asound/card0/codec#* | grep Codec
[sudo] password for patrick:
Codec: IDT 92HD81B1X5
patrick@dv6-3013nr:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
Output attached as a png

Sorry for the delayed response, I've been doing some stuff around the house and didn't get the notification but it's not a huge rush. No outstanding need for the mic just yet but I'd like to get it up and running.
Attached Images
File Type: jpg Screenshot.jpg (54.4 KB, 3 views)

Last edited by photoelectricgeek; 07-09-2011 at 08:39 PM.
 
Old 07-09-2011, 09:59 PM   #4
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Okay, looks like your mic is card 0, device 0. Can you record from any application?

Good luck. ;-)
 
Old 07-09-2011, 10:45 PM   #5
photoelectricgeek
LQ Newbie
 
Registered: May 2009
Location: Mary Esther, Florida
Distribution: Ubuntu 11.04
Posts: 10

Original Poster
Rep: Reputation: 0
Well I've tried recording in sound recorder and gmail's voice chat but I'll download audacity and see if it records.

EDIT: Audacity didn't work either. Still no sound.

Last edited by photoelectricgeek; 07-09-2011 at 10:55 PM.
 
Old 07-10-2011, 07:59 AM   #6
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Sounds (no pun intended) like your mic just isn't configured. Please post the output from the following.

Code:
$ cat /etc/modprobe.d/alsa-base.conf
What does alsamixer or any mixer say about the mic?

Good luck. ;-)
 
Old 07-10-2011, 03:40 PM   #7
photoelectricgeek
LQ Newbie
 
Registered: May 2009
Location: Mary Esther, Florida
Distribution: Ubuntu 11.04
Posts: 10

Original Poster
Rep: Reputation: 0
I would post the output but after running that code the mic worked.

Thanks for the help.
 
Old 07-11-2011, 10:00 PM   #8
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Glad you got it sorted.

Good luck. ;-)
 
Old 07-13-2011, 12:29 PM   #9
photoelectricgeek
LQ Newbie
 
Registered: May 2009
Location: Mary Esther, Florida
Distribution: Ubuntu 11.04
Posts: 10

Original Poster
Rep: Reputation: 0
weird.
The mic was working fine after I ran some of those things you told me to enter in Terminal but now after a system restart it's no longer recognizing the microphone in chrome or the sound recorders.

Here's the output to the last code you gave...

Quote:
patrick@dv6-3013nr:~$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
 
Old 07-14-2011, 06:22 PM   #10
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Try adding one of the following options to /etc/modprobe.d/alsa-base.conf

Code:
options snd-hda-intel model=ref
options snd-hda-intel model=auto
options snd-hda-intel model=hp
Add each option one at a time to see if any of those work. After each change, restart, the open alsamixer and see what's working. If any of these work, you can stop there.

Good luck. ;-)
 
Old 07-21-2012, 07:52 PM   #11
Jimi-James
LQ Newbie
 
Registered: Jul 2012
Posts: 7

Rep: Reputation: Disabled
I have the exact same problem with the exact same webcam (on an HP Touchsmart tm2-2150us) and the exact same terminal output, with one difference: my mic didn't randomly start working again after typing those commands. I tried the instructions in the post above mine, but they didn't work for me. They all changed what was in alsamixer, but my mic still failed to record no matter what settings I set the new channels to.

I'm running Kubuntu 12.04, and my mic did work in 11.04.

Last edited by Jimi-James; 07-21-2012 at 07:53 PM.
 
Old 08-02-2012, 09:44 PM   #12
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Hi Jimi-James, Welcome to LQ. Sorry it took so long to get back to you here. Could you please post the results from the commands in the above posts #2 & #6?

Good luck. ;-)
 
Old 08-02-2012, 09:52 PM   #13
Jimi-James
LQ Newbie
 
Registered: Jul 2012
Posts: 7

Rep: Reputation: Disabled
Code:
~$ sudo cat /proc/asound/card0/codec#* | grep Codec
Codec: IDT 92HD81B1X5
Codec: Intel IbexPeak HDMI
jimi@Death-Book:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
~$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
~$
 
Old 08-03-2012, 08:29 PM   #14
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Try adding the following to the end of /etc/modprobe.d/alsa-base.conf

Code:
options snd-hda-intel model=auto
Save and close the file, then restart the services or reboot and see if you have any additional mixer options for the mic.

Good luck. ;-)
 
Old 08-03-2012, 08:51 PM   #15
Jimi-James
LQ Newbie
 
Registered: Jul 2012
Posts: 7

Rep: Reputation: Disabled
I don't have any additional mixer options when I do that (I did press F4 to see the capture devices).
 
  


Reply

Tags
drivers, hp, laptop, microphone, webcam


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Webcam integrada não funciona (Integrated webcam does not work) wiltontsi Debian 5 04-15-2011 06:16 AM
Alienware M15X and Karmic: Webcam and Integrated Microphone tstrike Linux - Laptop and Netbook 4 03-07-2010 11:33 AM
usb webcam with integrated microphone wastingtime Linux - Hardware 0 10-19-2008 01:35 PM
Microphone issues on Intel integrated audio CWizard Linux - Hardware 1 10-18-2005 02:27 PM
Philips Usb Webcam - Microphone Integrated pingouinux Linux - Hardware 4 08-02-2004 04:07 PM


All times are GMT -5. The time now is 12:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration