LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-20-2006, 10:11 AM   #1
Ian_Hawdon
Member
 
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 317

Rep: Reputation: 30
Red face Webcam 0c45:60af Microdia, not assigned to /dev/video0 (new drivers won't compile)


Just bought a new web cam (my other one was rubbish, this one seems worse!)

I plug it in, this is what lsusb gives

Code:
linux:/home/ian/install/sn9c102-1.32 # lsusb
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 0a48:3260 I/O Interconnect
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 005: ID 0c45:60af Microdia
Bus 001 Device 001: ID 0000:0000
dmesg gives this:

Code:
usb 1-2: new full speed USB device using ohci_hcd and address 5
usb 1-2: SN9C103 PC Camera Controller detected (vid/pid 0x0C45/0x60AF)
usb 1-2: No supported image sensor detected
usb 1-2: SN9C103 PC Camera Controller detected (vid/pid 0x0C45/0x60AF)
usb 1-2: No supported image sensor detected
After a little research, i found i needed new SN9C102 drivers, so i downloaded them, the problem come when i want to compile them:

Code:
linux:/home/ian/install/sn9c102-1.32 # make modules
**************************************************************************
* Building Video4Linux2 driver v1.32 for SN9C10x PC Camera Controllers...*
* Official Linux 2.6.16 is the minimum version for this driver.          *
* Read the documentation "sn9c102.txt" for more informations.            *
* Type "make help" for a list of available targets.                      *
**************************************************************************

make -C /lib/modules/`uname -r`/build M=/home/ian/install/sn9c102-1.32 modules
make[1]: Entering directory `/usr/src/linux-2.6.13-15-obj/i386/default'
make -C ../../../linux-2.6.13-15 O=../linux-2.6.13-15-obj/i386/default modules
  CC [M]  /home/ian/install/sn9c102-1.32/sn9c102_core.o
In file included from /home/ian/install/sn9c102-1.32/sn9c102_core.c:42:
/home/ian/install/sn9c102-1.32/sn9c102.h:27:31: error: media/v4l2-common.h: No such file or directory
/home/ian/install/sn9c102-1.32/sn9c102.h:36:25: error: linux/mutex.h: No such file or directory
In file included from /home/ian/install/sn9c102-1.32/sn9c102_core.c:42:
/home/ian/install/sn9c102-1.32/sn9c102.h:110: warning: type defaults to ‘int’ in declaration of ‘DEFINE_MUTEX’
/home/ian/install/sn9c102-1.32/sn9c102.h:110: warning: parameter names (without types) in function declaration
/home/ian/install/sn9c102-1.32/sn9c102.h:142: error: field ‘dev_mutex’ has incomplete type
/home/ian/install/sn9c102-1.32/sn9c102.h:142: error: field ‘fileop_mutex’ has incomplete type
/home/ian/install/sn9c102-1.32/sn9c102_core.c: In function ‘sn9c102_start_transfer’:
/home/ian/install/sn9c102-1.32/sn9c102_core.c:717: error: implicit declaration of function ‘kzalloc’
/home/ian/install/sn9c102-1.32/sn9c102_core.c:718: warning: assignment makes pointer from integer without a cast
/home/ian/install/sn9c102-1.32/sn9c102_core.c: In function ‘sn9c102_init’:
/home/ian/install/sn9c102-1.32/sn9c102_core.c:1413: error: implicit declaration of function ‘mutex_init’
/home/ian/install/sn9c102-1.32/sn9c102_core.c: In function ‘sn9c102_release_resources’:
/home/ian/install/sn9c102-1.32/sn9c102_core.c:1431: error: implicit declaration of function ‘mutex_lock’
/home/ian/install/sn9c102-1.32/sn9c102_core.c:1431: error: ‘sn9c102_sysfs_lock’ undeclared (first use in this function)
/home/ian/install/sn9c102-1.32/sn9c102_core.c:1431: error: (Each undeclared identifier is reported only once
/home/ian/install/sn9c102-1.32/sn9c102_core.c:1431: error: for each function it appears in.)
/home/ian/install/sn9c102-1.32/sn9c102_core.c:1437: error: implicit declaration of function ‘mutex_unlock’
/home/ian/install/sn9c102-1.32/sn9c102_core.c: In function ‘sn9c102_open’:
/home/ian/install/sn9c102-1.32/sn9c102_core.c:1458: error: implicit declaration of function ‘mutex_lock_interruptible’
/home/ian/install/sn9c102-1.32/sn9c102_core.c: In function ‘sn9c102_mmap’:
/home/ian/install/sn9c102-1.32/sn9c102_core.c:1790: error: implicit declaration of function ‘vm_insert_page’
/home/ian/install/sn9c102-1.32/sn9c102_core.c: In function ‘sn9c102_ioctl’:
/home/ian/install/sn9c102-1.32/sn9c102_core.c:2739: error: implicit declaration of function ‘v4l_print_ioctl’
/home/ian/install/sn9c102-1.32/sn9c102_core.c: At top level:
/home/ian/install/sn9c102-1.32/sn9c102_core.c:2755: error: ‘v4l_compat_ioctl32’ undeclared here (not in a function)
/home/ian/install/sn9c102-1.32/sn9c102_core.c: In function ‘sn9c102_usb_probe’:
/home/ian/install/sn9c102-1.32/sn9c102_core.c:2774: warning: assignment makes pointer from integer without a cast
/home/ian/install/sn9c102-1.32/sn9c102_core.c:2779: warning: assignment makes pointer from integer without a cast
make[4]: *** [/home/ian/install/sn9c102-1.32/sn9c102_core.o] Error 1
make[3]: *** [_module_/home/ian/install/sn9c102-1.32] Error 2
make[2]: *** [modules] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.13-15-obj/i386/default'
make: *** [modules] Error 2
That doesn't look good

It seems SUSE doesn't put in the "media/v4l2-common.h" files and folders!

Where can i get these (preferably from the SUSE disc)

As you may have guesed, i am running SUSE, version 10.0 kernel 2.6.13-15-default

Thanks in advance
 
Old 08-20-2006, 10:12 AM   #2
Ian_Hawdon
Member
 
Registered: Feb 2003
Location: Heddon on-the-wall, northumberland, england
Distribution: Ubuntu
Posts: 317

Original Poster
Rep: Reputation: 30
Ok, just noticed the kernel requirements for the driver!

2.6.16, ok, i shall upgrade and try again later
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with /dev/video0 ponaka_aruna Linux - General 3 09-27-2005 02:21 AM
external cdrw assigned to /dev/uba instead of /dev/sr0 gchew Slackware 0 11-14-2004 04:22 AM
webcam, effecTV, /dev/video0 and vloopback gunslinger77 Linux - Software 0 04-20-2004 04:07 AM
/dev/video0 Tuttle Slackware 10 07-23-2003 04:39 AM
Two Video Devices - /dev/video0 & /dev/video1 liguorir Linux - Software 1 07-21-2003 09:20 PM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration