LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-25-2012, 11:28 AM   #1
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 199

Rep: Reputation: 5
Wake-on-LAN (WOL) for System76 lemu2?


My System76 Lemu2 has this version of Phoenix BIOS:
CALPELLACRB.86C.0000.X.0000000000
I called System76, this is the most recent BIOS for the Lemu2, but unfortunately the BIOS doesn't support WOL.

How do I get WOL functionality? I've tried
Code:
ethtool -s eth0 wol g
but to no avail.

Thanks
 
Old 09-26-2012, 03:41 PM   #2
jefro
Guru
 
Registered: Mar 2008
Posts: 11,139

Rep: Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362
"BIOS doesn't support WOL."

I guess you could look to an open bios but I still doubt that will fix it.

WOL and acpi/apm and motherboard and power supply and nic all have to support wol.
 
Old 09-26-2012, 05:23 PM   #3
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
Are you sure it doesn't support WOL?!?! If you enable PXE booting, you may find that options to WOL kind of "magically" appear, like drives often do when you have them plugged in at boot...

The only other thing you can try is to set the BIOS to wake from a power-off situation and rig a way to turn on power to the machine, such as with a Z-wave enabled appliace adapter.

That,... or just sleep the machine all the time and figure out some way to initiate un-suspend by LAN.
 
Old 09-26-2012, 07:44 PM   #4
jefro
Guru
 
Registered: Mar 2008
Posts: 11,139

Rep: Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362
I get the feeling that a tech from system 76 told you this.

" Re: Wake-on-LAN (WOL) for System76 lemu2?
Our laptops don't feature wake on LAN capability. For that, you would need to go with our Desktops."
 
Old 09-26-2012, 11:16 PM   #5
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 199

Original Poster
Rep: Reputation: 5
Unhappy

Quote:
Originally Posted by jefro View Post
I guess you could look to an open bios
Coreboot, e.g., doesn't support my chipset.
 
Old 09-26-2012, 11:17 PM   #6
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 199

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by JaseP View Post
Are you sure it doesn't support WOL?!?!
I'm sure I can get WOL working (somehow)
Quote:
Originally Posted by JaseP View Post
If you enable PXE booting, you may find that options to WOL kind of "magically" appear, like drives often do when you have them plugged in at boot...
How do I enable PXE booting? Thanks

---------- Post added 09-26-12 at 09:18 PM ----------

Quote:
Originally Posted by jefro View Post
I get the feeling that a tech from system 76 told you this.

" Re: Wake-on-LAN (WOL) for System76 lemu2?
Our laptops don't feature wake on LAN capability. For that, you would need to go with our Desktops."
I'm pretty sure it was a Sys76 tech…
 
Old 09-26-2012, 11:19 PM   #7
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 199

Original Poster
Rep: Reputation: 5
My Bios is a proprietary Phoenix Tech BIOS. I hear theirs are bare-bones and junk.
 
Old 09-27-2012, 10:15 AM   #8
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
For PXE booting,... look under either the tab for boot settings or advanced chipset features in the BIOS... Hunt around...

My ASUS EEE PC 702 (8GB SSD) from 2007 (or so) has Network/PXE booting capability,... I'm sure that more modern laptops would too, unless it's been crippled...
 
Old 09-27-2012, 05:48 PM   #9
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 199

Original Poster
Rep: Reputation: 5
My LemU2 uses a CLEVO 3100 subsystem. The CLEVO manual for it says, on PDF pg. 197, that it supports WOL, even with the Phoenix Tech BIOS.
 
Old 09-27-2012, 07:05 PM   #10
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,816

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
As you posted the specifications indicate that the computer supports WOL but did not find anything in the manual under the BIOS section where it is mentioned on shown in a set up page.

So how are you sending the magic packet? Are you using the correct MAC?

Also, it is possible that WOL is only supported in certain states. One of my HPs only wakes up from S4 i.e hibernation.
 
Old 09-27-2012, 07:17 PM   #11
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 199

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by michaelk View Post
So how are you sending the magic packet? Are you using the correct MAC?
My dd-wrt router sends the packet.
 
Old 09-27-2012, 07:39 PM   #12
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,816

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
Do you have another computer available to test WOL?
 
Old 09-28-2012, 01:10 AM   #13
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 199

Original Poster
Rep: Reputation: 5
wakealarm

Quote:
Originally Posted by michaelk View Post
Do you have another computer available to test WOL?
Yes, I'll try it, but I'm pretty sure the problem is my laptop. I set /sys/class/rtc/rtc0/wakealarm to 2 minutes into the future, but after 2 minutes after going into suspend, it didn't awake.
 
Old 09-28-2012, 06:16 AM   #14
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,816

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
I do not remember reading anything in the manual about BIOS alarm functions which is different then WOL. Try send a magic packet from a different computer on the LAN other then the router and post back.
 
Old 10-03-2012, 01:50 AM   #15
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 199

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by michaelk View Post
Try send a magic packet from a different computer on the LAN other then the router and post back.
It didn't awake.
 
  


Reply

Tags
bios, eth0, suspend, wakeonlan, wol


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 13.0 Wake on lan WOL 1998chevy1500 Slackware 7 03-29-2010 07:55 AM
Wol (wake On Lan ) Problem sniffer_raghav Linux - Networking 0 06-02-2008 01:44 PM
ethtool can't seem to enable wake-on-LAN (wol) on my NIC bellsal Linux - Newbie 4 10-28-2007 04:28 AM
Choosing your OS on wake on lan (wol) footloose Linux - Software 2 05-30-2007 07:48 PM
Help with WOL Wake on LAN Knight Templar Linux - Networking 3 07-19-2006 09:45 PM


All times are GMT -5. The time now is 10:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration