LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-20-2005, 08:53 AM   #1
hcgrant
Member
 
Registered: Feb 2004
Location: UK Hertfordshire
Distribution: Opensuse 12.2 plus Macs and a Vista and two little RaspberryPi
Posts: 44

Rep: Reputation: 15
Unhappy Wacom PenPartner buttons dont work in Mandiva 10.2


Ive just upgraded to Mandriva LE2005 (Mandrake 10.2) I use both a Genius Netmouse pro (PS/2) and a Wacom Penpartner. The mouse is OK but the Wacom pen won't "click". The Pen will move the cursor on the screen but pressing on the tip or the eraser button doesnt produce any result. However the side button does work.

Everything works fine on Mandrake 10.0 (Installed in another partition)

Using " xinput test Pen1 " etc shows the coordinates changing but no button events for the tip or the eraser button. The side button produces button 2 press and release events. Taking the pen away from the pad produces button 39 press and release events. Any Ideas ?

The entry in the X config files for both 10.2 and 10.0 are the same and are :-

Section "Module"
.
Load "wacom"
.
.
Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Pen1"
Driver "wacom"
Option "Device" "/dev/ttyS1"
Option "Type" "stylus"
Option "Mode" "absolute"
Option "Buttons" "3"
EndSection

Section "InputDevice"
Identifier "Eraser1"
Driver "wacom"
Option "Device" "/dev/ttyS1"
Option "Type" "eraser"
Option "Mode" "absolute"
EndSection

Section "InputDevice"
Identifier "Cursor1"
Driver "wacom"
Option "Device" "/dev/ttyS1"
Option "Type" "Cursor"
Option "Mode" "absolute"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
EndSection
.
.
Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Pen1" "AlwaysCore"
InputDevice "Eraser1" "AlwaysCore"
InputDevice "Cursor1" "AlwaysCore"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
 
Old 05-23-2005, 04:32 PM   #2
hcgrant
Member
 
Registered: Feb 2004
Location: UK Hertfordshire
Distribution: Opensuse 12.2 plus Macs and a Vista and two little RaspberryPi
Posts: 44

Original Poster
Rep: Reputation: 15
Problem Solved ?
since the Pen buttons worked in 10.0 and not in 10.2 Ive just copied the 10.0 version of wacom_drv.o to 10.2 and the pen works properly now in 10.2. So it would seem that the wacom driver supplied with Mandriva LE2005 is broken.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
getting Wacom tablet to work in 'absolute' mode xilmin Linux - Hardware 7 05-07-2005 08:33 AM
application buttons dont stretch on taskbar xconspirisist Fedora 1 11-10-2003 04:20 AM
Things dont work when you dont understand withoutaclue Linux - Newbie 3 03-12-2003 10:51 AM
Wacom Tablet and wacom drivers Mallow005 Linux - General 1 12-27-2002 03:26 AM
Wacom Penpartner and Gimp Daudistrachur Linux - Newbie 2 10-06-2002 11:22 AM


All times are GMT -5. The time now is 06:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration