LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-08-2004, 01:52 PM   #1
DozenEggs
Member
 
Registered: Jul 2004
Location: Toronto, Canada
Distribution: SuSE 9.1, Fedora Core 2, WinXP
Posts: 37

Rep: Reputation: 15
Exclamation Video Card Not Working on Fedora Core 2 With GeForce FX 5200


Hey, I Just Started Using Linux Like About 3 Weeks. 2 Weeks With SuSE 9.1 Pro On My Cousin's Comp And It Just Drew Me To Linux, So Then I Used His CD's To Install Fedora Core 2 On My Comp When I Came Back Home. This Is My Question, I Have An nVidia GeForce FX 5200 Video Card And I'm Not Sure That It's Supported Or Detected. Do I Have To Install Anything To Make It Work Like A Linux Driver Or Anything? Please Help! If You Need My Comp Specs Here They Are.

SONY VAIO COMP
Intel Pentium 4 CPU
Dual Booting Fedora Core 2 And Windows XP Home
1500Mhz
512 SDRam
nVidia GeForce FX 5200 128MB
 
Old 07-08-2004, 02:34 PM   #2
guessme
Member
 
Registered: Jul 2004
Posts: 40

Rep: Reputation: 15
hi dozeneggs,
even i am a new user to fedora 2. did u connect your monitor to the graphics card and if u can see the graphical user interface and have a doubt whether the drivers are installed properly or not.i think i know some raw techiniques to check whether your video card is working fine or not. just go to terminal and check using glxgears

#glxgears

this gives the FPS of your system. if it is somewhere in 200-300. i think the fedora has installed its default drivers and you can find the appropriate drivers in

http://www.nvidia.com/object/linux_d..._1.0-6106.html

even you have the installation instructions there.

if i am wrong. i am sorry for it.

guessme
 
Old 07-08-2004, 04:06 PM   #3
DozenEggs
Member
 
Registered: Jul 2004
Location: Toronto, Canada
Distribution: SuSE 9.1, Fedora Core 2, WinXP
Posts: 37

Original Poster
Rep: Reputation: 15
Didn't Work

I tried the installer and it said that it failed and it didnt work. My fps was between 130-90 using glxgear command. Is this normal or not?
 
Old 07-08-2004, 04:21 PM   #4
guessme
Member
 
Registered: Jul 2004
Posts: 40

Rep: Reputation: 15
if it is 90-130 it means ur graphic card driver isn't installed properly. did u try to install it exiting x windows as u should x windows and install it using the sh command. u should install from the command prompt. not from the terminal.
 
Old 07-08-2004, 06:34 PM   #5
DozenEggs
Member
 
Registered: Jul 2004
Location: Toronto, Canada
Distribution: SuSE 9.1, Fedora Core 2, WinXP
Posts: 37

Original Poster
Rep: Reputation: 15
Question Ok

I never did that opps i'll try that now, btw how do i not use X window, do i logout and go to sessions and choose a diff one?
 
Old 07-08-2004, 06:52 PM   #6
guessme
Member
 
Registered: Jul 2004
Posts: 40

Rep: Reputation: 15
go to etc/inittab
replace the line/change

id:5:initdefault:

change it with

id:3:initdefault:

restart ur system.
it stops in terminal mode login as root
and execute the sh command. write down the sh command before hand so u dont make any typo mistakes. if this file and ur kernel are compatible it runs fine. it asks for kernel updation from nvidia click ok and everything should work fine.

after installation u will get back to terminal.
then type startx at terminal
#startx
it starts xwindows. check glxgears now u should get fps in 1000's . change ur inittab file back to default 5 replace default 3 with 5.

thats it
 
Old 07-08-2004, 07:25 PM   #7
DozenEggs
Member
 
Registered: Jul 2004
Location: Toronto, Canada
Distribution: SuSE 9.1, Fedora Core 2, WinXP
Posts: 37

Original Poster
Rep: Reputation: 15
Question Umm...

When i check my fps, it doesnt start glxgears in terminal, its says an error, the error is :

Xlib: extention "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-Buffered visual

I installed the driver u wrote down before like you said, i changed the file and restarted, installed the nvidia driver, wrote down startx and changed the file back to normal and restarted and now im back here in KDE. i tried the glxgears and i got that error. Did i do something wrong??
 
Old 07-08-2004, 07:39 PM   #8
guessme
Member
 
Registered: Jul 2004
Posts: 40

Rep: Reputation: 15
sorry i forgeot something. now u need to follow the instructions in the site back where u downloaded from
http://www.nvidia.com/object/linux_d..._1.0-6106.html
read the readme file in step 3. or the direct link is

the link is:

ftp://download.nvidia.com/XFree86/Li...106/README.txt

this is the part u need to do:
---------------------------------------------------
(sec-03) EDITING YOUR X CONFIG FILE
__________________________________________________________________________

In April of 2004, the X.org Foundation released an X server based on
the XFree86 X server. Many Linux distributions will use the X.org
X server in the future, rather than XFree86. The differences between
the two X servers should have no impact on NVIDIA Linux users with
two exceptions:

1) The X.org configuration file name, though it uses the same syntax
as XFree86's XF86Config file, is called /etc/X11/xorg.conf;
this README refers generically to these configuration files as
"the X config file".

2) The X.org log file, though its output is nearly identical
to the XFree86.0.log file, is called /var/log/Xorg.0.log; this
README refers generically to these files as "the X log file".


When XFree86 4.0 was released, it used a slightly different XF86Config
file syntax than the 3.x series did, and so to allow both 3.x and 4.x
versions of XFree86 to co-exist on the same system, it was decided that
XFree86 4.x was to use the configuration file "/etc/X11/XF86Config-4"
if it existed, and only if that file did not exist would the file
"/etc/X11/XF86Config" be used (actually, that is an over-simplification
of the search criteria; please see the XF86Config man page for a
complete description of the search path). Please make sure you know
what configuration file your X server is using. If you are in doubt,
look for a line beginning with "(==) Using config file:" in your X log
file ("/var/log/XFree86.0.log" or "/var/log/Xorg.0.log").

If you do not have a working X config file, there are several ways
to start: there is a sample config file that comes with XFree86,
and there is a sample config file included with the NVIDIA driver
package (it gets installed in /usr/share/doc/NVIDIA_GLX-1.0/).
You could also use a program like 'xf86config'; some distributions
provide their own tool for generating an X config file. For more
on X config file syntax, please refer to the man page (`man XF86Config`,
or `man xorg.conf`).

If you already have an X config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist. There are also numerous options that can be added to the
X config file to fine-tune the NVIDIA X driver. Please see Appendix D
for a complete list of these options.

Once you have configured your X config file, you are ready to restart X
and begin using the accelerated OpenGL libraries. After you restart X,
you should be able to run any OpenGL application and it will automatically
use the new NVIDIA libraries. If you encounter any problems, please
see the FREQUENTLY ASKED QUESTIONS section below.


_________________________________________________________________________

Last edited by guessme; 07-08-2004 at 07:41 PM.
 
Old 07-08-2004, 09:21 PM   #9
DozenEggs
Member
 
Registered: Jul 2004
Location: Toronto, Canada
Distribution: SuSE 9.1, Fedora Core 2, WinXP
Posts: 37

Original Poster
Rep: Reputation: 15
...

that didnt help, i still dont know how to edit my xorg.conf file. I need help!!
 
Old 07-08-2004, 10:37 PM   #10
guessme
Member
 
Registered: Jul 2004
Posts: 40

Rep: Reputation: 15
go to computer on the desktop
computer > filesystem > etc > xorg.conf

thats the path once u open the file. edit it as it says like editing
driver "nv"
line with
driver "nvidia"

drive "nv" wil be in the section "device"

in the module section in the files u will have various loads
in one line type

load "glx"

remove the two lines if they are in the loads which says
load "dri"
load "GLcore"


ok
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia geforce fx 5200 on slackware 10.0 not working good... snip128 Linux - Newbie 1 10-31-2004 10:15 PM
How to swap video card from sis to geforce 5200? sirius57 Linux - Hardware 0 10-14-2004 02:13 PM
TwinView with Gforce fx 5200 on Fedora Core 1,not working Sathanas Linux - Hardware 0 04-20-2004 09:42 PM
Installing Fedora on Laptop > GeForce FX 5200 Go Jefklak Red Hat 5 12-27-2003 03:49 AM
My GeForce FX 5200 video card won't work on RH9 jogurt666 Red Hat 0 11-03-2003 03:18 AM


All times are GMT -5. The time now is 02:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration