LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 03-28-2003, 12:47 PM   #1
Perdido
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Rep: Reputation: 0
Very low sound


I have installed kernel 2.4.21. Since then, when I log in KDE my sound is very low.

Here is what I have in my /var/log/messages file:

Mar 28 16:44:24 portatil sound: Loading sound module (snd-maestro3) succeeded
Mar 28 16:44:24 portatil kernel: maestro3: version 1.23 built at 15:30:15 Mar 14 2003
Mar 28 16:44:24 portatil modprobe: /lib/modules/2.4.21-0.13mdk/kernel/drivers/sound/maestro3.o.gz:
Mar 28 16:44:24 portatil modprobe: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
Mar 28 16:44:24 portatil modprobe: You may find more information in syslog or the output from dmesg
Mar 28 16:44:24 portatil modprobe: init_module: No such device
Mar 28 16:44:24 portatil modprobe: modprobe: insmod /lib/modules/2.4.21-0.13mdk/kernel/drivers/sound/maestro3.o.gz failed
Mar 28 16:44:24 portatil modprobe: modprobe: insmod maestro3 failed
Mar 28 16:44:25 portatil aumix: vol set to 58, 58, R
Mar 28 16:44:25 portatil aumix: pcm set to 71, 71
Mar 28 16:44:25 portatil aumix: speaker set to 100, 100
Mar 28 16:44:25 portatil aumix: line set to 100, 100, P
Mar 28 16:44:25 portatil aumix: mic set to 100, 100, P
Mar 28 16:44:25 portatil aumix: cd set to 100, 100, P
Mar 28 16:44:25 portatil aumix: igain set to 100, 100
Mar 28 16:44:25 portatil aumix: line1 set to 100, 100, P
Mar 28 16:44:25 portatil aumix: phin set to 100, 100, P
Mar 28 16:44:25 portatil aumix: video set to 100, 100, P
Mar 28 16:44:25 portatil sound: Loading mixer settings succeeded

Could you help me?.

Thank you in advance.
 
Old 03-28-2003, 02:20 PM   #2
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
do you need to load the maestro module? if you load a module (that succeeds) called snd-maestro I would think that you shouldn't need any other modules. Plus the maestro doesn't look like its loading anyhow, and if you still have sound then you might as well just get rid of it.

As for the volume...
check out this man page for aumix
http://linuxcommand.org/man_pages/aumix1.html
you should be able to boost the default volume setting from 58 to 100 like the rest.
 
Old 03-28-2003, 02:37 PM   #3
Perdido
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by jpbarto
do you need to load the maestro module? if you load a module (that succeeds) called snd-maestro I would think that you shouldn't need any other modules. Plus the maestro doesn't look like its loading anyhow, and if you still have sound then you might as well just get rid of it.
Could you tell me how to do it?. I am a newbbie

Quote:
Originally posted by jpbarto
As for the volume...
check out this man page for aumix
http://linuxcommand.org/man_pages/aumix1.html
you should be able to boost the default volume setting from 58 to 100 like the rest.
Thank you. Now I have the default volume to 100 but I would like to have it solved everytime I log in. So, I think I have to solve the problem with the maestro modules. Could you help me?.
 
Old 03-28-2003, 03:30 PM   #4
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
ok, well what distro are you running? there will be initialization scripts in /etc/rc.... depending on your distro different files are in different places. But somewhere in one of those scripts will be a line that reads something like
/sbin/modprobe maestro

comment it out with an '#' at the beginning of the line... such as
# following line commented out by perdido 03/28/03
# /sbin/modprobe maestro

that should take care of the module. Now when you reboot (it sounds like you found and altered the aumix config) your modules should load without errors and your default volume should be at 100... is this correct? Is it still too quiet?

P.S. a quick and easy way to locate the file with the modprobe command in it would be
<prompt># cd /etc/rc.d (or whatever dir your scripts are in)
<prompt># grep -H -r maestro *

this should recursivley search all files and subdirectories listing every filename that contains the word maestro in its contents.

Last edited by jpbarto; 03-28-2003 at 03:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound is low... LinuxHawk Linux - General 3 10-30-2004 07:56 PM
Sound volume very low stocks29 Linux - General 6 09-24-2004 02:44 PM
Sound Is Too Low aeb105 Linux - Newbie 9 10-31-2003 02:35 AM
sound on Linux is really low GT_Onizuka Linux - Newbie 6 08-23-2003 05:22 PM
Low sound anima_a_ignifer Linux - Hardware 6 10-29-2002 11:16 AM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration