LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 09-12-2003, 06:49 AM   #1
shycalais
Member
 
Registered: Sep 2003
Distribution: rh
Posts: 43

Rep: Reputation: 15
USRobotics Modem Trouble


ok my original modem was a winmodem and it sucked, so i went through the junk pile (my closet) and found a USRobotics 56k sportster flash modem!

i'm using REDHAT9..

well on startup kazaam (name??) picks it up and i configured it.. everything was going well.. but i can't seem to dial out on it.. i've dropped into the terminal and fed lines into it such as

(its on ttyS0)

echo "ATA" > ttyS0
it picks up!

echo "ATDT0407021300" > ttyS0
nothing.. it seems all the lights flicker, i don't get anything...

so i tried to go into network config and install and activate it... still nothing happens...

i'm in windows atm and its working fine, can anyone give me any advice on how to fix this? its a pain, to access this forum i must log out of RedHat9 and log into windowsXP

i'm still very new to linux (3days) and still have little idea, pardon my ignorance if its something simple
 
Old 09-12-2003, 06:54 AM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
It probably is. The most likely thing I can find is your commands being way to simple.
I sometimes use a PC-Card modem, in order to dial, I have to pass it a string like.. ATDT &F1 &c3 &d &e &g &this&that &speed & protocal... blah blah.. its like a whole paragraph long. You'll need to go find the online manual for your modem, on US robotics website, and figure out a nice long string that tells the modem everything it has to do
 
Old 09-12-2003, 07:03 AM   #3
shycalais
Member
 
Registered: Sep 2003
Distribution: rh
Posts: 43

Original Poster
Rep: Reputation: 15
on it right now! shouldn't redhat know this though? it picks it up as a USRobotics sportster flash... when i get this working, and figure out how to code this stuff, i'm going to fix a heap of stuff c/c++ is a favourite of mine
 
Old 09-12-2003, 07:21 AM   #4
shycalais
Member
 
Registered: Sep 2003
Distribution: rh
Posts: 43

Original Poster
Rep: Reputation: 15
no go... USRobotics just says ATDT no "to dial out"
and theres nothing there saying initalise modem so i'm guessing its standard ATZ thanks anyway CAEDA anyone else got a suggestion?
 
Old 09-12-2003, 07:50 AM   #5
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
You didnt quite understand that.
Its not going to be listed under initialse in the manual. You have to read the whole thing. Then, you have to make a custom init string. Which will tell the modem... Turn on.. use v.90 use upstreem speed ???, use downstream speed ???, and so on, for every single feature the modem needs to use. Redhat wont do this by itself.

Here's a list of normal init strings needed for a modem to function.
http://www.tcq.net/tcsupport/modems.htm
 
Old 09-13-2003, 02:26 AM   #6
shycalais
Member
 
Registered: Sep 2003
Distribution: rh
Posts: 43

Original Poster
Rep: Reputation: 15
you've been a good help!

thanks man! i think its going to be working!!
found some custom init strings!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USRobotics modem Not Found (9.1 Personal) ??? jpass Suse/Novell 3 11-01-2004 06:29 PM
USRobotics internal modem in RH9 daemon_14 Linux - Networking 0 08-06-2003 01:59 PM
USRobotics Modem and 3ComMdm XDJ Linux - Hardware 0 07-13-2003 03:57 PM
USRobotics v92 USB Modem Problem pintsize Linux - Newbie 0 06-17-2003 03:41 PM
USrobotics modem installation rdaves@earthlink.net Linux - Newbie 7 05-21-2001 08:14 AM


All times are GMT -5. The time now is 12:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration