LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-13-2004, 09:52 AM   #1
UberMousE
LQ Newbie
 
Registered: Apr 2004
Location: Wales
Distribution: SuSE 9.0
Posts: 4

Rep: Reputation: 0
USB2 NTFS Hard Drive Mount Permission


Hi

If I'm doing something really silly then I'll apologise now.

I'm trying to mount a 60Gb hitachi hard drive to my SuSE 9 laptop using a usb converter. Not as silly as it sounds as I've managed to successfully browse the drive by doing this:

su
<rootpassword>
cd /
mkdir /mnt/usb2
mount -t ntfs /dev/sda1 /mnt/usb2
cd /mnt/usb2
ls -l
<directorylisting>

The problem is, when I try and and browse the /mnt/usb2 folder as a normal user I get permission denied. Not to be outdone I did this:

chmod 777 /mnt/usb2

no joy. So I added this line into fstab:

dev/sda1 /mnt/usb2 ntfs user, exec, noauto, codepage=850, iocharset=iso8859-1, quiet, unmask=0 0 0

No joy.

Is this a limitation on NTFS? Is it my Distro? Am I being stupid? Will I ever be able to write to this disk using the above method?

Thanks

UberMousE
 
Old 04-13-2004, 10:27 AM   #2
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
It is not called 'unmask', it is 'umask'. So you should have:
Code:
/dev/sda1 /mnt/usb2 ntfs user,exec,noauto,codepage=850,iocharset=iso8859-1,quiet,umask=0 0 0
 
Old 04-13-2004, 11:00 AM   #3
UberMousE
LQ Newbie
 
Registered: Apr 2004
Location: Wales
Distribution: SuSE 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you but no joy. I now have this line in fstab as well:

/dev/sda /media/sda auto noauto,user,exec 0 0 #HOTPLUG B3Fu.oDWa+wJ1Pb2

What the ?!?!?!?! does that mean?

Back to permissions, any other ideas how to browse this drive as a user instead of root?
 
Old 04-13-2004, 11:03 AM   #4
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
That's what 'umask=0' does, it lets regular users browse. Change the line back to 'sda1'.
 
Old 04-13-2004, 11:18 AM   #5
UberMousE
LQ Newbie
 
Registered: Apr 2004
Location: Wales
Distribution: SuSE 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks, my FSTAB entry now reads

/dev/sda1 /mnt/usb2 ntfs user,exec,noauto,codepage=850,iocharset=iso8859-1,quiet,umask=0 0 0

But my user can't see into the folder via Konqueror and I still get permission denied within bash
 
Old 04-13-2004, 11:22 AM   #6
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Unmount the drive, then as root run 'chmod 777 /mnt/usb2'. Then mount again.
 
Old 04-14-2004, 03:35 AM   #7
UberMousE
LQ Newbie
 
Registered: Apr 2004
Location: Wales
Distribution: SuSE 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
Still no joy. I'm sorry if I'm being a 'tard, I'm a bit new to this. Now, SuSE has added the following line to fstab automatically:

/dev/sda1 /media/sda1 auto sync,noauto,user,exec,umask=0 0 0 #HOTPLUG B3Fu.xJiBhBAIBaD

When I remove the USB HDD this line disappears so I presume SuSE is trying to make it easier!? So I've unmounted /mnt/usb2 and run chmod 777 /media/sda1, rebooted and remounted. Access still denied to everyone other than root.
 
Old 05-02-2004, 05:30 PM   #8
bourbon_lord
LQ Newbie
 
Registered: May 2004
Location: NZ
Distribution: Gentoo
Posts: 2

Rep: Reputation: 0
Hmmm....I have exactly the same problem with NTFS partitions accessed via a Promise ATA controller. Can explore as root, but no matter what I do I cant browse them as user.
Did you find a solution??
 
Old 05-02-2004, 05:47 PM   #9
bourbon_lord
LQ Newbie
 
Registered: May 2004
Location: NZ
Distribution: Gentoo
Posts: 2

Rep: Reputation: 0
Fixed it! Not too different from what I was using before, but this is what I added to fstab:

/dev/hde5 /mnt/hd2 ntfs ro,auto,users,umask=0000

is the extra umask zero significant??
 
Old 05-03-2004, 02:50 AM   #10
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
NTFS in LINUX experimental for writing. SUSE and several other distributions take caution when mounting NTFS partitions. You may want to set the umask to 222 so that you do not accidently write to the NTFS partition.

If you want to write to the USB drive, use fat32 and you can still use it under Windows or Mac. Windows XP can not format fat32 about 32 gigabytes but someone compiled mkdosfs for windows to format fat32 above the 32 gigabyte limit. Go to [url]http://www.mager.org/mkdosfs/[/ur]. I have not test it.

Setting USB storage devices in fstab is not very smart. What if you have several storage devices connected to the USB port and then you connected your NTFS hard drive. The drive will not be mounted or your first storage device is screwd up. To fix this use hotplug to detect the device and then mounts it for you. You have to do some bash scripting to make it work.

BTW, its directory not folder. In Windows, its still called a directory.
 
Old 05-14-2004, 05:27 AM   #11
lauer
Member
 
Registered: Aug 2003
Location: Germany
Distribution: openSuSE
Posts: 61

Rep: Reputation: 16
Ah, hotplug, now you've got my attention ... and it's not even OT to this thread

I remember the time in previous SuSE versions (I now use 9.1 which is very nice) that I just inserted my USB stick, it got recognized, mounted, and - under KDE - a konquerer window popped up. I understand, this is what hotplug is nowadays intended to do.

However, it does not for me under 9.1

If the stick is plugged in during boot, everything is fine.
If I unplug and replug it, I can no longer see my files.
If I plug it in after log in, nothing happens.

Is there some well known magic to be performed to get hotplug behave as described above?

Harald
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount ntfs hard drive daffyduke Mandriva 5 01-18-2005 11:38 PM
How To Mount An NTFS Hard Drive TheHateCrew Linux - Hardware 4 09-14-2004 09:11 AM
Mount NTFS Windows Drive / Permission Problems allen_p Linux - Newbie 1 08-05-2004 09:16 PM
Can't figure out how to mount hard drive in usb2.0 case jglidden Linux - Hardware 7 12-17-2003 06:56 PM
Cant mount NTFS Hard drive monkeymartin Linux - General 5 08-10-2003 09:35 PM


All times are GMT -5. The time now is 10:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration