LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-16-2010, 09:18 PM   #1
kernel-P4N1C
Member
 
Registered: Nov 2007
Location: Panama city, Republic of Panmaa
Posts: 167

Rep: Reputation: 18
USB webcam not working on slackwar 13 x86_64


Hi

I'm trying to make work a logitec orbit... wich is supposed to be supported out of the box using uvc drivers already part of my kernel.

The system automatically assign it to /dev/video0 and works ok with mplayer; but sometimes is not linked with /dev/video0 which is a pain... like right now.

Here is some info
Code:
root@dragon:/home/weput# lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 014: ID 046d:08c2 Logitech, Inc. QuickCam PTZ
Code:
weput@dragon:~$ lsmod | grep v4l
v4l1_compat            15364  2 uvcvideo,videodev
v4l2_compat_ioctl32    10912  1 videodev
Code:
root@dragon:/home/weput# ls /dev/video*
ls: cannot access /dev/video*: No such file or directory
root@dragon:/home/weput# uname -r
2.6.29.6
 
Old 03-18-2010, 12:50 PM   #2
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Have a look at dmesg to see what device is being assigned. If it's changing from /dev/video0 perhaps you need to write a udev rule to enforce consistent assigning.
 
Old 03-18-2010, 02:06 PM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Read footnotes 1 and 2, which are linked from your camera model:
http://linux-uvc.berlios.de/#footnote-1

it seems these cameras have firmware issues, but there exist patches.
http://www.quickcamteam.net/document...ompatibilities
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Webcam partly working in Linux Mint 8 stardustdk Linux - Hardware 3 02-07-2010 05:47 PM
usb webcam not working with Firefox cwfrad Linux - Newbie 1 06-12-2009 02:27 AM
aMSN PB-WC100 USB webcam not working toni_uk Linux - Software 0 01-20-2009 04:42 PM
mandrake linux 10.0 kernel 2.6.3 usb scanner, webcam not working grolon Mandriva 2 04-28-2004 08:56 PM
USB Webcam is not working linuxfan1 Linux - Newbie 9 04-17-2004 11:29 AM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration