LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-31-2007, 08:22 PM   #1
Arla
Member
 
Registered: Jun 2005
Location: SE
Distribution: Gentoo, k 2.6.24
Posts: 48

Rep: Reputation: 15
SOLVED: USB stick won't mount ("wrong fs type, bad option, bad superblock ...")


dmesg happily says my USB memory stick is found and ready at /dev/sdb. It's formatted in Windows as FAT. Yet it gives the following error for three differently formulated mount commands:

# mount /dev/sdb1 /mnt/usb1
# mount -t vfat /dev/sdb1 /mnt/usb1
# mount -t vfat /dev/sdb /mnt/usb1
mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage, or other error

I've also tried reformatting (FAT and FAT32) a couple of time.

The same command have worked for the same memory stick on another system/machine.

Thanks in advance for any ideas!

Last edited by Arla; 06-01-2007 at 08:33 AM. Reason: solution found
 
Old 05-31-2007, 09:26 PM   #2
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
What is the output from running
Code:
fdisk -l
when the USB drive is inserted? Note that's a lowercase "L"
 
Old 06-01-2007, 07:23 AM   #3
Arla
Member
 
Registered: Jun 2005
Location: SE
Distribution: Gentoo, k 2.6.24
Posts: 48

Original Poster
Rep: Reputation: 15
# fdisk -l
[...]
/dev/sdb1 1 1010 1033199 6 FAT16
# mount /dev/sdb1 /mnt/usb1
mount: wrong fs type, bad option, bad superblock
on /dev/sdb1, missing codepage, or other error
 
Old 06-01-2007, 07:58 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,505

Rep: Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079
How about
Code:
mount -t msdos /dev/sdb1 /mnt/usb1
 
Old 06-01-2007, 08:23 AM   #5
Arla
Member
 
Registered: Jun 2005
Location: SE
Distribution: Gentoo, k 2.6.24
Posts: 48

Original Poster
Rep: Reputation: 15
Thank you for that, syg00. You made me take a look at dmesg, which said that codepage 437 couldn't be found. Then I remembered disabling something like that (apparently precisely that) in Native Language Support under File Systems in the kernel configuration (I'm running Gentoo). I'm right now recompiling and will edit this message when done.

Edit: And it works.

Last edited by Arla; 06-01-2007 at 08:33 AM.
 
  


Reply

Tags
codepage, fat, mount, solution, usb, vfat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 09:55 AM
ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1, saiket Linux - Hardware 3 04-12-2008 01:07 AM
usb drive won't mount - error: wrong fs type, bad option, bad superblock on /dev/sda1 bluecog6 Linux - Hardware 4 01-27-2007 10:07 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 06:50 PM
USB 2.0 memory stick mount: wrong fs type, bad option, bad superblock on /dev/sda1, o olivier.riff Linux - Hardware 2 11-12-2003 09:11 AM


All times are GMT -5. The time now is 04:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration