LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 01-28-2009, 03:47 PM   #1
Teo-sama
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
Unhappy USB Mouse with inverted axis


I know you have seen problems like this, I've been reading a lot of threads about, but can't get it to work.
My wireless USB Mouse (unknown Mark) that I bought on eBay get detected by Ubuntu 8.10, but seems to be working backwards. I mean, with the inverted axis. I know there is a way to make it get inverted again, adding the right code on xorg.conf. I tryed SO MANY possible ways to do it, but I can't. Also I tested the mouse on Windows (XP and Vista) and works the same (backwards).

Here's the lines on my xorg.conf

Quote:
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/input/mouse1"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
Option "InvX" "on"
Option "InvY" "on"
EndSection
I know there is more than "inverting the axis", but that was the last thing i tryed.
Also, I think it doesn't work with the "mice" driver, but with "mouse1", because I watched how this adds on "/dev/input" when I plug and unplug the usb receptor.

PLEASE! any help?
 
Old 02-04-2009, 04:39 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,359
Blog Entries: 3

Rep: Reputation: 169Reputation: 169
Quote:
Option "Emulate3Buttons" "true"
Option "InvX" "on"
Option "InvY" "on"
theses are not needed. and you may have to add
Quote:
Option "ZAxisMapping" "4 5 6 7"
4 and 5 is for scrolling try 6 and 7 tell me what happens but most likley this is a revesed circut on the mouse circuit board so it is a bad device. send it back
Quote:
Option "Device" "/dev/input/mouse1"
way out of place.
Quote:
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection
try the above.
 
  


Reply

Tags
axis, device, ibex, mice, mouse, ubuntu, usb, xorg, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with USB mouse's axis elvijs Linux - Hardware 2 06-22-2007 02:30 AM
Mouse scrolly doesn't work, even though added axis option in config file. RHLinuxGUY Slackware 8 07-22-2005 11:33 PM
How can I disable the X & Y axis of a USB-mouse bigperk420 Slackware 3 11-06-2004 10:54 PM
Mouse is off axis aliensub Linux - Hardware 6 09-29-2004 04:35 PM
Mouse Scrolling in the X-axis Dachaz Linux - Hardware 0 04-03-2004 05:25 AM


All times are GMT -5. The time now is 07:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration