LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 04-26-2004, 08:27 PM   #1
Googly
LQ Newbie
 
Registered: Feb 2004
Location: Boise, Idaho, United States
Distribution: Gentoo
Posts: 16

Rep: Reputation: 0
USB mouse not working


mouse isn't detected by XFree86 4.1

when I plug it in it says: "hub.c: USB new device connect on bus2/2 assigned device number 2
usb.c: USB device 2 (vend/prod 0x46d/0xc016) is not claimed by any active driver

when loading X it says "Cannot open device /dev/input/mice No such device"

also the touchpad kinda works but it jumps around and pushes random buttons and stuff.
 
Old 04-26-2004, 11:06 PM   #2
Googly
LQ Newbie
 
Registered: Feb 2004
Location: Boise, Idaho, United States
Distribution: Gentoo
Posts: 16

Original Poster
Rep: Reputation: 0
yay!

I got it working, just needed to load a few modules and do some sort of wierd usbfilesystem thingy kinda like:

mount -t usbdevfs none /proc/bus/usb
modprobe input
modprobe hid
modprobe mousedev
 
Old 04-26-2004, 11:09 PM   #3
bobbyduncan
LQ Newbie
 
Registered: Apr 2004
Location: Oklahoma City, OK
Distribution: Mandrake 10.0
Posts: 12

Rep: Reputation: 0
ThinkPad 560Z mouse not working

i chose "no mouse" on install of Mandrake 9.1 and now my little red trackpoint mouse doesn't work so I can't use Linux when the KDE boots.

How do I install my laptop's default mouse?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB mouse not working Vertex78 Slackware 5 09-26-2004 08:13 PM
help getting usb mouse working liquigel Debian 1 02-18-2004 02:45 PM
ps/2-mouse via usb-adaptor not working - usb error=-110 mule Fedora 0 01-30-2004 07:23 AM
slackware 9.1 USB mouse and other usb devices not working jimMC Linux - Hardware 11 01-24-2004 11:58 AM
usb mouse not working eduardo_ha Linux - Hardware 14 01-22-2003 11:12 PM


All times are GMT -5. The time now is 03:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration