LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-23-2003, 03:23 AM   #1
mad2physicist
LQ Newbie
 
Registered: Aug 2003
Location: Houghton NY
Distribution: Slackware 9.0
Posts: 6

Rep: Reputation: 0
USB hard drive rejects dev number


I have a Universal Buslink Corporation external hard drive (USB), model number L30 (30GB). It works fine with windows, for which they gave drivers. However, in linux, on bootup, it gives messages like:
usb.c: assigning device number 2
usb.c device rejected device number 2 (error=-100)

It goes on like this until it reaches device number 5, then it stops giving messages and finishes booting up.
I have the usb-ohci, usb-storage, and usbcore modules installed. Are there more modules that I need? I'm running slackware 9.0, and I checked through the USB drivers they have and added as many as looked relevent to /etc/rc.d/rc.modules.
Thanks.
 
Old 09-03-2003, 06:53 AM   #2
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
You probably have all the modules for USB installed, but you also need to check on scsi devices. Linux treats almost all writable USB devices as scsi, so you will need to see 'scsi_mod', 'sr_mod' and 'sd_mod' at least. Post the output of 'lsmod' and 'cat /proc/scsi/scsi'. These are commands issued at a console while you're logged in as root.

Last edited by geoff_f; 09-03-2003 at 06:54 AM.
 
Old 09-03-2003, 09:47 PM   #3
mad2physicist
LQ Newbie
 
Registered: Aug 2003
Location: Houghton NY
Distribution: Slackware 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
Here's my lsmod:
lsmod
Module Size Used by Not tainted
maestro3 25680 1
ac97_codec 9512 0 [maestro3]
soundcore 3332 2 [maestro3]
ds 6568 2
yenta_socket 9632 2
pcmcia_core 38112 0 [ds yenta_socket]
ide-scsi 8048 0
tulip 41248 1
usb-storage 60116 0 (unused)
mdc800 8248 0 (unused)
keybdev 1952 0 (unused)
mousedev 4212 0 (unused)
hid 18596 0 (unused)
input 3200 0 [keybdev mousedev hid]
usb-ohci 18856 0 (unused)
usbcore 58144 1 [usb-storage mdc800 hid usb-ohci]

So I've got the ide-scsi module in there anyway. And here's the "cat" you wanted:
cat /proc/scsi/scsi
Attached devices: none

I'll look for more scsi modules as well. But the problem is that the same error occurs if I try a USB mouse, which makes me think it is probably a USB error.

Thanks
 
Old 09-04-2003, 04:32 AM   #4
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
Well, your scsi arrangement doesn't look normal to me. If you have ide-scsi to handle a CD burner, then something should show up in /proc/scsi/scsi. The output of my /proc/scsi/scsi is:

[root@HomeComp geoff]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: PiOnEeR Model: DvD-RoM DvD-116 Rev: 1.22
Type: CD-ROM ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 01 Lun: 00
Vendor: LITE-ON Model: LTR-40125S Rev: ZS0K
Type: CD-ROM ANSI SCSI revision: 02

Now, Mandrake 9.1 uses devfs, so that might account for some differences, since you use Slackware. For example, if Slack doesn't have devfs, then you might not have 'sr_mod' or 'sd_mod', but I would think you would still need 'scsi_mod' regardless. My 'lsmod' says that 'scsi_mod' is used by 'ide-scsi' (as well as by 'sr_mod' and 'sd_mod'). This needs help from a Slackware person, I'm afraid.

Last edited by geoff_f; 09-04-2003 at 05:00 AM.
 
Old 09-04-2003, 04:45 PM   #5
elavalle
LQ Newbie
 
Registered: Sep 2003
Location: mexico
Distribution: red hat 8.0
Posts: 11

Rep: Reputation: 0
Have you removed plug& play from the bios you are using???
I'm having sort of the same issue with my usb intellimouse... when I removed the plug&play option from it at least I got it to work once... after I rebooted it fail again but at this it did something.
 
Old 09-04-2003, 05:34 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Is your computer's USB ports 2.0 or 1.0,1.1 . I never could get a 2.0 device to work on a 1.1 USB port. I might be able now. If your USB ports are 2.0 you need to load one or the other of the following modules usb-uhci or usb-ehci.

This site has some info about modules and hardware.
http://www.linux-usb.org/usb2.html

I haven't tried this but you could load both modules even if your ports are not 2.0. Then maybe you can mount it. Let me know if this works.

Good luck
Brian1
 
Old 09-06-2003, 07:36 AM   #7
mad2physicist
LQ Newbie
 
Registered: Aug 2003
Location: Houghton NY
Distribution: Slackware 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
My computer has the 1.1 USB. However, the hard drive is about 6 months older than the computer, so I really doubt that its a 2.0 USB hard drive. The mouse, being a mouse, might be.
I tried the following commands:



root@Mad2Physicist:~# modprobe usb-uhci
/lib/modules/2.4.20/kernel/drivers/usb/usb-uhci.o.gz: init_module: No such device
/lib/modules/2.4.20/kernel/drivers/usb/usb-uhci.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20/kernel/drivers/usb/usb-uhci.o.gz: insmod /lib/modules/2.4.20/kernel/drivers/usb/usb-uhci.o.gz failed
/lib/modules/2.4.20/kernel/drivers/usb/usb-uhci.o.gz: insmod usb-uhci failed
root@Mad2Physicist:~# modprobe ehci-hcd
/lib/modules/2.4.20/kernel/drivers/usb/hcd/ehci-hcd.o.gz: init_module: No such device
/lib/modules/2.4.20/kernel/drivers/usb/hcd/ehci-hcd.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20/kernel/drivers/usb/hcd/ehci-hcd.o.gz: insmod /lib/modules/2.4.20/kernel/drivers/usb/hcd/ehci-hcd.o.gz failed
/lib/modules/2.4.20/kernel/drivers/usb/hcd/ehci-hcd.o.gz: insmod ehci-hcd failed
root@Mad2Physicist:~#


So I'm not really sure what was up with that. I'm wondering if it would work if I had a PC card USB port.
 
Old 09-06-2003, 08:39 AM   #8
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I did the experiment and ehci-hcd does not load with 1.1 USB controllers. I have another thought.
Try this:
In a terminal screen enter the following:
' echo "scsi add-single-device 0 0 0 0" > /proc/scsi/scsi '
Then do a ' cat /proc/scsi/scsi ' See if it shows a device now. If it does, try mounting it.

Good luck
Brian1
 
Old 09-06-2003, 12:11 PM   #9
mad2physicist
LQ Newbie
 
Registered: Aug 2003
Location: Houghton NY
Distribution: Slackware 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
Here's what it did:

root@Mad2Physicist:~# echo "scsi add-single-device 0 0 0 0" > /proc/scsi/scsi
root@Mad2Physicist:~# cat /proc/scsi/scsi
Attached devices: none

btw, when I attatched the hard drive while the computer was running to test this, i tried running a dmesg and it gave the following (exactly what it was giving before, but at least it knows I plugged something in...):

hub.c: new USB device 00:02.0-2, assigned address 2
usb_control/bulk_msg: timeout
usb-ohci.c: unlink URB timeout
usb.c: USB device not accepting new address=2 (error=-110)
hub.c: new USB device 00:02.0-2, assigned address 3
usb_control/bulk_msg: timeout
usb-ohci.c: unlink URB timeout
usb.c: USB device not accepting new address=3 (error=-110)

I am wondering if the problem is with not having the right scsi drivers. I'm going to start checking those.
Thanks for your help.
 
Old 09-06-2003, 12:19 PM   #10
mad2physicist
LQ Newbie
 
Registered: Aug 2003
Location: Houghton NY
Distribution: Slackware 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
Alright, after doing a "modprobe scsi_debug" I got the following in dmesg:

scsi1 : scsi_debug, Version: 0.61 (20020815), num_devs=1, dev_size_mb=8, 0
Vendor: Linux Model: scsi_debug Rev: 0004
Type: Direct-Access ANSI SCSI revision: 03
Attached scsi disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 16384 512-byte hdwr sectors (8 MB)
sda: unknown partition table
FAT: bogus logical sector size 0
VFS: Can't find a valid FAT filesystem on dev 08:00.

The last two lines were the result of varoius mount commands I tried.
Then I tried:

root@Mad2Physicist:/lib/modules/2.4.20/kernel/drivers/scsi# cat /proc/scsi/scsi
Attached devices:
Host: scsi1 Channel: 00 Id: 00 Lun: 00
Vendor: Linux Model: scsi_debug Rev: 0004
Type: Direct-Access ANSI SCSI revision: 03

However, when I try to mount it:

root@Mad2Physicist:/lib/modules/2.4.20/kernel/drivers/scsi# mount /dev/sda /exthd
mount: you must specify the filesystem type

However, at least it thinks something is there.
Unfortunately, unplugging the drive doesn't change what the SCSI things say, and when I plugged it in again, it only brought up the same "usb not accepting address=x" that i was getting before.
 
Old 09-06-2003, 10:48 PM   #11
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
Your mount command should have been something like:

mount -t vfat /dev/sda1 /exthd

'/dev/sda' refers to the whole drive, whereas '/dev/sda1' refers to the first partition on that drive. You need to specify a partition in a mount command, because it is the partition that holds the filesystem. '-t vfat' is specifying the filesystem type, so you don't get that 'mount: you must specify the filesystem type' error.

Last edited by geoff_f; 09-06-2003 at 10:54 PM.
 
Old 09-07-2003, 11:44 AM   #12
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
It seems to see the device on scsi 1 and not scsi 0. You can try this command ' ' echo "scsi add-single-device 1 0 0 0" > /proc/scsi/scsi '. and see what happens. Then mount like the above post mentions
' mount -t vfat /dev/sda1 /exthd ' . Just make sure you have created a subdirectory /exthd ' mkdir exthd '.

Also what is the format on the drive vfat or ntfs? You need to have ntfs configured in the kernel for it work.

Another option is boot with a knoppix disc and see if you can mount your USB drive.

Good luck
Brian1
 
Old 09-07-2003, 05:19 PM   #13
mad2physicist
LQ Newbie
 
Registered: Aug 2003
Location: Houghton NY
Distribution: Slackware 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
Yes, I knew it ought to be sda1, not sda. However, it said "/dev/sda1 is not valid block device" when I had tried that.
 
Old 10-19-2003, 03:48 PM   #14
yocompia
Member
 
Registered: Apr 2003
Location: Chicago, IL
Distribution: openbsd 3.6, slackware 10.0
Posts: 244

Rep: Reputation: 30
mad, i have a similar problem with a Buslink L20 (20 gig version of what you have) on slack 9.0. did you manage to fix these issues? if so, what did you do?

physics, reprazent,
y-p
 
Old 10-20-2003, 05:23 AM   #15
vernon
LQ Newbie
 
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
works for me :$

I have a 6gb USB External Toshiba Hard Drive
i did as follows

modprobe usbcore
modprobe usb-storage

cat /proc/scsi/scsi

> bash-2.05b# cat /proc/scsi/scsi
> Attached devices:
> Host: scsi1 Channel: 00 Id: 00 Lun: 00
> Vendor: TOSHIBA Model: MK6412MAT Rev: 0811
> Type: Direct-Access ANSI SCSI revision: 02

mount -t vfat /dev/sda1 /mnt/hd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing grub to external USB hard drive for later use as internal hard drive dhave Linux From Scratch 2 12-10-2005 09:48 AM
Hard Drive to /dev mapping rdhochhalter Suse/Novell 4 11-02-2005 07:37 PM
System Manager to modify inode number in USB Flash drive asaba Linux - Software 2 03-09-2005 04:12 AM
Hard Drive Serial Number? daver Linux - Hardware 4 03-17-2004 10:57 AM
external firewire hard drive linked with /dev/mouse? sohmc Linux - Hardware 0 01-17-2004 10:53 AM


All times are GMT -5. The time now is 09:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration