LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-29-2006, 01:13 PM   #1
radmaxntx
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Rep: Reputation: 0
Unhappy USB/HAL audio problem drivers won't load


Hi,
I've got fedora core 5 x86_64 loaded and everything is updated to latest. I use usb audio with an "Audio Advantage" product, spdif out, and it works flawlessly. I plug it in, HAL recognizes it, loads the drivers, life is good.

Last week I decided to add spdif input to my box with the edirol UA-1ex. After doing some reseach I thought this device would work. It doesn't.
When I
cat /proc/bus/usb/devices

The monitor spits out stuff, and then

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=ff(vend.) Sub=00 Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=0582 ProdID=0096 Rev= 1.00
S: Manufacturer=EDIROL
S: Product=UA-1EX
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=200mA
I: If#= 0 Alt= 0 #EPs= 0 Cls=ff(vend.) Sub=02 Prot=00 Driver=(none)
I: If#= 0 Alt= 1 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=00 Driver=(none)
E: Ad=01(O) Atr=09(Isoc) MxPS= 288 Ivl=1ms
I: If#= 1 Alt= 0 #EPs= 0 Cls=ff(vend.) Sub=02 Prot=00 Driver=(none)
I: If#= 1 Alt= 1 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=00 Driver=(none)
E: Ad=82(I) Atr=05(Isoc) MxPS= 288 Ivl=1ms

at the end.

so I Know the computer can see the new device but snd-usb-audio isn't loading.
I think it's a HAL issue. I think HAL needs a listing for the device.

I can manually modprobe snd-usb-audio and it loads but
amixer -c 1
says no card found.

How can I add an entry into HAL or ALSA so they know how to load the correct modules and configure the device????

Hope someone can help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE & hal/dbus/udev problem with USB card... mlaverdiere Debian 7 02-23-2006 08:00 PM
Fedora core 3 HAL locking up the system load UrbanDEV Linux - Software 3 01-08-2005 03:36 AM
How do I load USB Drivers during Install? Fernando534 Linux - Hardware 2 01-07-2005 08:27 AM
strange USB problem... Drivers don't load? exabrial Linux - Hardware 1 04-15-2004 04:57 PM
Please help unable to load usb drivers bernard_lee Linux - Wireless Networking 1 02-20-2004 11:49 PM


All times are GMT -5. The time now is 02:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration