LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   usb drive won't mount - error: wrong fs type, bad option, bad superblock on /dev/sda1 (http://www.linuxquestions.org/questions/linux-hardware-18/usb-drive-wont-mount-error-wrong-fs-type-bad-option-bad-superblock-on-dev-sda1-523173/)

bluecog6 01-27-2007 12:40 AM

usb drive won't mount - error: wrong fs type, bad option, bad superblock on /dev/sda1
 
the drive is a 1 gig pqi intellistick

the computer recognizes it, but when I try to open the drive to view the files, it gives me the error.

it is formatted as FAT32.

This is what I get from /var/log/messages:

Jan 27 00:32:01 linux-3syx kernel: usb 6-5: USB disconnect, address 3
Jan 27 00:32:05 linux-3syx kernel: usb 6-5: new high speed USB device using ehci_hcd and address 4
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: new device found, idVendor=3538, idProduct=0054
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: new device strings: Mfr=1, Product=2, SerialNumber=3
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: Product: IntelligentStick
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: Manufacturer: I-Stick2
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: SerialNumber: 00000000000516
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: configuration #1 chosen from 1 choice
Jan 27 00:32:06 linux-3syx kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Jan 27 00:32:06 linux-3syx kernel: usb-storage: device found at 4
Jan 27 00:32:06 linux-3syx kernel: usb-storage: waiting for device to settle before scanning
Jan 27 00:32:07 linux-3syx kernel: Vendor: I-Stick2 Model: IntelligentStick Rev: 0.00
Jan 27 00:32:07 linux-3syx kernel: Type: Direct-Access ANSI SCSI revision: 02
Jan 27 00:32:07 linux-3syx kernel: SCSI device sda: 2015231 512-byte hdwr sectors (1032 MB)
Jan 27 00:32:07 linux-3syx kernel: sda: Write Protect is off
Jan 27 00:32:07 linux-3syx kernel: sda: Mode Sense: 00 00 00 00
Jan 27 00:32:07 linux-3syx kernel: sda: assuming drive cache: write through
Jan 27 00:32:07 linux-3syx kernel: SCSI device sda: 2015231 512-byte hdwr sectors (1032 MB)
Jan 27 00:32:07 linux-3syx kernel: sda: Write Protect is off
Jan 27 00:32:07 linux-3syx kernel: sda: Mode Sense: 00 00 00 00
Jan 27 00:32:07 linux-3syx kernel: sda: assuming drive cache: write through
Jan 27 00:32:07 linux-3syx kernel: sda: sda1
Jan 27 00:32:07 linux-3syx kernel: sd 3:0:0:0: Attached scsi removable disk sda
Jan 27 00:32:07 linux-3syx kernel: sd 3:0:0:0: Attached scsi generic sg0 type 0
Jan 27 00:32:07 linux-3syx kernel: usb-storage: device scan complete
Jan 27 00:32:13 linux-3syx kernel: NTFS-fs warning (device sda1): is_boot_sector_ntfs(): Invalid boot sector checksum.
Jan 27 00:32:13 linux-3syx kernel: NTFS-fs error (device sda1): read_ntfs_boot_sector(): Primary boot sector is invalid.
Jan 27 00:32:13 linux-3syx kernel: NTFS-fs error (device sda1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
Jan 27 00:32:13 linux-3syx kernel: NTFS-fs error (device sda1): ntfs_fill_super(): Not an NTFS volume.


-------

can anybody help me? :confused:

i would really love to be able to transfer files from XP to openSuSE 10.2 with my [newly purchased] flash drive

bluecog6 01-27-2007 01:15 AM

here is my /etc/fstab

/dev/hdb2 / ext3 acl,user_xattr 1 1
/dev/hdb3 /home ext3 acl,user_xattr 1 2
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda1 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0

bluecog6 01-27-2007 02:24 AM

I think I got it...

I changed this line:
Quote:

Originally Posted by bluecog6
/dev/sda1 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0

to this:

/dev/sda1 /media/usb vfat noexec,noauto,users,gid=100 0 0


I borrowed the "noexec,noauto,users,gid=100" bit from another thread, and I freestyled the "/media/usb" and "vfat" parts. I had to create the "usb" folder in the /media folder.

The only issue -which may not be an issue- is that I was under the impression that the noexec and noauto lines would require me to manually mount the flash drive. When I plug it in, it opens up automatically, and I can access my stuff.

[to anyone viewing this] Should I be concerned at all?

jschiwal 01-27-2007 02:33 AM

The "noexec" option prevents files from being executed directly. It is commonly used for globally writable partitions like /tmp.

The "noauto" option will prevent "mount -a" from trying to boot the device when you boot up. This would cause a hang if the device weren't plugged in.

bluecog6 01-27-2007 09:07 AM

jschiwal - thanks for the reply


All times are GMT -5. The time now is 11:07 AM.