LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-27-2007, 12:40 AM   #1
bluecog6
Member
 
Registered: Jan 2007
Location: Missouri
Distribution: Arch, openSUSE
Posts: 32

Rep: Reputation: 15
usb drive won't mount - error: wrong fs type, bad option, bad superblock on /dev/sda1


the drive is a 1 gig pqi intellistick

the computer recognizes it, but when I try to open the drive to view the files, it gives me the error.

it is formatted as FAT32.

This is what I get from /var/log/messages:

Jan 27 00:32:01 linux-3syx kernel: usb 6-5: USB disconnect, address 3
Jan 27 00:32:05 linux-3syx kernel: usb 6-5: new high speed USB device using ehci_hcd and address 4
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: new device found, idVendor=3538, idProduct=0054
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: new device strings: Mfr=1, Product=2, SerialNumber=3
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: Product: IntelligentStick
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: Manufacturer: I-Stick2
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: SerialNumber: 00000000000516
Jan 27 00:32:06 linux-3syx kernel: usb 6-5: configuration #1 chosen from 1 choice
Jan 27 00:32:06 linux-3syx kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Jan 27 00:32:06 linux-3syx kernel: usb-storage: device found at 4
Jan 27 00:32:06 linux-3syx kernel: usb-storage: waiting for device to settle before scanning
Jan 27 00:32:07 linux-3syx kernel: Vendor: I-Stick2 Model: IntelligentStick Rev: 0.00
Jan 27 00:32:07 linux-3syx kernel: Type: Direct-Access ANSI SCSI revision: 02
Jan 27 00:32:07 linux-3syx kernel: SCSI device sda: 2015231 512-byte hdwr sectors (1032 MB)
Jan 27 00:32:07 linux-3syx kernel: sda: Write Protect is off
Jan 27 00:32:07 linux-3syx kernel: sda: Mode Sense: 00 00 00 00
Jan 27 00:32:07 linux-3syx kernel: sda: assuming drive cache: write through
Jan 27 00:32:07 linux-3syx kernel: SCSI device sda: 2015231 512-byte hdwr sectors (1032 MB)
Jan 27 00:32:07 linux-3syx kernel: sda: Write Protect is off
Jan 27 00:32:07 linux-3syx kernel: sda: Mode Sense: 00 00 00 00
Jan 27 00:32:07 linux-3syx kernel: sda: assuming drive cache: write through
Jan 27 00:32:07 linux-3syx kernel: sda: sda1
Jan 27 00:32:07 linux-3syx kernel: sd 3:0:0:0: Attached scsi removable disk sda
Jan 27 00:32:07 linux-3syx kernel: sd 3:0:0:0: Attached scsi generic sg0 type 0
Jan 27 00:32:07 linux-3syx kernel: usb-storage: device scan complete
Jan 27 00:32:13 linux-3syx kernel: NTFS-fs warning (device sda1): is_boot_sector_ntfs(): Invalid boot sector checksum.
Jan 27 00:32:13 linux-3syx kernel: NTFS-fs error (device sda1): read_ntfs_boot_sector(): Primary boot sector is invalid.
Jan 27 00:32:13 linux-3syx kernel: NTFS-fs error (device sda1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
Jan 27 00:32:13 linux-3syx kernel: NTFS-fs error (device sda1): ntfs_fill_super(): Not an NTFS volume.


-------

can anybody help me?

i would really love to be able to transfer files from XP to openSuSE 10.2 with my [newly purchased] flash drive
 
Old 01-27-2007, 01:15 AM   #2
bluecog6
Member
 
Registered: Jan 2007
Location: Missouri
Distribution: Arch, openSUSE
Posts: 32

Original Poster
Rep: Reputation: 15
here is my /etc/fstab

/dev/hdb2 / ext3 acl,user_xattr 1 1
/dev/hdb3 /home ext3 acl,user_xattr 1 2
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda1 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
 
Old 01-27-2007, 02:24 AM   #3
bluecog6
Member
 
Registered: Jan 2007
Location: Missouri
Distribution: Arch, openSUSE
Posts: 32

Original Poster
Rep: Reputation: 15
I think I got it...

I changed this line:
Quote:
Originally Posted by bluecog6
/dev/sda1 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
to this:

/dev/sda1 /media/usb vfat noexec,noauto,users,gid=100 0 0


I borrowed the "noexec,noauto,users,gid=100" bit from another thread, and I freestyled the "/media/usb" and "vfat" parts. I had to create the "usb" folder in the /media folder.

The only issue -which may not be an issue- is that I was under the impression that the noexec and noauto lines would require me to manually mount the flash drive. When I plug it in, it opens up automatically, and I can access my stuff.

[to anyone viewing this] Should I be concerned at all?
 
Old 01-27-2007, 02:33 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
The "noexec" option prevents files from being executed directly. It is commonly used for globally writable partitions like /tmp.

The "noauto" option will prevent "mount -a" from trying to boot the device when you boot up. This would cause a hang if the device weren't plugged in.
 
Old 01-27-2007, 09:07 AM   #5
bluecog6
Member
 
Registered: Jan 2007
Location: Missouri
Distribution: Arch, openSUSE
Posts: 32

Original Poster
Rep: Reputation: 15
jschiwal - thanks for the reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 08:55 AM
ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1, saiket Linux - Hardware 3 04-12-2008 12:07 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 05:50 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 10:31 AM
USB 2.0 memory stick mount: wrong fs type, bad option, bad superblock on /dev/sda1, o olivier.riff Linux - Hardware 2 11-12-2003 08:11 AM


All times are GMT -5. The time now is 04:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration