LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-31-2011, 06:07 PM   #1
goozlq
Member
 
Registered: Oct 2004
Location: Holland, Zaanstad
Distribution: Debian Sarge 3.1 / K 2.6 / KDE 3.3.2 / Pentium 3 512MB 20G / Amilo L7300 / P2 128MB 260GB
Posts: 31

Rep: Reputation: 15
USB devices cannot be read after NTFS installs in Debian Lenny


I bought an USB drive with 500GB. My Debian Lenny did not find this USB NTFS drive, so I installed all the NTFS packages with KPackage.

The new 500GB gives still an error ( Couldn't set locale to 'en_US' ).

I think that NTFS is supported years ago in Linux?

But after the NTFS installs, all other USB media gave an error in Konqueror:
Invalid filesystem Type.

How can I mount (automatically after plug-in) my USB drives?

dmesg tells that it recognizes the USB drives, but Konqueror gives an error.
 
Old 11-01-2011, 02:55 AM   #2
purevw
Member
 
Registered: Jan 2007
Location: Texas
Distribution: OpenSuSE 13, Kernel 3.13.3
Posts: 90

Rep: Reputation: 45
I am not as familiar with Debian as I would like to be. It would be helpful if you were to post the output of dmesg. Auto-mounting removable media is a bit of a security risk. That being said, I would think that you could use your partitioner (be very careful)to set the system to auto-mount whatever type of external drive. The partitioner should have options for you to set a mount point (i.e. /mount/ext-ntfs/). Be careful that "format drive" is not checked in the options. If you are using several different drives and only one usb port, you would have to set up each mount point when that particular drive is plugged in. Once done, the drive should mount to that path any time it's plugged in. I am not sure, but it may be necessary to manually unmount whatever drive you are using before you unplug it. I know that ntfs drives frown on being unplugged without being properly unmounted.
Does the KDE device notifier let you know when the drive is plugged? If things are working correctly, you should only have to click the "mount" icon in the notifier and the drive should show up under /media/device-name/ That is really the preferred method for mounting removable media with KDE.
Without seeing the output of dmesg, it is very hard to pinpoint what your problem might be. I can't imagine how installing ntfs support would have foo-barred your ability to mount other drives. Could you also post your /etc/fstab ?
 
Old 11-01-2011, 08:43 AM   #3
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 63

Rep: Reputation: 3
I use Ubuntu which is derived from Debian, and have no trouble at all with USB drives. I have never had to load an NTFS package, but perhaps that is a difference between Debian and Ubuntu. From your description, "new 500GB gives still an error ( Couldn't set locale to 'en_US' )" I wonder if your USB drive has something attempting to auto-execute on it. "en_US" is US English, and is a parameter set in the locale to determine what language to use in a program, interface or display. In short, I'm wondering if the NTFS package you loaded is in a different language than your OS, which could present an error like you are seeing.

My suggestion is to try booting from a live Ubuntu CD and see if it can mount the USB drive. You can also see if Dutch works as well as US English, just in case that locale variable is part of the problem. If the hardware is functional, then at least you will have narrowed the issue down to OS or software. If so, you might want to experiment with the US English version of Debian and see if it works there. I imagine that's not how you would like to work, but if you could narrow it down, it would help you find a permanent solution.
 
Old 11-01-2011, 03:40 PM   #4
hasienda
Member
 
Registered: May 2009
Location: Saxony, Germany
Distribution: Debian/GNU Linux
Posts: 37

Rep: Reputation: 18
Reconfigure locales, but ultimately give more information

The locale error might not be related to the issue of not seeing your USB drive and respective partion(s) on it. Anyway it should help to become root, issue a
Code:
dpkg-reconfigure locales
in a terminal, select one or more of the available en_US profiles and let them be (re-)compiled.

The mounting process and related issues are best seen by watching /var/log/syslog. Again becoming root (or getting adm group membership) is required to open that log file like
Code:
tail -f /var/log/syslog
and break out with <Ctrl>+<C> after you're done.

We'll need to know the messages that you see on/after connecting the USB drive to get any further than doing plain guesswork.

Btw, consider upgrading to Squeeze. This might not solve your issue, but better follow current stable before support is gone for old-stable in too many aspects. I've done many upgrades over the years, and Lenny->Squeeze wasn't especially hard, but YMMV.
 
Old 11-03-2011, 11:38 AM   #5
gwmorris
LQ Newbie
 
Registered: Sep 2011
Posts: 14
Blog Entries: 1

Rep: Reputation: Disabled
Well, I'm using Fedora, as it provides a nice GUI and also has a good kernel, but that's just me. I've tried Mandrake (when it was around), Slackware, RedHat (when IT was still free!), and dabbled with a few others. I bought a 500G external USB drive about 6 months ago or so for backups. The guy I got it from said he had a Mac, and it was for PC! Guess he wasn't that computer literate and I think I paid $40US for it. I plugged it in, restarted the computer and presto! It was mounted and everything. I knew I had the NTFS support, but didn't expect that. Since I was backing up BOTH Windows and Fedora Linux, the first thing I did was cut it in half, giving about 250G to NTFS and ext4 each. The computer had no problem with anything I did with it, and I successfully backed up everything I needed to. In your case, if you DON'T need NTFS, just format the whole drive with a Linux FS. If your system even recognizes it as a hard drive now, I'd reformat the entire 500G with ext4, reiser, ext3, whatever your distro can see! IF you can do that and don't really NEED the NTFS driver(s) or an NTFS file system, the next boot should see it just fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Access to NTFS USB devices from Dolphin Alain Lemerre Slackware 6 08-01-2010 12:17 PM
No volume control GStreamer plugins and/or devices found in Debian Lenny ron177 Linux - Newbie 3 07-21-2010 04:14 PM
Debian doesn't read USB devices, need troubleshooting ideas....PLEASE?! tmick Debian 8 03-18-2010 01:39 PM
debian 5 Lenny hidden my NTFS partition newslack Debian 3 11-15-2009 08:22 PM
Block devices are inaccessible - Debian Lenny indienick Debian 1 01-19-2009 11:44 AM


All times are GMT -5. The time now is 12:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration