LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-20-2006, 05:59 PM   #16
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Rep: Reputation: 31

Please don't type in "locate ......" That doesn't help. If you had posted your /etc/fstab and the out put of these two commands,

dmesg | grep usb
dmesg | grep sd

we could have helped you solve this problem a long time ago. If you won't help us help you in the simplest of ways, then I'm not going to try any longer, as it's a waste of your time and mine.

Good luck...

David

P.S. I found this on the net, and it explains things better than I could. Good luck...

http://www.novell.com/coolsolutions/feature/11637.html

Last edited by budword; 12-20-2006 at 07:24 PM.
 
Old 12-21-2006, 04:34 PM   #17
Tux-O-Matic
Member
 
Registered: Sep 2006
Distribution: Fedora Core 5 (no internet)
Posts: 95

Original Poster
Rep: Reputation: 15
Good News!
Now all of a sudden I have /dev/sda and /dev/sda1
So now I edit /etc/fstab to say:
Code:
/dev/sda      /mnt/usb      -------     0 0
...and no, I didn't put those hyphens in. I tried just about every file system I could think of in /etc/fstab. The closest I got was usbfs, which just listed some folders with a "device" text file and another unknown "001" file.
Anybody know what goes in the ------? (I'm sorry this thread is so long)
 
Old 12-22-2006, 01:47 AM   #18
red_moin
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Rep: Reputation: 0
about USB

/dev/sad1/mnt/usb auto default,users,noauto 0 0
 
Old 12-22-2006, 02:41 AM   #19
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Rep: Reputation: 31
This is what the line in your /etc/fstab should look like. Change noauto to auto if you want linux to mount it automaticly. (Might screw up some other stuff, but I'm not sure.) As it is, you will have to open a console and type mount /dev/sda when you want to use it.

/dev/sda /mnt/usb auto defaults,noauto,user 0 0

P.S. found some stuff on the net that implied hfs had to be enabled in the kernel.
"There are other times when you may want to mount a native OS X partition in Linux. An example of why you may want this is if you, say, have a bootable OS X environment on some removal media but want to easily transfer the drive around and/or load it up in PearPC. In this case, you instead would want to enable HFS+ in the kernel. As of 2.6.11, HFS (which is used by older macs) is available experimentally and UFS (which is used on some OS X machines for greater UNIX compatibility) in read-only. Enable Apple Extended HFS file system support."

I found that here....
http://72.14.203.104/search?q=cache:...s&ct=clnk&cd=9

I checked the man page for mount, and it looks like hfs and hpfs are supported, but by using auto, mount MIGHT not detect it correctly, so try hfs or hpfs for the extended version.

So if auto doesn't work, use hfs or hpfs for the filesystem type in fstab. If that doesn't work, check to see if you have hfs support enabled in the kernel you are running.

Good luck...

David

P.P.S. You might want to read this too, and that fs type might be hfsplus not hpfs.

http://www.linuxquestions.org/questi...d.php?t=497585

Good luck

Last edited by budword; 12-22-2006 at 02:57 AM.
 
Old 12-27-2006, 05:00 PM   #20
Tux-O-Matic
Member
 
Registered: Sep 2006
Distribution: Fedora Core 5 (no internet)
Posts: 95

Original Poster
Rep: Reputation: 15
Thank you for all your help, but nothing changed ever since I put that in.
I'm going to try to find out how to have hfs support on my system, because when I typed in "locate hfs", the only thing that came up was "hfs.ko", which seems like a disk image. Does anyone know how I could have hfs support.
Once again, thank you very much.
 
Old 12-27-2006, 05:07 PM   #21
Tux-O-Matic
Member
 
Registered: Sep 2006
Distribution: Fedora Core 5 (no internet)
Posts: 95

Original Poster
Rep: Reputation: 15
Actually, after a little Googling, I found hfs.
It's a text file, though. What am I supposed to do with it?
 
  


Reply

Tags
dev, mount, usb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive not working properly, read only device? (USB key storage device) Arodef Linux - Hardware 14 01-01-2010 08:32 AM
How to force kernel to use a USB 2.0-compatible device (ehci_hcd) as a USB 1.1 device eze Linux - Hardware 0 05-16-2006 06:24 AM
Failed to open device /dev/usb/ttyUSB0: No such device efm Linux - Newbie 2 04-04-2005 09:46 PM
HP Deskjet (USB) & CUPS & Slackware 9.1: Unable to open USB device "usb:/dev/usb/lp0&qu arnostienen Slackware 2 01-29-2004 04:22 PM
how can I mount this device: da0: <USB 2.0 Storage Device alkad_mzu *BSD 2 11-15-2003 07:15 PM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration