LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-15-2008, 04:34 AM   #1
nkd
Member
 
Registered: Oct 2006
Location: india
Distribution: fedora 8, ubuntu 10.10
Posts: 313

Rep: Reputation: 34
usb auto mount stopped working


hi everyone,
I have a fedora8 install on my laptop.
I have recently encountered a problem - my usb flash drives are no longer automatically mounted.
I donot remember having done anything in specific which caused it. But earlier on I had to just plug in my flash drive and an icon use to appear on the desktop. This is not working now.
However, I can still mount it manually.
I saw a few threads on this topic but haven't been able to find a solution as yet.What I have understood is - it's a HAL problem.
Can someone help me trouble shoot it.
thanks in advance
nishith
 
Old 12-15-2008, 09:21 PM   #2
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
One thing to try.

I have never used fedora. Are you using kde or gnome? You can usually set options to have the mount-point on the desktop or not and since you can mount manually this might just be disabled. Check your GUI config settings and make sure its enabled.
 
Old 12-16-2008, 12:25 AM   #3
nkd
Member
 
Registered: Oct 2006
Location: india
Distribution: fedora 8, ubuntu 10.10
Posts: 313

Original Poster
Rep: Reputation: 34
I am using GNOME and the auto mount options are all checked correctly.
This has to be something with the HAL configuration as I had some problems with gnome power manager a few days back. I think somehow I had broken a few gnome applications and gnome-mount may also be one of them which if I am not wrong uses hald.
I just need the right references to get going...
thanks anyway
nishith
 
Old 12-17-2008, 11:59 AM   #4
nkd
Member
 
Registered: Oct 2006
Location: india
Distribution: fedora 8, ubuntu 10.10
Posts: 313

Original Poster
Rep: Reputation: 34
ok here's something unusual I noticed....
During bootup there is a warning which says something like - udevadm to be called instead of udevsettle....I donot have enough time to read it.
I scoured the /var/log/messages file, after the bootup completed, but did not find the error / warning in it.
Is there some other place where the boot messages get stored as they show up on the screen when the bootup process is in progress.
From whatever, I know it seems like the warning kicks in immediately after udev is invoked.
thanks
nishith
 
Old 12-21-2008, 12:08 PM   #5
nkd
Member
 
Registered: Oct 2006
Location: india
Distribution: fedora 8, ubuntu 10.10
Posts: 313

Original Poster
Rep: Reputation: 34
Well I explored a little bit on my own and it seems like the trouble is only with the windows partitions , the linux partitions continue to automount and show up on my desktop alright.
So I looked into the /etc/hal/policy file and found the dir structure entirely empty. Shouldnot there be some policies and files to register the callouts for the DBus messages ?
Should I re install hald on my system
can someone help me out ?
thanks
nishith
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto Mount not working for USB? Hald not running? SonoranFun Linux - Newbie 6 05-15-2011 02:31 PM
how is the usb auto mount working ? nkd Linux - Hardware 2 10-31-2007 01:48 PM
USB stopped working vieraci Linux - Laptop and Netbook 4 05-12-2007 03:09 AM
SuSE 9.3 USB Flash Drive Auto Mount Stopped Working nuro305 Linux - Hardware 11 04-15-2007 05:21 AM
auto mount ext3 usb hardrive not working fedora 5 Paridoth Fedora 2 05-30-2006 08:39 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration