LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-04-2008, 10:49 PM   #1
dreamscaper
Member
 
Registered: Aug 2008
Location: Austin, TX
Distribution: Kubuntu Hardy Heron 8.04
Posts: 31

Rep: Reputation: 15
unresolved nightmare sound problem - inspiron 1721, card=SB600, SBx00 Azalia


I have tried all sorts of things to get the darned sound working. I have been at it for some time. I have tried getting new modules, I have tried modifying menu.lst with acpi=off, I have tried uninstalling and reinstalling alsa. I have gone through all kinds of troubleshooting manuals. I don't know what else to do. I am determined though. If there is anyone here that is really good at solving this stuff, I could really use your help. I am running Kubuntu Hardy Heron 8.04.

Here is an article on my computer which has all the hardware info from someone who got it to work with pclinuxos: http://pclinuxoshwdb.com/index.php?o...=887&Itemid=63

Also, I have noted that /conf/asound is completely empty. I have suspected that maybe that was it, but I really have no idea if that means anything or how to fix it.

Here is my lspci:

00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)
00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
03:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
03:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
0b:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
 
Old 08-04-2008, 11:09 PM   #2
bhaslinux
Member
 
Registered: Oct 2003
Location: UnitedKingdom
Distribution: Debian Lenny
Posts: 351

Rep: Reputation: 47
Did your compiled module load properly and detect the sound card ? (ALSA) [see dmesg output]
This may look silly but it so happens that when a sound module is loaded, the sound is muted. So you have to use aumix or something equivalent and increase the sound and then check if the soundcard is working ...
Your card looks like SoundBlaster and I think there must not be any trouble with this type of card.
 
Old 08-04-2008, 11:53 PM   #3
dreamscaper
Member
 
Registered: Aug 2008
Location: Austin, TX
Distribution: Kubuntu Hardy Heron 8.04
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bhaslinux View Post
Did your compiled module load properly and detect the sound card ? (ALSA) [see dmesg output]
This may look silly but it so happens that when a sound module is loaded, the sound is muted. So you have to use aumix or something equivalent and increase the sound and then check if the soundcard is working ...
Your card looks like SoundBlaster and I think there must not be any trouble with this type of card.
Yes, I have checked the volume many times. Bars are all the way up, and it is not muted. As far as I can tell the card has been detected properly. I have used the "test sound" option in the system settings area to test the sound several times after loading modules and this and that, with no luck. I am considering updating the kernel to see if that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Technologies Inc SBx00 Azalia kafnir Linux - Hardware 1 01-11-2008 08:25 PM
Wireless on Dell Inspiron 1721 running Fedora 8 nkaem_ael Linux - Laptop and Netbook 0 01-04-2008 08:35 PM
i have problem with sound in ATI SB600 chipset,i not hear sound on it jodiedupri Linux - Hardware 0 01-26-2007 08:30 AM
Intel HD Audio (azalia) - No sound! (kernel 2.6.17.8 @ slackware current) violat0r Linux - Hardware 11 08-25-2006 03:07 AM
Sound Card nightmare. Will Slackware 11 07-17-2002 05:33 PM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration