LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-18-2009, 06:19 PM   #1
desertViking
Member
 
Registered: Aug 2005
Location: Arizona
Distribution: Slackware 13, Arch Linux
Posts: 85

Rep: Reputation: 15
Unplugging USB device generates weird /var/log/messages entry


Hi,

I'm having trouble getting Mandriva to recognize my udev rules. These rules work fine on several other distros. I've used them on Suse, Fedora, Slackware and Debian, so I'm reasonably confident that they are crafted OK but I'm not understanding something about udev on Mandriva.

The correct read/write attributes are not set when I plug the device in, but it functions correctly if I mannual set them via chmod.

The interesting thing is that when I disconnect the device, it throws a wierd error into /var/log/messages:

Code:
exec of program '/lib/udev/' failed
Has anyone ever seen that before, and does it provide some clue as to what my problem might be?
 
Old 09-18-2009, 08:04 PM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
hi

I am no expert but
http://www.reactivated.net/writing_udev_rules.html
http://linux.die.net/man/8/udevadm

2) maybe your rule expects a certain mount pathway which Mdv does not use?

3) have you tried to run
udevadm info
udevadm control debug

4) does your rule have a line similar to this? separated by a comma of course

RUN+="/bin/chmod 660 /pathway/file or /dev/something "

or define group or use 666 to get it working rw

Last edited by aus9; 09-18-2009 at 08:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/var/log/messages and /var/log/cron not working sigkill Linux - Software 6 08-09-2008 01:08 PM
Why?? reset high speed USB device using ehci_hcd in /var/log/message steve457 Linux - Software 0 07-12-2007 05:58 PM
/var/log/messages weird entries blizunt7 Linux - Security 5 11-01-2005 05:56 PM
Redirecting the kernel messages to file other than /var/log/messages jyotika_b83 Linux - General 3 04-28-2005 06:39 PM
weird network jibberish in /var/log/messages - how to remove? chibi Linux - Networking 3 09-22-2004 10:17 AM


All times are GMT -5. The time now is 09:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration