LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Unable to mount USB stick "Only Root can do that"... (http://www.linuxquestions.org/questions/linux-hardware-18/unable-to-mount-usb-stick-only-root-can-do-that-876415/)

dkolars 04-21-2011 05:59 PM

Unable to mount USB stick "Only Root can do that"...
 
Just recently uggraded from Ubuntu 9.10 to 10.04... I'm not liking 10.04!!

It's messed with my KMail, and NOW I find that when I insert a USB stick, I get the message:

"An error occurred while accessing '7.4 GiB CANON_DC (vfat) [/media/Ext3]', the system responded: mount: only root can mount /dev/sdi1 on /media/Ext3"

What the H**L happened... in 9.10, I put in the stick, and could instantly view/copy/etc. from it in Krusader...

Same result with a USB HDD...

I've read a bunch of posts, and nothing really says how to have Ubuntu simply mount whatever I give it to read... That's what I'm after... I made myself part of the Admin and root groups, but that only changed the error message to show that the system recognized what device I'd plugged in.

It's the lil' things, and 10.04 seems to have a few... So, tried to mount it:

:~$ sudo mount /dev/sdi1 on /media/Ext3
[sudo] password for dkolars:
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
One can change the type of mount containing the directory dir:
mount --make-shared dir
mount --make-slave dir
mount --make-private dir
mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
mount --make-rshared dir
mount --make-rslave dir
mount --make-rprivate dir
mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount.
:~$


Halp... I need to transfer files from my desktop to my laptop before I leave tonight for 10 days!!

dkolars 04-21-2011 06:01 PM

OK, so just caught the error... I had the word "on" in the mount command... However, when I shut down my system and restart it, am I gonna have to jump thru all these hoops again? Sure hope not... I want it to auto mount...

dkolars 04-21-2011 06:07 PM

OK... new problem.. when I upgraded to 10.04, suddenly Krusader is seeing my external drives as Ext2, Ext3... there used to be Ext1, but that's the one that died... it ALSO sees Ext2_ & Ext3_... The drives with the underscores are the "real" drives... Have no idea why the names were changed and why the original names are not being used... Anyway, I issued the mount command, and it mounted the USB stick to Ext3... But, that is not accessible! Just like Ext2... they are something that I can't get into. 10.04 sucks, near as I can tell... had none of these problems with 9.10 and the one before it...

spankbot 04-21-2011 06:12 PM

With regards to letting users mount USB devices...

Do you have a line for /dev/sdi1 in your /etc/fstab? If not, you need to have one. In order to allow users to mount/umount your usb stick you would would need a line that looks something *like* this...

Code:

/dev/sdi1  /media/Ext3  vfat    user,noauto,relatime    0  0
I don't use Ubuntu, but here is the Ubuntu specific instructions your need...
https://help.ubuntu.com/community/Fstab

spankbot 04-21-2011 06:17 PM

Your questions are a little confusing because your seem to have named your mount points after filesystem types (Ext2, etc).

Can you post the output of "sudo fdisk -l" as well "df" along with a specific question? This way we'll have a better understanding of what's in your computer.

yancek 04-21-2011 06:28 PM

Agree with what spankbot said and also if you look at the command and output from mount you posted in your initial post, you don't have a filesystem type. If it's a fat32 partitions: mount -t vfat /mnt/sdi1 /media/usb.

I'd change the mount point you used from Ext3, don't know why you would use something like that. Also do you have the directory in /media, in your initial post it would be Ext3?

dkolars 05-05-2011 02:01 AM

Thanks for the replies... I'm back on the mainland now and dealing with this again!!

I think the root of my problem was that I had a hard drive die. Spankbot sez: "Your questions are a little confusing because your seem to have named your mount points after filesystem types (Ext2, etc)."

Not understanding the meaning of that, I did a search and found what he was referring to... What I was doing was naming the drives logically (to me)... 1st external hdd = Ext1, 2nd external hdd = Ext2, etc. Did not know about the Linux use of ext2, et. al.

So, my disk drives are HD1 (Primary), HD2 (2nd internal hdd), and the 3 external drives. Ext1 died, or rather, as it turns out, the electronics in the external case died. I plugged the drive into a different SATA case, and the drive works just fine... AFTER about 3 re-boots, Lucid now recognizes all 3 external drives again and mounts them on boot up.

BUT, I still have showing in /media (via Krusader [Properties][Permissions]):
-- HD1 (internal drive, user & group = root)
-- HD 1 (user and group = root-- Clicking on it gives "ACCESS DENIED to HD 1")
-- HD2 (internal drive, user & group = root)
-- Ext1 (user & group = root -- clicking on it gives message ** below)
-- Ext1_ (1st external drive, user & group = dkolars)
-- Ext2 (user & group = root -- clicking on it gives message ** below)
-- Ext2_ (2nd external drive, user & group = dkolars)
-- Ext3 (3rd external drive user & group = root -- HOWEVER, I can access this drive and do anything with any file!)

**
Could not mount device.
The reported error was:
mount: only root can do that

The drives with the underscore after the name appeared when I upgraded (?) to 10.04 from 9.10.

Curious as to why Ext3 is root like Ext1 & Ext2, but I can only access Ext3? Very strange... I've changed nothing in the /etc/fstab.

Here is the output of "sudo fdisk -l":

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd0f4738c

Device Boot Start End Blocks Id System
/dev/sda2 * 1 60801 488384001 5 Extended
/dev/sda5 1 58363 468792733+ 83 Linux
/dev/sda6 58363 60801 19591204+ 82 Linux swap / Solaris

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000970a9

Device Boot Start End Blocks Id System
/dev/sdb1 1 60801 488384001 7 HPFS/NTFS

Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x99f37a64

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 121601 976760001 7 HPFS/NTFS

Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes
1 heads, 63 sectors/track, 31008336 cylinders
Units = cylinders of 63 * 512 = 32256 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x01f3fc46

Device Boot Start End Blocks Id System
/dev/sdd1 * 2 31008256 976760032+ 7 HPFS/NTFS

Disk /dev/sdi: 1000.2 GB, 1000204885504 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000a7eb1

Device Boot Start End Blocks Id System
/dev/sdi1 * 1 121601 976760001 7 HPFS/NTFS


Here's my fstab:

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda5 :
UUID=e98bf6c1-2056-47f4-8ad9-455c7e7fa529 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda6 :
UUID=bb687805-94d4-46de-8bd8-8d4c772848d8 none swap sw 0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sr1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sdb1 /media/HD2 ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sdg1 /media/Ext1 ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sdh1 /media/Ext2 ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sdi1 /media/Ext3 ntfs-3g defaults,locale=en_US.UTF-8 0 0


I should probably mention that in Nautilus, the drives are shown as HD2 (pointing to /media/HD2), Ext1 (pointing to /media/Ext1_), Ext2 (pointing to /media/Ext2_), and Ext3 (pointing to /media/Ext3).

So, all that said, should I create new names for the external drives in /media, then change the entries in fstab to match the new names? I'm adding an additional external drive as well, so will have to add it to everything as well.

Wondering where HD 1 came from, and why 10.04 changed the names??? Also wanting to get rid of the extra crap like that and have it accurately show what's what.

Thanks! DK.


All times are GMT -5. The time now is 12:04 AM.