LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Unable to Install ZTE AC8710 CDMA Hi Speed Modem on Fedora 10 x86. (http://www.linuxquestions.org/questions/linux-hardware-18/unable-to-install-zte-ac8710-cdma-hi-speed-modem-on-fedora-10-x86-713596/)

maheshkuruganti 03-22-2009 02:14 PM

Unable to Install ZTE AC8710 CDMA Hi Speed Modem on Fedora 10 x86.
 
I am unable to install a ZTE AC8710 CDMA Hi Speed Modem on Fedora 10.I have somehow found the Linux Drivers but am unable to compile them as I do not have the required Kernel Headers which I can't download in Linux because my Internet is not working.I have tried the entire process of trying to add the Device ID and setting up xvdial but I am unable to find the ttyUSB or USBtty or USBacm in /dev. Any help would be appreciated.Thank You.

khurtsiya 04-30-2009 01:52 PM

I have same problem.

hurry_hui 04-30-2009 02:12 PM

I do not know if this is hijacking someone's thread. But you need to create your own post. Anyway, you need to post output of 'lsusb' and 'dmesg | grep -i usb' for start.

khurtsiya 05-01-2009 01:48 AM

Whi is this hijacking - we have same problem.

Quote:

michael@michael-laptop:~$ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 008: ID 19d2:fff5
Bus 005 Device 003: ID 0458:0036 KYE Systems Corp. (Mouse Systems) Pocket Mouse LE
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 138a:0001
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 07ca:a309 AVerMedia Technologies, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 064e:a103 Suyin Corp.
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Quote:

michael@michael-laptop:~$ dmesg | grep -i usb
[ 2.086549] usbcore: registered new interface driver usbfs
[ 2.086568] usbcore: registered new interface driver hub
[ 2.086946] usbcore: registered new device driver usb
[ 2.162817] ehci_hcd 0000:00:1a.7: new USB bus registered, assigned bus number 1
[ 2.181016] ehci_hcd 0000:00:1a.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[ 2.181136] usb usb1: configuration #1 chosen from 1 choice
[ 2.181158] hub 1-0:1.0: USB hub found
[ 2.188997] USB Universal Host Controller Interface driver v3.0
[ 2.389345] uhci_hcd 0000:00:1a.0: new USB bus registered, assigned bus number 2
[ 2.389460] usb usb2: configuration #1 chosen from 1 choice
[ 2.389482] hub 2-0:1.0: USB hub found
[ 2.501025] usb 1-2: new high speed USB device using ehci_hcd and address 2
[ 2.596257] uhci_hcd 0000:00:1a.1: new USB bus registered, assigned bus number 3
[ 2.596367] usb usb3: configuration #1 chosen from 1 choice
[ 2.596390] hub 3-0:1.0: USB hub found
[ 2.637513] usb 1-2: configuration #1 chosen from 1 choice
[ 2.804781] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 4
[ 2.916126] usb 3-2: new full speed USB device using uhci_hcd and address 2
[ 2.928122] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[ 2.928238] usb usb4: configuration #1 chosen from 1 choice
[ 2.928271] hub 4-0:1.0: USB hub found
[ 3.078590] usb 3-2: configuration #1 chosen from 1 choice
[ 3.136567] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 5
[ 3.136664] usb usb5: configuration #1 chosen from 1 choice
[ 3.136686] hub 5-0:1.0: USB hub found
[ 3.344594] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 6
[ 3.344690] usb usb6: configuration #1 chosen from 1 choice
[ 3.344709] hub 6-0:1.0: USB hub found
[ 3.416122] usb 4-6: new high speed USB device using ehci_hcd and address 4
[ 3.448588] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 7
[ 3.448682] usb usb7: configuration #1 chosen from 1 choice
[ 3.448701] hub 7-0:1.0: USB hub found
[ 3.588631] usb 4-6: configuration #1 chosen from 1 choice
[ 3.704128] usb 5-1: new full speed USB device using uhci_hcd and address 2
[ 3.860813] usb 5-1: configuration #1 chosen from 1 choice
[ 4.108118] usb 5-2: new low speed USB device using uhci_hcd and address 3
[ 4.284761] usb 5-2: configuration #1 chosen from 1 choice
[ 4.749196] usbcore: registered new interface driver hiddev
[ 4.763156] input: Genius NetScroll + Mini Traveler as /devices/pci0000:00/0000:00:1d.0/usb5/5-2/5-2:1.0/input/input2
[ 4.774909] input,hidraw0: USB HID v1.10 Mouse [Genius NetScroll + Mini Traveler] on usb-0000:00:1d.0-2
[ 4.774926] usbcore: registered new interface driver usbhid
[ 4.774929] usbhid: v2.6:USB HID core driver
[ 16.357505] input: Acer Crystal Eye webcam as /devices/pci0000:00/0000:00:1d.7/usb4/4-6/4-6:1.0/input/input10
[ 16.368166] usbcore: registered new interface driver uvcvideo
[ 16.368169] USB Video Class driver (v0.1.0)
[ 38.372620] usbcore: registered new interface driver usbserial
[ 38.373987] usbserial: USB Serial support registered for generic
[ 38.375283] usbcore: registered new interface driver usbserial_generic
[ 38.375294] usbserial: USB Serial Driver core
[ 972.600360] usb 5-1: USB disconnect, address 2
[ 972.853070] usb 5-1: new full speed USB device using uhci_hcd and address 4
[ 973.027222] usb 5-1: configuration #1 chosen from 1 choice
[ 973.572129] usb 5-1: USB disconnect, address 4
[ 984.472099] usb 5-1: new full speed USB device using uhci_hcd and address 5
[ 984.652374] usb 5-1: configuration #1 chosen from 1 choice
[ 984.655929] usbserial_generic 5-1:1.0: generic converter detected
[ 984.657372] usb 5-1: generic converter now attached to ttyUSB0
[ 984.775592] usbcore: registered new interface driver libusual
[ 1642.805129] usb 5-1: USB disconnect, address 5
[ 1642.809768] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[ 1642.809809] usbserial_generic 5-1:1.0: device disconnected
[ 1643.049082] usb 5-1: new full speed USB device using uhci_hcd and address 6
[ 1643.577095] usb 5-1: device not accepting address 6, error -71
[ 1643.633146] hub 5-0:1.0: unable to enumerate USB device on port 1
[32345.064050] usb 5-1: new full speed USB device using uhci_hcd and address 8
[32345.223782] usb 5-1: configuration #1 chosen from 1 choice
[32345.228289] usbserial_generic 5-1:1.0: generic converter detected
[32345.230147] usb 5-1: generic converter now attached to ttyUSB0

hurry_hui 05-01-2009 02:15 AM

Quote:

Whi is this hijacking - we have same problem.
Well, it's Ok then.

Btw, you need to enter information above within [code]...[/code] not [quote]...[/quote]


Quote:

Bus 005 Device 008: ID 19d2:fff5
This I think your modem device.

You might try this.

Code:

sudo modprobe usbserial vendor=0x19d2 product=0xfff5
Then check again with 'sudo wvdialconf' .

khurtsiya 05-02-2009 02:50 AM

That was done before. Then Trying to detect by GNOME-PPP with no results.

Your suggestion:

Code:

michael@michael-laptop:~$ sudo modprobe usbserial vendor=0x19d2 product=0xfff5
[sudo] password for michael:
michael@michael-laptop:~$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0  S1  S2  S3  USB0 USB1 USB2


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDial

If you still have problems, send mail to <wvdial-list@lists.nit.ca>.
michael@michael-laptop:~$

P.S.
What is the difference between quote and code?
There are no code button in quick reply, so it is easier to use quote =)

khurtsiya 05-08-2009 05:19 AM

Anyone?

Installed Ubuntu 9.04 - no luck again...

taaheel 10-09-2009 06:18 PM

Hi .. I hope you solved it but if not ..
Then (for ubuntu 8.04 & kernels above 2.6.30 (may be in 2.6.29 but i haven't tried it)) .
So you need to switch the mode first (from product=0xfff5 to product=ffff) because the modem shows the flash drive (or the cdrom) mode first , and you can do that by installing usbb_modeswitch (look for it !!)
Then you edit the conf file in
Code:

sudo gedit /etc/usb_modeswitch.conf
Remove the (;) before the target product id of your modem (zte ac8710 or any supported modems) it's supposed to be (ffff) ..
Then you run the command usb_modeswitch it should say in the end something like ok or goodby (or any positive answer) then run lsusb if it didn't switch try removing the modem and putting it back wait about 10 seconds and run lsusb if itswitched congrats if it didn't then make sure you did all the above right (or may be be I'm not right) ..

After all the above you need to run (as root or by sudo )

Code:

# modprobe usbserial product=0x19d2 vendor=0xffff
then make sure you have wvdial or a similer one (kppp ,ppp) then set it to your modem properties (username , password , Baud ) i use wvdial and you set by editing
/etc/wvdial.conf
it should look like
Code:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
 Baud = 115200
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = #777
Password = *******
Username = *******
stupid mode = 1
New PPPD = yes

Then (as root or sudo )
# wvdial (sudo wvdial)

{when I said for "ubuntu 8.04 & kernels above 2.6.30 ..." , I ment the 2.6.28 has the usbserial model built in it so you need to put it as an option in /boot/grub/menu.lst }

you do that by typing in the line that starts
kernel /boot/vmlinuz-2.6.30-02063003-generic root=/dev/sda1 ro quiet splash usbserial.vendor=0x19d2 usbserial.product=0xffff
somthing like that (make sure it's inone line)
then save it restart (remember this is for ubuntu 9.04 jaunty (and the 2.6.28 kernel))}
hope it worked ... ;)
please inform me if there's a mistake I made somewhere .. :)

NOte : when you disconnect for any reason you have have to remove the modem the replug it >>bye


All times are GMT -5. The time now is 03:30 AM.