LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-21-2005, 01:26 PM   #1
spariggio82
Member
 
Registered: Apr 2004
Location: Camporotondo Etneo, Sicily
Distribution: SuSE 8.2 SuSE 9.1 Fedora C1 Slackware 10.1 Knoppix 3.9
Posts: 174

Rep: Reputation: 30
Angry Unable to install intel onboard soundcard using ALSA


Hi to all

I've Installed Knoppix 3.9 on my laptop and most of the things goes fine.

However when I try to configure my soundcard I get some trouble

My soundcard is an intel ICH6 family

exactly from lspci I obtain this:

Code:
0000:00:1b.0 0403: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
I've tried to configure it using alsaconf. But even if I've installed the latest version from alsa site and even if alsa initially show it when I try to configure here's what I obtain:

Code:
Running update-modules...
Loading driver...
Setting up ALSA...done (not loaded).
Setting default volumes...
Saving the mixer setup used for this in /etc/asound.state.
/usr/sbin/alsactl: save_state:1163: No soundcards found...
What can I do???

Thanks in advance for your help
 
Old 09-22-2005, 08:32 AM   #2
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 374

Rep: Reputation: 55
What motherboard do you have ?

Also what kernel do you use ?

The majority of ICH6 have azalia high definition codec (Realtec or Cmedia chipset).
If that is the case then the module is "snd-hda-intel"

If you run "modprobe snd-hda-intel" then it should work
I believe it was included in 2.6.12 kernel.
 
Old 09-23-2005, 02:22 AM   #3
spariggio82
Member
 
Registered: Apr 2004
Location: Camporotondo Etneo, Sicily
Distribution: SuSE 8.2 SuSE 9.1 Fedora C1 Slackware 10.1 Knoppix 3.9
Posts: 174

Original Poster
Rep: Reputation: 30
First of all Happy Birthday.

Quote:
Originally posted by imitheos
What motherboard do you have ?


I don't know exactly. I have an ASUS laptop


Quote:
Also what kernel do you use ?
2.6.11


Quote:
The majority of ICH6 have azalia high definition codec (Realtec or Cmedia chipset).
If that is the case then the module is "snd-hda-intel"

If you run "modprobe snd-hda-intel" then it should work
I believe it was included in 2.6.12 kernel.
It should be realtek chipset. However when I run modprobe snd-hda-intel here's what I have for answer:

Code:
WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.11/kernel/sound/acore/snd-page-alloc.ko): Invalid module format
FATAL: Error inserting snd (/lib/modules/2.6.11/kernel/sound/acore/snd.ko): Invalid module format
WARNING: Error running install command for snd
WARNING: Error inserting snd_timer (/lib/modules/2.6.11/kernel/sound/acore/snd-timer.ko): Invalid module format
WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.11/kernel/sound/acore/snd-page-alloc.ko): Invalid module format
FATAL: Error inserting snd (/lib/modules/2.6.11/kernel/sound/acore/snd.ko): Invalid module format
WARNING: Error running install command for snd
WARNING: Error inserting snd_timer (/lib/modules/2.6.11/kernel/sound/acore/snd-timer.ko): Invalid module format
FATAL: Error inserting snd_pcm (/lib/modules/2.6.11/kernel/sound/acore/snd-pcm.ko): Invalid module format
WARNING: Error running install command for snd_pcm
WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.11/kernel/sound/pci/hda/snd-hda-codec.ko): Invalid module format
WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.11/kernel/sound/acore/snd-page-alloc.ko): Invalid module format
FATAL: Error inserting snd (/lib/modules/2.6.11/kernel/sound/acore/snd.ko): Invalid module format
WARNING: Error running install command for snd
WARNING: Error inserting snd_timer (/lib/modules/2.6.11/kernel/sound/acore/snd-timer.ko): Invalid module format
WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.11/kernel/sound/acore/snd-page-alloc.ko): Invalid module format
FATAL: Error inserting snd (/lib/modules/2.6.11/kernel/sound/acore/snd.ko): Invalid module format
WARNING: Error running install command for snd
WARNING: Error inserting snd_timer (/lib/modules/2.6.11/kernel/sound/acore/snd-timer.ko): Invalid module format
FATAL: Error inserting snd_pcm (/lib/modules/2.6.11/kernel/sound/acore/snd-pcm.ko): Invalid module format
WARNING: Error running install command for snd_pcm
WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.11/kernel/sound/pci/hda/snd-hda-codec.ko): Invalid module format
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.11/kernel/sound/pci/hda/snd-hda-intel.ko): Invalid module format
FATAL: Error running install command for snd_hda_intel

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel onboard soundcard not working anothernixconvert Mandriva 2 11-29-2005 08:20 PM
Alsa problem, intel onboard Dagger907 Debian 11 10-21-2005 07:23 PM
the onboard Intel 82451G1 NIC of Dell SC 1425 install error on RedHat 7.3 and 9.0 lone168 Linux - Hardware 3 05-17-2005 02:10 PM
ALSA Problem with Intel Onboard Sound bjmurph Linux - Hardware 3 09-26-2004 06:38 PM
Slackware, AC97 onboard, VIA8233 - can't install ALSA - help please zerillos Slackware 5 07-15-2003 07:16 AM


All times are GMT -5. The time now is 02:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration